1. Are you ready for the Galaxy S20? Here is everything we know so far!
Thread Status:
Not open for further replies.

Custom recovery Optimus One P500/Thunderg

Discussion in 'Archived Threads' started by getitnowmarketing, Nov 18, 2010.

  1. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    Attached Files:

  2. dryhte

    dryhte Well-Known Member

    getitnowmarketing = drellisdee?

    If so, is this version identical to RC2 on XDA?

    If not, is this some sort of co-operation?

  3. dryhte

    dryhte Well-Known Member

    re: xda-developers - View Single Post - Section for the LG Optimus One P500

    Yup, that works fine.

    P500 Optimus One

    Thanks I'll update my script soon so other's that have enabled swap on sd can mass-storage mount sdcard in recovery untill then use the above commands if you have partitoned sd card for swap.
    divyanshu308 likes this.
  4. dwvenus

    dwvenus Lurker

    I have the new Verizon LG Vortex which I understand used to be the Optimus One. If this is correct, can I apply these root programs, etc for the Optimus One onto my Vortex? Thanks.
  5. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    You must use vortex recovery. You can use the enable jit one though. Diff devices.
  6. lgromb

    lgromb Lurker

    Where is the file "install-recovery.sh" adb returns me:
    mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
    failed on '/system/etc/install-recovery.sh' - No such file or directory

    I guess this is because the file "install-recovery.sh" is missing. Where can i find it ? And how do i put it in my Lg O1 ?
  7. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    You dont want that file there as it keeps recovery from "sticking" its not in all roms usually there ater you do an ota update. That command removes it. If its not there move on to next step.
  8. lgromb

    lgromb Lurker

    Thank you very much, problem solved :)
  9. Jamelly

    Jamelly Lurker

    How come I can't see the picture above when I do "reboot recovery" on CMD, and when I do Power + Vol. Down + Home key while off? Is there something I still need to do....?
  10. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    Did you flash it as per the entire instructions?
  11. SeerKan

    SeerKan Lurker


    Only one question before I do this: how do I get back to the original recovery ? Just in case I have to take the phone to waranty or something like that :)

  12. Jamelly

    Jamelly Lurker

    Nevermind, I installed it now on my phone. For backing up nand, do I need the phone to be USB plugged?
  13. death2all110

    death2all110 Android Expert

    No you do not. it goes to your sd card
  14. mysticgenius

    mysticgenius Lurker


    I tried this, but i get the warning

    "mount permission not granted"

    I have tried issuing the commands through ADB and through droid explorer.

    Im using win 7 x64.

    please can you advise...I have root access through z4root.


  15. Hi

    I followed these instructions and was able to flash 1.1 recovery image to LG OPTIMUS S.

    From adb shell, I was able to do reboot recovery and get to recovery menu and I was able to take backups successfully

    However, I am not able to get into recovery mode when I press Vol Down or Home Button during Power ON cycle.

    Is there a way to get into recovery mode during switching ON the phone

    Also, I tried to flash 1.2 version of this. I got bad mount sector error.

    1.1 works good, but cannot go into recovery mode during power ON.

    I just want to fix this before I flash custom ROM.

    Any help is appreciated.

  16. r0cc0

    r0cc0 Lurker

    Hello everyone, I wanted to know how to do a reset after putting the smartphone Custom recovery and jit.
    menu backup / restore you can do a reset to bring the smartphone to factory settings, keeping the recovery and jit

    Thanks to all for replies and sorry if the text is garbled, but I use google translator!
  17. mysticgenius

    mysticgenius Lurker

    Bump Bump,

    I have tried everything, I can run the mount command and this gives me output, but when i try to run:

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system

    I get mount permission denied

    I have tried to use root explorer to mount RW then i manually copyed in the flash_image which worked, I now have the flash_image in /system/bin/

    but when i issue chmod /system/bin/flash_image i get:

    unable to chmod /system/bin/flash_image : Operation not permitted

  18. orymd

    orymd Lurker

    When i try to restore a nandroid backup, the recovery says: run "nandroid-mobile.sh recovery" from adb... why? i can make a backup but i can't restore it... Wow :D
  19. magicknot

    magicknot Lurker


    After installing this and rebooting the mobile phone, I'm getting this message on the screen:

    Fastboot mode started
    -- suspend --
    -- reset --
    -- portchange --
    STALL GET_DESCIPTOR 128 6 3840 o 5
    fastboot: processing commands

    What am I supposed to do now?

    Thanks for the helping
  20. salte_eskil

    salte_eskil Lurker

    same problem for me as for magicknot :( followed the instructions but ended up with fastboot mode on boot and nothing happens. please help (a)
  21. rakesh_4utoo

    rakesh_4utoo Lurker

    Same problem with me also ,i think i bricked my device,plsease help me
  22. skycat61

    skycat61 Lurker

    I had problems with restoring from backups with message

    run "nandroid-mobile.sh recovery" from adb"

    but when I did this the script complained that it could not mount the sdcard.

    It turns out that my sdcard was formatted with no partitioning and hence incorrect partition names were being used in the script.

    The solution was:-

    1. save the whole contents of the sdcard on my PC.

    2. repartition the sdcard, using either the recovery program's built-in tools or a linux box with an sdcard adapter (don't forget to format your partition if going the linux route).
    You will want a FAT partition for your storage, an ext2 partition for later use by app2sd, and some swap space too. I also added via linux a fourth partition for the debian linux distribution at some point. :)

    3 Add your saved data back to the card.

    3. reboot recovery mode with the new sdcard and and you should now be able to restore backups.
  23. Siddhesh222

    Siddhesh222 Lurker

    Doesn't work for me, I did everything as mentioned, but it opens up a LG recovery ( I think) which asks me to set Language,date etc :/ and all my apps and stuff is gone :/.What is this, can someone help?
  24. angel_garcia

    angel_garcia Lurker

    Hi, I have problems making the recovery, here's how I did it if anyone knows where I could be wrong:

    z4root.1.3.0.apk I installed the file and I run, it has created the icon z4root "I opened and I put" Permanent Root "with prior activation of" USB debugging "because it will not let me root , while doing the "Permanent Root" the terminal rein) and after reinciciar I turn to get into the "z4root" and verify that this root because it makes (your device is Already rooted) in the notifications I get (# superuser z4root Superuser Has Been Granted permission), also has created an icon called "superuser" when you open this program "z4root" I select and I put afford. Having done all this I run the program "Terminal Emulator" and putting the first two lines I get the following in the mobile:

    $ # mount-o remount, rw-t yaffs2 / dev/block/mtdblock1 / system

    $ cat / sdcard / flash_image> / system / bin / flash_image

    cat / sdcard / flash_image> / system / bin / flash_image: Operation not permitted

    If I put the # on each line as shown below do nothing:

    $ # mount-o remount, rw-t yaffs2 / dev/block/mtdblock1 / system

    $ # cat / sdcard / flash_image> / system / bin / flash_image

    $ # chmod 755 / system / bin / flash_image

    $ # mv / system / etc / install-recovery.sh / system / etc / install-recovery.sh.bak

    $ # mount-o remount, ro-t yaffs2 / dev/block/mtdblock1 / system

    $ # flash_image recovery / sdcard/recovery-RA-GNM-thunderg-1.1.0.img

    $ # reboot recovery

    I sorry, my English is very bad, I translated with google translator.
  25. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    Dont type the "#" thats just the cursor prompt showing you have a root # shell not a user $ shell. To change the $ to # you have to type su first.

    angel_garcia likes this.

Share This Page