1. Are you ready for the Galaxy S20? Here is everything we know so far!
Thread Status:
Not open for further replies.

Custom Recovery Optimus V

Discussion in 'Archived Threads' started by getitnowmarketing, Feb 6, 2011.

  1. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    Attached Files:

    1. Download the Forums for Android™ app!


  2. jntdroid

    jntdroid Android Enthusiast

    any particular reason my phone would NOT have the install-recovery.sh file? this is the file that restores stock recovery after a reboot, right? (and possibly removes root?)

    i just rooted using these instructions, and that's all i've done... i've searched everywhere with root explorer and can't find that file (or anyone like it) anywhere
  3. jntdroid

    jntdroid Android Enthusiast

    i went ahead and finished the instructions since that step simply renames the file, and it works fine, but still i wish i knew why my phone didn't have that file...
  4. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    That file (install-recovery.sh) only exists after an OTA update.
    FybrOptx likes this.
  5. jessebwallace

    jessebwallace Lurker

    Hey, saw your post on XDA.
    Sorry that you weren't credited.
    I'm gonna try and root tonight, and have downloaded from this source.
    Buying you a drink, too!
  6. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    Thanks a lot. In these tough times it really helps.
  7. FybrOptx

    FybrOptx Lurker

    So it's nothing to freak out about then? If not, sweet! You rock! Bought mine today, activated it about an hour ago and decided to root and install the recovery.
  8. dinlaca

    dinlaca Newbie

    Just donated. Thanks for the great work.

    Any plans to update recovery with additional functionality now that Optimus V source has been released? Thanks for letting us know.
  9. jntdroid

    jntdroid Android Enthusiast

    thanks for the info... a few drinks headed your way - the money i save by having this phone vs. a droid x or incredible, or whatever, and being able to play with it like i could play with those, thanks to guys like you, is easily worth a few drinks!
  10. jntdroid

    jntdroid Android Enthusiast

    Hey another quick question...

    I'm replacing my wife's OptV, and on her old one, I'm trying to revert everything back to stock, including the recovery. However I'm stuck. I can't get the phone to boot beyond thunderc... no matter what I do, when I power down, reboot, battery pull, etc. - it goes right back into thunderc.

    How did I get here? Well, I uninstalled Superuser and did a factory data reset - forgetting about the custom recovery, like a dummy... It then booted into thunderc, wiped data/cache, and now I'm stuck. I've tried restoring a nandroid from another thread, but it didn't work. I have a recovery.img (supposedly stock) and flash_image on the sd card, but can't seem to get the right ADB code to work simply through thunderc (I'm no ADB expert, but semi-familiar).

    I'm searching but no luck so far...
  11. lowtolerance

    lowtolerance Lurker

    In the "Flash zip from SDCard" menu, I can't seem to scroll the directory listing. I can move the selection bar up and down the list of presented directories, but I can't see directories past what is displayed initially. Am I doing something wrong, or is this a bug?
  12. brian417

    brian417 Lurker

    I'm having the exact same problem. I have rodimus.zip on the sd card but i can't scroll past all my music folders to get to it. seems to be a bug. will try with a different sd card that only has the rodimus.zip on it.
  13. zerovgs

    zerovgs Lurker

    in your walkthrough:

    flash_image recovery /sdcard/ recovery-thunderc-v-1.2.0-GNM.img

    should be:

    flash_image recovery /sdcard/recovery-thunderc-v-1.2.0-GNM.img

    The extra space wouldn't work for me so I got it through trial and error.
  14. FuzyBaffy

    FuzyBaffy Newbie

    I installed thunderc-v-1.2.0 for optimus v and flashed a couple of custom roms. No big issues. I finally went back to my first original nandoid backup I made right after flashing this recovery.

    I was having issues with the data dropping constantly and so I went to the phone's normal android settings menu and under security told the phone to wipe all data. Not in your recovery under the normal android settings security menu, which I had used before I had rooted my phone and it worked fine.

    Now the phone keeps on booting to the thunder optimus v 1.2 recovery. I tried flashing to a stock nandroid backup I found, it flashes but goes back to thunder rec. I flashed to the nandroid backup I had previously made and tested working previously, loop to thunder recovery. Everything keeps on going to the thunder boot recovery.

    Can anyone help or recommend another thread to post in? I see other threads along the same line as my issue with no solutions other than to return the phone. My phone is over 30 days old so I am screwed. Funny thing is I was basically running stock just wanted to remove the crapware installed and get access to my titanium backups from my old phone :(

    I see some mention of the KDZ updater to unbrick but I don't believe there is an optimus v image available?

    I had a stock rom and when you wipe from the menu it must flip a flag on the bootloader or something. This Recovery dosn't flip that "Flag" to done after it has wiped in recovery. Thankfully this recovery has ADB and I just flashed a stock rom and manually pushed the stock recovery which stopped the boot loop. Not sure why there is a radio flash warning above and not a wipe warning.
  15. ashton4life

    ashton4life Newbie

    Hello everyone, I just bought the Optimus V from Virgin Mobile and love it. The problem I'm having is that when I went into the system recovery mode (Home-Vol Down-Power) it only gives me 4 options, reboot system now, apply sdcardupdate.zip, wipe data/factory reset and wipe cache partition. I dont have any option to back up to SD. Any ideas or options I've missed?

  16. gerbetta33

    gerbetta33 Member

    I have the same issue. All I want to do is get cyanogenmod 7 on my optimus v, and I have all of the downloads, but I can't figure out how to get custom recovery
  17. joaquinrivero

    joaquinrivero Lurker

    My android has died, when the installation finished, when reboot starts:
    I was waiting arround 30 minutes and dont anything, now i can't acces in recovery mode nethier OS.

    HELP! :eek:
  18. kane0187

    kane0187 Lurker

    I've rooted my phone. Super User says its all fine, no errors. So know I'm trying to get this new ROM to overclock but every time I try to follow these instructions it either says flash_image is a read only file when I try to use the terminal emulator or if I use cmd prompt it says permission denied....:mad:
    cat /sdcard/flash_image > /system/bin/flash_image I can't get past that. I have both files in the root directory of my sd card. I don't know where to go from here??? If you could give me any suggestions I would really appreciate it :)
  19. getitnowmarketing

    getitnowmarketing Android Enthusiast
    Thread Starter

    Updated directions
    kane0187 likes this.
  20. kane0187

    kane0187 Lurker

    Thank you for the quick response but I'm still having the same issues. With terminal and from cmd prompt(Using superoneclick to gain access hope thats what I'm supposed to use) but when I put the commands in its still the same even when I try 'su'. The only way I can get past the first part was if I added a '.zip' to the end of flash_recovery but I'm assuming thats not right either lol because I get to where I got to flash_image recovery /sdcard/recovery-thunderc-v-1.2.0-GNM.img and I either get a syntax error or permission denied when I add the '.zip' to the end of flash_image. I'm stumped. When I use the terminal emulator and put in 'su' the phone notifies me that it got permission granted but doesn't do that from the comp.
  21. veezy

    veezy Lurker

    Can u update the instructions and tell us how to do it starting ALL THE WAY from plugging the phone into your computer, I'm a noob and this is very confusing the CMD doesn''t find anything you tell me to type in! :(
    dcannoli likes this.
  22. talibith

    talibith Lurker

    Thanks so much! I thought I was about to brick my phone. lol. Praise the lord!
  23. moonmang

    moonmang Lurker

    I am getting "invalid length" when running
    cat /sdcard/flash_image > /system/bin/flash_image
  24. iiturnull

    iiturnull Lurker

    This... I am in the exact same boat as this guy. I can't get it to do what the instructions say from the terminal. I don't know what directories I should be started from, whether or not the phone should be in debugging mode or storage. Need some more concise step-by-step please.
  25. CuriousNoob

    CuriousNoob Android Enthusiast

    export PATH=/data/local/bin:$PATH
    $ $su
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system
    #cat /sdcard/flash_image > /system/bin/flash_image
    /sdcard/flash_image: invalid length

    This is what I get. Any suggestions? I have the flash_image unzipped that I extacted and same for the recovery file. I use terminal emulator on The optimus V. Please help, I don't know what this means.

Share This Page