1. Are you ready for the Galaxy S20? Here is everything we know so far!

Customising LowBattery.ogg

Discussion in 'Music & Media' started by mattyjim, Sep 2, 2011.

  1. mattyjim

    mattyjim Lurker
    Thread Starter

    Hello!


    I'm trying to customise my low battery notification (on Samsung Galaxy S, running CyanogenMod 7), but there seems to be something weird going on with the .ogg that I'm using.

    Here are the steps that I've taken so far (I'm using Windows 7 x64 to do the .mp3 -> .ogg conversion by the way, just in case it makes a difference):

    1. Convert an .mp3 to .ogg (I've tried this using Switch and Goldwave so far), and rename it to LowBattery.ogg

    2. Rename the current LowBattery.ogg (at \system\media\audio\ui) to LowBattery.ogg.bkp (I know about using root explorer and mounting as r/w, etc)

    3. Paste my new LowBattery.ogg into \system\media\audio\ui

    4. Reboot my phone


    ...but no joy :(


    I've tried doing the same thing with the Lock and Unlock sounds (so that I don't have to wait for my battery to run down ;)), but that doesn't work either.


    A couple of things that I've noticed when I've been looking around though:

    1. If I try to play my new LowBattery.ogg file (manually, by tapping on it) when it's actually in the ..\audio\ui folder then I get an error message (can't play this file type), but if it's just on the root of my internal SD card then it plays fine

    2. If I inspect the file details of my new LowBattery.ogg file when it's actually in the ..\audio\ui folder then I can see:

    MIME: application/octet-stream
    MD5: computing...

    3. If I inspect the file details of my new LowBattery.ogg file when it's on the root of my internal SD card, I can see:

    MIME: application/ogg
    MD5: <there's a big long MD5 hash here>




    There's something going on here that I don't understand, I think :thinking:


    Can anybody tell me where I might be going wrong?



    Any help would be greatly appreciated :)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mattyjim

    mattyjim Lurker
    Thread Starter

    Just in case anyone else experiences this issue: it looks as though there was a permissions issue.

    I've no idea whether it was the fact that I converted into .ogg using Windows, or whether it had something to do with the converter that I used, but I opened my new LowBattery.ogg file (using an app that has root explorer functionality, etc) and saw that only 'Owner: Read' permission was granted.


    I changed the permissions to match the other files in the ..\UI folder.......

    Owner: Read Write
    Group: Read
    All: Read


    .......and now everything works!! Whoo! :D



    Maybe this info will come in handy for someone else.
     
Loading...
Similar Threads - Customising LowBattery ogg
  1. ShamusVW
    Replies:
    3
    Views:
    952

Share This Page

Loading...