1. Check out our companion app, Forums for Android! Download from Google Play

Support D3 wifi issue...connects but no internet.

Discussion in 'Android Devices' started by Frinkiac, Nov 28, 2011.

  1. Frinkiac

    Frinkiac Member
    Thread Starter

    Nov 28, 2011
    Hello all,

    I've tried searching for a thread that addresses this specific issue, but haven't found one.

    Recently acquired D3, rooted it and everything has been working fine. Initially, I could connect it to the home wifi network and it worked just fine.
    Pretty quickly after I got it and rooted it (not sure if the problem is related), the issue kept coming up that I could connect to the home wifi network but not get on the internet or any apps that use internet. I took it to another place and entered the password for that wifi network, same result...it will connect me to the wifi network, wifi icon comes on and bars turn blue, but it can't get actual internet access.

    Occasionally, when I delete all data settings from Dolphin browser and forget/re-enter the network, and then start up the browser again, it will give me approximately 10 seconds of internet. I can get to Google homepage and maybe the news page if I'm quick.

    I've tried manually resetting the router, forgetting and re-entering the wifi information on my phone a million times, changing the advanced wifi settings to enable auto IP, and nothing works. The best I can get is that tiny window of actual wifi internet time when I forget/relearn the network and enter my browser after having deleted all browser data.

    Any tips on what to do to get full internet back on wifi? And any idea what's causing it? The fact that I can get a few seconds of internet via wifi shows me that I might not be far off, but then again I am stumped as far as what to do next.

    Any advice is really appreciated.


  2. TyrannoTaurus

    TyrannoTaurus Well-Known Member

    Sep 10, 2011
    Northern Illinois
    That happened once on my D3, but it went away when I turned-off and rebooted the phone.
  3. Demonpiggies

    Demonpiggies New Member

    Aug 8, 2011
    Rhode Island
    If it's password protected, make sure you use all caps. When I had set up my router, everything except my Droid would connect correctly. The phone said it was connected but no internets. I reentered with all caps and it connect fine after.

    If your connection is open (phone sees it as connected but you can't get online) then your router may be blocking your phone's connection. I'm more hard-pressed to say it's some setting or misconfiguration on the Droid but routers have weird options now-a-days.

Share This Page