1. Are you ready for the Galaxy S20? Here is everything we know so far!

data/aacdump (Netflix)

Discussion in 'Android Devices' started by sbdc003, Jan 5, 2014.

  1. sbdc003

    sbdc003 Android Enthusiast
    Thread Starter

    Hi guys & gals,

    Has anyone noticed that Netflix creates a huge aacdump file?

    Here is an example.

    Before watching a movie

    System data: 80.4MB
    Free space: 1579MB

    [​IMG]


    After watching one TV episode

    System data: 660MB
    Free space: 998MB

    [​IMG]


    When I wasn't rooted, there was no way to retrieve free space without factory reset and I got sick of resetting my phone every time I watched movies, so I quit using Netflix.

    My phone (OOTB JB) was rooted a few months ago, but I had not used Netflix until recently as I was too lazy to find out what's taking up space in System data.

    Well, it's a new year and I'm a movie buff. So, I decided to find out what's going on.

    It looks like Netflix creates an aacdump file as shown in the screenshot below. Now, I can just delete it every time I use Netflix.

    [​IMG]


    I was a bit surprised that no one has really talked about this issue.
     


  2. db2

    db2 Android Enthusiast

    My available space dwindled to tens of megabytes, so when I found that file was the culprit I deleted it and put a blank one in its place with no write permissions. I don't recommend doing that because now Netflix doesn't work.

    What an annoying thing. More annoying though is Netflix on my TF101 doesn't do that, the file isn't there at all.
     
    sbdc003 likes this.
  3. db2

    db2 Android Enthusiast

    I tried the following:

    Code (Text):
    1. touch /storage/extSdCard/aacdump
    2. su
    3. cd /data
    4. rm aacdump
    5. ln -s /storage/extSdCard/aacdump .
    Same result as when /data/aacdump was read only. The next thing I'm going to try is formatting a microsd card (that's card, not internal storage) to ext2 and setting the permissions of extSdCard/aacdump the same as /data/aacdump to see if that gets it working. The idea there is that having the actual file I'm linking to on a FAT partition with no real permission support is messing it up somehow.
     
    sbdc003 likes this.
  4. sbdc003

    sbdc003 Android Enthusiast
    Thread Starter

    Thanks for the reply and update.

    Deleting aacdump worked for a while, but you are right. Netflix stopped working the other night. So, I restarted my phone and that temporarily solved the problem even though I had to sign-in again.

    It's very odd. I wonder if it's a Samsung thing.
     
  5. db2

    db2 Android Enthusiast

    Not sure, but my last attempt seems to have met with success. There are more steps than anticipated, but a bonus that makes it worth the effort. Just in case I'll say if you're not rooted this will not work.

    First back up your microsd contents and partition/format it so the first partition is FAT and the second is ext2 (NOT ext3 or ext4, those journal and kill your sdcard). Both should be primary partitions, not logical. As far as sizes I did 10GB/6GB. The phone will automount the FAT partition so put your stuff back on there. The ext2 partition it will ignore, which is where Link2SD comes in to play.

    Start up Link2SD, it will do its startup thing, ask for root rights (grant it obviously), then ask what the format of the second partition is. On mine ext2 was already selected but make sure just in case. It'll do its thing again then ask to reboot, go ahead and hit the reboot button.

    When the phone is done booting it'll look like nothing happened which is just fine. If you want you can open up Link2SD at this point and link your largest apps to free up some internal storage (this is the bonus I mentioned)... filter the list by what's "internal" to make it easier to see. I freed over 100MB moving a few apps just as a test to make sure it worked and it did.

    Start Netflix and watch something for a couple minutes to make sure /data/aacdump is created.

    Now what you want to do is this in a terminal (you need a terminal app):

    Code (Text):
    1.  
    2. su
    3. cd /data
    4. cp aacdump ./sdext2
    5. rm aacdump
    6. ln -s /data/sdext2/aacdump aacdump
    7. chown media.system ./sdext2/aacdump
    8. exit
    9. exit
    10.  
    This symlinks aacdump, which now resides on the ext2 partition of the microsd card, to the place Netflix expects it to be. All the actual data will go to the microsd card instead now and Netflix won't know the difference.

    note: I did this with a 16GB card. It wouldn't be worth doing with a card you can't have at LEAST a 4GB ext2 partition on IMO. If you only have a 1 or 2GB card then this would be a pointless exercise for you though, get a bigger card first.

    Followup: Five hours and all is well. This works. Unrelated to Netflix/aacdump, do not use Link2SD's "integrate" function... I broke Chrome hard trying it.
     
    sbdc003 likes this.
  6. sbdc003

    sbdc003 Android Enthusiast
    Thread Starter

    Very clever!

    BTW, watching YouTube videos afterwards has made the size of aacdump smaller (7~12 MB) somehow. Odd.
     
  7. loonycgb2

    loonycgb2 Android Enthusiast

    Netflix and youtube use decoding software to produce videos so they dont get the movies stolen or illegally copied.

    aacdump is the actual video you are watching in a dumped readable format. If you make it read only you will not be able to decode the movies to watch.

    using link2sd to make netflix be put on sdcard will make the dump file be created on the sdcard instead.
     
  8. db2

    db2 Android Enthusiast

    Why doesn't this happen on my TF101 I wonder? Everything works fine but there's no giant blob of video data hanging out in my storage.
     

Samsung Galaxy Reverb Forum

The Samsung Galaxy Reverb release date was December 2012. Features and Specs include a 4.0" inch screen, 5MP camera, 768GB RAM, Snapdragon S2 processor, and 1700mAh battery.

December 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...