1. Download our Official Android App: Forums for Android!

Support Data connection in skyrocket

Discussion in 'Android Devices' started by modijay, Jan 5, 2012.

  1. modijay

    modijay Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 5, 2012

    Jan 5, 2012
    1
    0
    5
    Hi,
    I hv just started using Samsung Galaxy S2 Skyrocket and each tym my cell is locked ,the data connection is lost ,due to which i cant receive any messages on whats app
    ..pls provide wid a solution
     

    Advertisement

  2. nyydynasty

    nyydynasty Android Expert
    Rank:
    None
    Points:
    103
    Posts:
    956
    Joined:
    Sep 13, 2010

    Sep 13, 2010
    956
    173
    103
    Male
    IT Manager
    NY
    Do you have an app like Juice Defender? The lock screen should not be disabling your data connection since there is no setting for that. It CAN turn off your wifi connection (thats in the wifi settings menu) but then 3G/4G should take over when wifi gets turned off.

    If you have Juice Defender, you need to modify the settings because that app is whats killing your 3G/4G connection.

    edit: just remembered that the skyrocket also has a power saving mode. It might be that if you have it enabled

    edit #2: just saw that lunatic beat me to my previous edit :)
     
    Showme and modijay like this.
  3. EarlyMon

    EarlyMon The PearlyMon
    VIP Member
    Rank:
    None
    Points:
    5,218
    Posts:
    57,631
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    57,631
    70,445
    5,218
    New Mexico, USA
    Welcome to the forums!

    I've moved your question to the Skyrocket support area. I am hoping that other Skyrocket owners can chime in if it is a configuration issue or something like that.

    If you have any trouble, click on my name and send me a private message.

    But I'm sure that the helpful cats here will have you squared away in no time.
     
    modijay likes this.
  4. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #2
    Points:
    4,238
    Posts:
    37,112
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    37,112
    35,689
    4,238
    Male
    IT
    Pennsylvania
    If you go to menu>settings you should see 'power saving mode'. See if you have your phone set to turn off all the radios when it sleeps.
     
    Mr. Ed likes this.
  5. clubtech

    clubtech Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 21, 2010

    Jan 21, 2010
    10
    0
    15
    I opened a thread about this over at XDA and i think this is also the issue you are having:
    Constantly getting disconnected from Google servers on LTE - xda-developers

    Are you located in CA by any chance? I think that all the people who complained about this issue are from CA so far.
     
  6. Showme

    Showme Newbie
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    28
    5
    16
    Gulf Coast of Texas
    Sorry to butt in but I just wanted to say that I also was having connection issues after my phone screen would time out and go to sleep. Each time I would have to go to the Mobile Network setting and re-check Use Packet Data to connect.

    I checked the Power Saving Mode and found nothing useful so I uninstalled Juice Defender because I could find no setting that indicated the network would be disconnected after any set time or event.

    Everything works again and I have 4g LTE showing again except when I am connected to the home wireless network with WiFi.

    Thanks for posting the info to help me out.
     

Share This Page

Loading...