1. Are you ready for the Galaxy S20? Here is everything we know so far!

Data connection not working

Discussion in 'Android Devices' started by qwerty2222, Sep 19, 2011.

  1. qwerty2222

    qwerty2222 Lurker
    Thread Starter

    Hello,

    I recently upgraded to a HTC Desire S and have had some problems with my mobile internet.

    I can connect to the data network (H/3G/etc) fine and have good signal levels, but when it does, only the up arrow flashes and nothing internet based will work. The phone works fine when connected to wifi.

    I am on T-Mobile (UK) and the pre-loaded APN settings are correct according the support website, I have also tried variants of the T-Mobile APN settings found on the internet.

    In the Testing menu under Phone information it says PPP Sent: *number of pkts* but PPP received: 0 pkts

    Every time I connect to the mobile internet the up arrow will flash repeatedly but no data seems to be received. No webpages or anything else will load.

    I tried a factory reset a few days ago which seemed to do something (some data was received and both the data arrows were flashing) but this soon reverted to the problem state.

    My mobile internet works fine on when I put my SIM in my old phone so I am fairly sure its not a SIM/account issue.

    Has anyone else had/fixed this issue?
     

    Advertisement

  2. notebook

    notebook Android Enthusiast

    This might be worth a try.

    Other than that, call T-Mobile as they should be able to send you their current APN settings to your phone and run some remote tests.

    If it's an old SIM, it may need updating or exchanging for a new one.
     
Loading...
Tags:

Share This Page

Loading...