1. Download our Official Android App: Forums for Android!
  2. We apologize for the disruption in email services! They are sending out now, but there is a backlog, so it may take a little time to catch up.

Support Data Connections sleep - Screen Off

Discussion in 'Android Devices' started by NaNaNiii, Mar 17, 2013.

  1. NaNaNiii

    NaNaNiii Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    42
    Joined:
    Jan 8, 2012

    Jan 8, 2012
    42
    6
    16
    Hi, Data connections (Wifi + 3G) go to sleep whenever the screen is off for more than a couple of minutes and only reconnect when screen is turned back on again, which is annoying because push notifications don't come through. Power saver is turned off and this only recently started happening out've the blue. Is there anyway to fix this? Thanks
     

    Advertisement

  2. NaNaNiii

    NaNaNiii Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    42
    Joined:
    Jan 8, 2012

    Jan 8, 2012
    42
    6
    16
  3. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,501
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,501
    22,914
    3,118
    Scotland
    It's not anything to do with the JB power saver options is it?
     
  4. NaNaNiii

    NaNaNiii Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    42
    Joined:
    Jan 8, 2012

    Jan 8, 2012
    42
    6
    16
    The option for " Data Connection - Put to sleep when screen is off" is unchecked
     
  5. GuitarG20

    GuitarG20 Clueless Senior Member
    Rank:
    None
    Points:
    253
    Posts:
    2,067
    Joined:
    Jun 23, 2012

    Jun 23, 2012
    2,067
    972
    253
    Male
    Texas
    I'm assuming you don't have any apps that are supposed to do this installed/running? (juice defender, deep sleep, etc.)
     
  6. NaNaNiii

    NaNaNiii Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    42
    Joined:
    Jan 8, 2012

    Jan 8, 2012
    42
    6
    16
    Yup, had deep sleep installed but removed after a day or so
     
  7. benitorios

    benitorios Member
    Rank:
     #1,240
    Points:
    18
    Posts:
    66
    Joined:
    May 8, 2010

    May 8, 2010
    66
    15
    18
    In addition to turning off the option "Put to sleep when screen is off" in the Power saver, also make sure that your Wifi is otherwise set to permanently on during sleep:

    Settings > Wi-Fi > Menu, Advanced > Check option "Always" under Keep Wi-Fi on during sleep.

    That, in combination with the unchecked option for putting to sleep in power saving mode, should keep your Wi-Fi running (I do this regularly for Play Store updates, etc. and they're fully downloaded when I wake the screen later)

    I don't know about keeping 3G on at all times, though.
     
Tags:

Share This Page

Loading...