1. Download our Official Android App: Forums for Android!

Support Data sometimes turns off -- why?

Discussion in 'Android Devices' started by CharlesLewis, Sep 17, 2011.

  1. CharlesLewis

    CharlesLewis Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    199
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    199
    8
    36
    Sometimes, not always, when I try to access data over the 3G network, I discover that the "Data Enabled" setting is not checked. If I go under settings and check it, all works as it should. I can't figure out, though, what is turning it off. I suspect it is happening when I have WiFi enabled and move to an area where WiFi is not available. Normally, the 3G connection automatically turns on, but as I said, not always.

    Does anyone have an idea what might be causing this strange behavior, and more importantly, what I can do to eliminate it? I am running Green Power and Juice Defender, so it's possible a setting there might be relevant, though I don't know what.

    Hope you can solve this minor irritation.
     

    Advertisement

  2. Saltine713

    Saltine713 Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    690
    Joined:
    Sep 7, 2010

    Sep 7, 2010
    690
    55
    98
    Podcaster
    NY
    I really don't think those apps do anything special. It could be they are causing the issue, or that your data will turn off if there is not enough service?

    What phone and carrier do you have?
     
  3. CharlesLewis

    CharlesLewis Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    199
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    199
    8
    36
    Droid X / Verizon. I don't think the service is the issue, since it happens at home when I know the connection should be good.
     
  4. Saltine713

    Saltine713 Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    690
    Joined:
    Sep 7, 2010

    Sep 7, 2010
    690
    55
    98
    Podcaster
    NY
    Well since I have an HTC phone, I'm not too sure of the settings on your phone, but go to:

    Settings---Wireless and Networks--- in there, there should be options for mobile internet always on.

    Also, it could be that you have the wifi takeover setting on, so whenever Wifi detects an open network, it shuts off the data and turns on Wifi.

    Otherwise, it could be one of those apps. Check their settings and see if they are allowed to change the settings for data.
     
    CharlesLewis likes this.
  5. RyanB

    RyanB Guest
    Rank:
    None
    Posts:
    0
    Joined:

    OP: have you checked which battery mode you are using?
     
    CharlesLewis likes this.
  6. CharlesLewis

    CharlesLewis Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    199
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    199
    8
    36
    On the Droid, I don't see that option there. Under Wireless and Networks, I have Airplane Mode, WiFi settings, Bluetooth settings, Tethering, VPN settings, and Mobile networks. Under the last, I have system select with two options: Home only and Automatic. I assume Automatic is the correct one.

    Under Battery and Data Manager, I have Data Delivery with three options: Background Data (on), Data Roaming (off), and Data Enabled (on). That last is the one that sometimes gets turned off without any reason that I have been able to determine.
     
  7. CharlesLewis

    CharlesLewis Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    199
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    199
    8
    36
    Maximum battery saver. The information for that setting is "While phone is not connected to a charger, stops syncing data after 15 minutes of inactivity. Dims the display."

    When all is working right, I might not have a data connection when I first try to make a connection, but it turns on after a few seconds. When all is not working right, it doesn't ever turn on until I go into settings and re-enable it.
     
  8. CharlesLewis

    CharlesLewis Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    199
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    199
    8
    36
    No, I normally have to switch on WiFi; otherwise, the default is 3G.

    Green Power shows "Not managing WiFi and Mobile Network". Juice Defender is not a running app, so I apparently turned it off, though the app is still on the list of available apps.

    Thanks.
     

Share This Page

Loading...