1. Are you ready for the Galaxy S20? Here is everything we know so far!

Default Home Launcher Won't Save...HELP!

Discussion in 'Android Devices' started by jboku, Dec 3, 2013.

  1. jboku

    jboku Member
    Thread Starter

    Okay, I am at my wits end and Google has yielded no helpful results so I am hoping the android community here can come through...

    Phone: Note 3
    Android Ver: 4.3
    Rom: None (Stock).

    Rooted: No

    My home launcher (Currently Nova Prime) will NOT save even though I say "Always" when it prompts me to complete the action using...

    When the Issue started:
    About 1 week ago out of no where (I had been using Nova Launcher Prime for at least a month).

    What Causes it:
    1 - Anytime I first turn the phone on from "sleep" (turning the screen on)
    2 - Every time I load up google now and press "Home".

    Right now my phone screen is off, when I turn it on and unlock it after its been "asleep" and I press the "home button" on my Note 3, it asks me which launcher I want to use, I select "Nova Launcher Prime" and say "Always use this". From then on it works fine UNTIL I either load up Google Now or turn my screen back off by tapping the power button. At that point, it will once again ask me "Complete action using...".

    What I've tried:
    1. I've gone into Nova Settings and made sure Nova was selected as the default launcher.
    2. I've tried using other launchers (including the stock touch-wiz) and it does the same thing.
    3. Uninstalled / Re-Installed Nova
    4. Cleared the Cahce / Stopped the launchers (Touch-Wiz, Easy Touch Wiz, and Nova) in apps manager.

    The only other "solution" I've found by googleing is to clear the dalvic cache which I cannot do since I am not rooted (but I am strongly leaning that way if it will fix this ANNOYING problem). Can anyone, please anyone help me with this?


    1. Download the Forums for Android™ app!


  2. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    Hey there, jboku. Sorry you're having such an annoying problem!

    I think this might get better help in the Note 3 forum, so I'm moving it over there.
  3. Rukbat

    Rukbat Extreme Android User

    If you boot into recovery (Volume Up, Home and Power - you'll see a tiny blue message in the top right corner - let the buttons go), you can wipe device data and device cache.
  4. jboku

    jboku Member
    Thread Starter

    Will this wipe my phone memory so I will need to re-download all my apps and lose all my pics / movies?
  5. BlueBiker

    BlueBiker Android Expert

    The Google Now / Home button thing is a known bug. Sorry, I don't remember which Note 3 forum thread it was reported in.
  6. FBA

    FBA Newbie

    Yup, I read that yesterday. I don't use Google now, or Google plus or any of that shit, so I don't see the issue on mine using Nova.
  7. drexappeal

    drexappeal Extreme Android User

    KOLIO likes this.
  8. jboku

    jboku Member
    Thread Starter

    I apologize for the confusion. When looking this up I found out there are others with many different types of Android phones that have the same problems with other launchers so I posted this in the general discussion area and a mod moved back to the note 3 area. I was just hoping someone somewhere had a way to fix this because having a phone that constantly ask you to change your default home launcher is extremely annoying.

    On a side note I have noticed my phone is asking me to change defaults on a lot of applications I had already set to default such as Google Chrome. However they do not continue you ask me to make the default.
    dustwun77 and BlueBiker like this.
  9. BlueBiker

    BlueBiker Android Expert

    Oh too funny, I wondered how that happened. So it's not a Note 3 problem, it's more widespread. That's good from our perspective, increases the chance that it'll get noticed and fixed.

    BTW, I was going to mention that your first post above is exceptionally well organized and helpful for any developer investigating the problem. Suggest you consider software Q/A for a profession!
  10. jboku

    jboku Member
    Thread Starter

    If anyone is interested, I have decided to wipe my device and in the process root it. I am going to do this tomorrow and will let you know if this fixes the problem (which is should -- just an extreme solution for what seems like a simple problem).
    dustwun77 likes this.
  11. KOLIO

    KOLIO Guest

    How about just trying a cache wipe first (root is NOT required):


    If that doesn't work,check some of your developer settings (if you've been in that part of the phone).

    Then scroll down until you see the APPS section.Make sure the DO NOT KEEP ACTIVITIES BOX is unchecked.

    Not sure if this would cause defaults to be lost/unkept,but,I'd start w/these two choices before going w/the Factory Reset.

    Rooting in of itself is not going to solve this.I'd try some of the home launcher selector apps in the GOOGLE PLAY STORE as well before going down the Factory Reset Route,should the above not help.
    Digital Controller and BlueBiker like this.
  12. juniortrd

    juniortrd Lurker

    I had this same problem, and I just restarted my phone and now Nova Prime remains as the default launcher.
  13. Digital Controller

    Digital Controller The Real Bass Creator

    I would definitely suggest against the root right now with all the stuff with knox going on and the root methods being hit or miss right now.

    I like KOLIO's idea.
  14. jboku

    jboku Member
    Thread Starter

    Thank you for these tips. I tried them but still the same problem, and since it's a note 3, not only does it ask me to save it every time, it then tells me to go to task manager to clear all defaults if I want to (which I tried once just to see if it fixed it -- it didn't). It shows up as the default in there though :/.

    I figure if I have to wipe my phone (only option seems viable at this point) why wouldn't I root it too? It's become so annoying I don't even like to use my phone anymore.
  15. jwither

    jwither Android Enthusiast

    Please don't wipe anything before you use the function in Nova to back up your home screen settings to a file. Then uninstall nova/reboot/reinstall/restore (import from backup file).
  16. jboku

    jboku Member
    Thread Starter

    Thanks, I have already made a backfile and will copy it to my computer. I think for now I will just factory reset it and hope that fixes the issue.

    On a side note, If I go to Task Manager > Clear Defaults > I see it keeps being removed from there somehow. I don't know why it wont stick.
  17. drexappeal

    drexappeal Extreme Android User

    I even tried replicating your issue, going from Google Now and using the home button to back out and couldn't.
  18. jboku

    jboku Member
    Thread Starter

    FIXED!!!!!!!!!!! And I didn't need to root or re-flash to factory defaults.

    I Uninstalled the last few apps I had installed on my device (they were free bongo / drum apps) and guess what? FIXED! I don't know how one of these apps caused this to happen, but I am glad it's fixed. Thank you all for your support :).
  19. DonnieSue

    DonnieSue Lurker

    I know I'm a little late to the party but I was able to resolve my issue with TouchWiz continually asking me to choose my default. Super simple, can't believe I didn't notice this before. In settings, go to application, default applications, then click on Home under set defaults. Choose TouchWiz home and then push your home button. Say always and ok. This is the part I kept missing. I just wasn't reading the popup. So far, so good.
    Lanaew79 likes this.
  20. TommyB1088

    TommyB1088 Lurker

    I am also a bit late here but you must FIRST make sure you delete any unneeded apps on your phone. If it remains delete the rest (unlikely) until you find the bogus app. I went through 3 Samsung S5 handsets & an Xperia Z3 before I realised it was an app problem . DONT PASS ON THIS!!
  21. Phone: Samsung Galaxy s6
    Android Ver: lollipop 5.1.1
    Rooted: No

    My home launcher (Currently Go Launcher Z) will NOT save even though I say "Always" when it prompts me to complete the action.
    Any help?????
  22. TommyB1088

    TommyB1088 Lurker

    Disable/uninstall the Google Search app first. If that doesn't work, uninstall any apps you have recently downloaded (delete all your apps if you need to - I know that's a pain in the ass but it's necessary) as certain apps are the route of this issue.

    This is time consuming but it works. If you go through your apps 1 at a time and uninstall them individually you may be able to determine which app is causing the issue and save some of your other apps being deleted unnecessarily.

    Post the results if you figure out what app it is.
  23. Ok so I see my Hotmail was an option to connect so I connect it then restart the phone and go launcher came up and this time I chose it and when I told my application setting an it's show its my default now so we see how that goes...Thanks
  24. Hai Tran

    Hai Tran Lurker

    Cofirm that restarting phone after nova was installed resolves problems.

Samsung Galaxy Note 3 Forum

The Samsung Galaxy Note 3 release date was September 2013. Features and Specs include a 5.7" inch screen, 13MP camera, 3GB RAM, Snapdragon 800 processor, and 3200mAh battery.

September 2013
Release Date
Similar Threads - Default Home Launcher
  1. smontanaro
  2. prince214
  3. Beadmaster
  4. markdoc
  5. OnGoGS7A
  6. Alex Ethridge
  7. Milo Williamson
  8. halfbeing
  9. Love Jesus
  10. CoolDroid72

Share This Page