1. Download our Official Android App: Forums for Android!

Root DeFroST Rom. MMS Failing? Radio??

Discussion in 'Android Devices' started by patpending, Oct 2, 2010.

  1. patpending

    patpending Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    170
    Joined:
    May 31, 2010

    May 31, 2010
    170
    23
    38
    Customer Advisor, Telstra
    Adelaide, South Australia
    Hi all,

    Currently running DeFroST 4.7 on my rooted desire.

    First question - I can't seem to get MMS to work, either send or receive? I've looked through threads on here, and also the DeFroST thread on xda developers, but I haven't seen a resolution ... anyone have any ideas?

    Also, I keep seeing "Updated Radio" download links all over the place ... being a bit of a n00b, I would assume this is not to do with the FM Radio :eek: is there a simple explanation of what these may be? And should I need to worry about maybe updating mine?

    Any advice would be greatly appreciated.

    Cheers,
    Dave.
    HTC Desire
    Rooted
    DeFroST 4.7
     

    Advertisement

  2. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,305
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    The radio is the software for the physical radio, which picks up your mobile network. you should try to keep up to date.

    The latest radio which I am also using with defrost is her:

    http://xda.b42.nl/richardtrip/32.48.00.32U_5.11.05.14.zip

    Put it on your SD card and flash it from recovery.

    Keep an eye on the defrost thread in xda. it always mentions that recommended radio and latest defrost version in the first post.

    [ROM-FroYo AOSP+CyanogenMod] DeFroST 4.9 01/10: HAVS/MODS/OTA - xda-developers

    Mms could be down to the app settings. check your apn on network settings against your carrier's recommend settings.

    Hope this helps
     
  3. patpending

    patpending Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    170
    Joined:
    May 31, 2010

    May 31, 2010
    170
    23
    38
    Customer Advisor, Telstra
    Adelaide, South Australia
    You seem to be the only one on the end of the keyboards for replying - thanks heaps Dan, really appreciate it.

    So these "Radio" .zip's aren't carrier/region specific? Eg, being on Telstra in Australia isn't any different to being on Orange in the UK?

    Also, the "flash it from recovery" instruction ...... can I install this using ROM Manager?

    As for the MMS, I've checked and rechecked the APN settings ( I work in the Telstra shop :p ) but still no joy. Have trawled through the thread, and it seems that half of users' phones are fine with MMS and the other half don't work :/

    Thanks again for your continued responses!
     
  4. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,305
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    In regards to mms then, not sure, sorry. don't really send mms.

    Radio is pretty much like a driver. in Rom manager, choose boot into recovery. choose the option to install zip from SD card. browse to it and select it. it will install and tell you to reboot via the menu, so press back and select reboot system. this last bit is very important.

    That's it

    I'm on 4.9 now. No problems
     
  5. patpending

    patpending Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    170
    Joined:
    May 31, 2010

    May 31, 2010
    170
    23
    38
    Customer Advisor, Telstra
    Adelaide, South Australia
    Awesome, cheerz!

    One last thing (for this thread anyway :p) is there any reason I'd need to update radio before or after an actual ROM update?
     
  6. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,305
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    I don't do it regularly. Usually I stay on the same radio for a few versions. Or do you mean should you do it before or after the rom? Guides usually tend to say before, but I usually do it afterward. Not sure if it makes a difference really. I often reflash the rom over itself after forgetting to remove apps so I guess thats both anyway haha
     
  7. landwomble

    landwomble Newbie
    Rank:
    None
    Points:
    16
    Posts:
    15
    Joined:
    Jun 4, 2010

    Jun 4, 2010
    15
    2
    16
    the only way I've got MMS to work reliably (I can always MMS myself, usually can't MMS other people on other networks) is via Handcent SMS. I set max MMS size to 200k, and set the phone identity to "iphone". It works now.
    MMS sending is complicated - there's the MMS/GPRS settings on the phone, there's the size of the message itself, there's stuff the networks do invisibly that changes size depending on sendign/receiving type of handset etc.
    The above works for me, anyway.
     
  8. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,305
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Are you on the Defrost ROM?
     
  9. cq914

    cq914 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 11, 2010

    Sep 11, 2010
    1
    0
    5
    I am having the same problem, MMS worked fine for me on the older defrost rom but I am on the latest ROM 5.1 and radio and I can't send and receive MMS.... its doesn't even go in the failed or sending state....

    Does anybody have a solution regarding and btw yeah APN settings are correct and on the same setting a Nexus one is sending MMS fine.
     
  10. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,305
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    I just did a wipe data on a titanium backup for [sms / mms prefs], now all working fine.
     
Tags:

Share This Page

Loading...