1. Download our Official Android App: Forums for Android!

Support Desire Exchange push mail when roaming

Discussion in 'Android Devices' started by Desiroid, Jul 19, 2010.

  1. Desiroid

    Desiroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    8
    0
    5
    I am currently roaming outside my home network in the UK and cannot get Exchange Server to automatically synch. I have read countless posts on this forum and elsewhere trying to self-help before posting, but despite this one appearing to be the same issue, I have been unable to fix it.

    In essence when opening Menu > Settings > Accounts & Synch > Manage Accounts / Exchange Active Sync > Account Settings I see that the option for "Sync when roaming" is not only unticked but also greyed out so I cannot enable it.

    How can I fix this, please?

    Note that Menu > Settings > Wireless & networks > Mobile Networks > Data roaming is ticked and so is ... > Enable always-on mobile data.

    I am currently on an Edge network and manual Exchange Synch works just fine but having automatic sync is more important right now that worrying about the roaming charge.

    Cheers,
    Desiroid
     

    Advertisement

  2. aalard

    aalard Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    1
    0
    5
    I have exactly the same problem with my HTC Desire. The problem for me is that I use the provider Telfort in the Netherlands and as they use the network from another provider I'm always roaming according to my phone.

    On my previous windows mobile phone I was able to change a setting in the registry to correct this but does anyone knows how you can do this in Android?
     
  3. Desiroid

    Desiroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    8
    0
    5
    That must be really frustrating, aalard. At least (I hope!) I will get exchange auto synch when I travel home again!

    This morning I noticed another option that is also behaving outside my control, even though not actually greyed-out: Menu > Settings > Accounts & Synch > Manage Accounts / Exchange Active Sync > Schedule keeps changing to "disabled when roaming" instead of using the push-mail settings I have chosen. If I set push-mail, it reverts to disabled a few seconds later.

    Grrrr. :mad:
     
  4. Desiroid

    Desiroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    8
    0
    5
    ... and now it's gone back to push-mail and I changed nothing... :thinking:

    The problem as originally described remains though.
     
  5. Desiroid

    Desiroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    8
    0
    5
    An update regarding the Schedule observation: I have confirmed by manual network selection that the disabled schedule only happens when connected to a third party operator rather than the "foreign" operation of my home operator (Vodafone). If connection is to the local Vodafone operator here the Schedule correctly shows as "push-mail" but if connection is to anyone else it is disabled. I can live with this, as manually selecting Vodafone gives a rock steady connection where I am.

    Now, back to the original problem with "Sync when roaming" being both disabled and greyed-out... Hmmm ?
     
  6. Desiroid

    Desiroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 19, 2010

    Jul 19, 2010
    8
    0
    5
    Perhaps I now have the answer.

    Although from a FAQ page for a different smartphone with non-Android operating system the information seems generic enough as to make sense for a Desire, too.

    Time for me to make a phone call to my Exchange Server administrator.
     
  7. Leoker

    Leoker Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 21, 2011

    Feb 21, 2011
    1
    0
    5
    (Telfort in the Netherlands):

    On exchange 2007, the client access policy for "Allow sync when
    roaming" should be checked on the server profile. This will allow the
    user to edit the field on the device.
     
Tags:

Share This Page

Loading...