1. Check out our app, Forums for Android! Download and leave feedback here!

Support Desire HD bluetooth problems - in car

Discussion in 'Android Devices' started by quentin_rayner, Nov 6, 2010.

  1. quentin_rayner

    quentin_rayner New Member
    Thread Starter
    5

    Nov 5, 2010
    4
    0
    5
    Hi,

    Love the Desire HD, but seem to have a major problem with connecting it to my Audi in car bluetooth system.

    It connects, but within seconds it disconnects and won't connect again - anyone else have this issue?

    Help!
     

    Advertisement

  2. arlrb

    arlrb Well-Known Member
    43

    Oct 18, 2010
    305
    38
    43
    Yep, annoying. I have a relatively old Nokia car kit (5 years+) that it won't connect to.
    Sees it, asks for the pin, sits there doing something for a bit, then says error in establishing connection, every time.
    This is the first phone it's not worked with; nokia, iPhone, other android phones all work with no hassle
    I don't think HTC are up to speed with bt yet, I have a keyboard that won't connect too.
    Stereo headphones work ok, & my normal bt headset for calls.
     
  3. dvhttn

    dvhttn Well-Known Member
    173

    Oct 17, 2010
    1,510
    276
    173
    I wish ....
    Sunny Cornwall
    Hmmm. I've come from a Nokia E71 and the BT on that was dodgy to say the least! Anyway, the DHD connects up with my old Pioneer head-unit with BT and seems to work so far though the particular head-unit I have has it's own BT problems!!!

    I do seem to be having problems with my Plantronics headset though. They are paired fine and connect fine but quite often when I answer a call the audio is routed through the phone speaker and not the headset, which sort of defeats the object somewhat ..... You have the option of where to route the audio to at that point but even choosing 'headset' doesn't do things correctly.

    Anyone else having problems like this? Any settings I may have missed?

    Dave
     
  4. quentin_rayner

    quentin_rayner New Member
    Thread Starter
    5

    Nov 5, 2010
    4
    0
    5
    Well think I am going to see if Audi has an update for the firmware in my car, but do see that HTC have problems with BT...

    I might have to invest in an in-ear one for a time..!
     
  5. Choochter

    Choochter Member
    36

    Oct 15, 2010
    13
    2
    36
    I've been having this same issues with on the loan Merc E class, wifes Nokia works no problem.
    I'm away to buy a new head set for my A4 and would like to find out why were having these pairing issues before I commit to buying a new one?
    Is this common or only happening to a few of us?
    Is this the same as streaming? Can you guys manage this?
     
  6. IanW

    IanW New Member
    5

    Nov 25, 2010
    1
    0
    5
    Problems with Bluetooth headsets as well. I've been having issues with either bluetooth Motorola or Plantronics headsets. Headset disconnects during the call or when the call first connects. This is using the Choice Dialler app and HTC Desire HD. Frustrating as it will work on some calls but fall over on others
     
  7. colaboy

    colaboy Member
    5

    Nov 30, 2010
    5
    0
    5
    Hello,


    Worked flawlessly with my audi A5 for several weeks. Now suddenly, the last days the bluetooth connection drops after 10 seconds and will NOT reconnect!!!!

    This is SO annoying.

    No clue what's changed or causes this....


    Ramon
     
  8. DDHD

    DDHD New Member
    5

    Dec 6, 2010
    1
    0
    5
    Hi,

    I am having similar issues with my VW car kit. I had a Fiscon unit and now the latest Novero (Nokia) - which I upgraded in the hope the the "disconnection" disappear... but no luck... it's gotten worse.
    Still have to troubleshoot to find out where the problem is from...
    Did anyone manage to fix the issues ??
     
  9. colaboy

    colaboy Member
    5

    Nov 30, 2010
    5
    0
    5
    Hello,


    I have the feeling that it has to do with the grouping of contacts in the phone.

    I ungrouped all my contacts (no longer connected to a facebook/whatsapp account etc etc) and suddenly my phone starts to connect again!!!

    However I still do have issues like that the sound still is going via the phone and not the carkit when somebody calls, but okay... Have to work that out...

    But the connection problem seems solved...


    Ramon
     
  10. dvhttn

    dvhttn Well-Known Member
    173

    Oct 17, 2010
    1,510
    276
    173
    I wish ....
    Sunny Cornwall
    I don't have any contacts *grouping* on mine. I download my contacts from Outlook and that's it. And I don't have connection problems either except for ones caused by my head unit which itself has (HW) BT problems ....

    As for the sound going to the phone, how do you answer? I've found that both with my car kit (well, BT head unit - Pioneer) and my Plantronics headset where the sound goes depnds on which device you use to answer. With my old Nokia (E71 but all others that I've used as well) if the phone was paired with a BT device, it wouldn't matter which one you answered with (that is, you could touch the headset to answer OR use the phone directly) the audi would go to the BT device, not the phone.

    With the DHD if I use the phone to answer then the sound comes through the phone, but answer using the BT device (headset or head unit) and the sound comes from the BT device as it should. Looking at some BT docs. it implies that this is the way it should work though I must admit it is ambiguous, mainly, I suppose, as I'm not too well versed in BT technology docs, I just use it!

    However, I can use the phone to call and the sound does go through the BT device ....

    Is this what happens with yours?

    Dave
     
  11. colaboy

    colaboy Member
    5

    Nov 30, 2010
    5
    0
    5
    Dave, maybe this is the case. Not sure though. I will have to test tonight...


    Ramon
     
  12. arlrb

    arlrb Well-Known Member
    43

    Oct 18, 2010
    305
    38
    43
    Just seems very hit & miss for me. Sometimes it connects to my bt stereo headphones (motorola), sometimes not. Sometimes restarting the headphones sorts it, sometimes restarting the phone sorts it.

    Still not been able to connect to my nokia car kit or bt keyboard at all (tried all the various bt keyboard apps out there).
    It can see them (pairs), yet won't connect.

    It has always connected to my bt ear piece without fail.

    I don't think htc have given much time to this side of things, i've never ever had any trouble with any other phone & bt until now... but i can forgive it as it does everything else so well.
    Hopefully an update will fix it, if not 2.3??
     
  13. dvhttn

    dvhttn Well-Known Member
    173

    Oct 17, 2010
    1,510
    276
    173
    I wish ....
    Sunny Cornwall
    I must admit that the Nokia E71 I had before also had shed loads of BT problems due, supposedly, to Nokia having their own in-house written BT stack. Sound familiar? What amazes me is that BT is supposedly a standard and there are still all of these problems.

    Dave
     
  14. arlrb

    arlrb Well-Known Member
    43

    Oct 18, 2010
    305
    38
    43
    That's what i thought - a standard.
    That's why i think htc haven't been that thorough with this particular handset & bt.
    (would appear that anything other than basic, basic bt (ear piece bt) & it is intermittent... or nothing at all!)
     
  15. GoodGravey

    GoodGravey New Member
    6

    Dec 18, 2010
    1
    2
    6
    I've been experiencing what sounds like the same issue connecting to the Seat bluetooth kit in our car. Everything worked fine with my old HTC Hero but the HTC Desire HD handset would connect then 10-30 seconds later would drop the connection.

    I'd nearly given up but today I spotted in, settings > power saver > "Disable Bluetooth" (Turn off Bluetooth if not in a call) which by default was set as on.

    I've now turned it off and so far the Bluetooth kit now seems to pair and connect and hold connection.

    Might not be the answer for everyone but thought I'd share just in case.

    Hope it helps.
     
    danski and Kevlar-Source like this.
  16. WeBlah

    WeBlah Member
    36

    Nov 22, 2010
    20
    3
    36
    I would tend to agree with this:

    I had a similar issue. I 'resolved' (to some extent) by deleting the pairing on car and phone (the phone needed rebooting before it would delete the pairing, for some reason!)

    When pairing again, do not allow contacts to be shared. It paired and remained connected. Not a solution, but a work-around until we can work out what the exact problem is!
     
    tonyhoughton likes this.
  17. GerardFG

    GerardFG New Member
    5

    Dec 21, 2010
    3
    0
    5
    I have exactly the same issue on my Desire since yesterday, as I accepted the last update. Everything went fine but since then I face this issue.
    Your solution seems the good one, but i don't have any power saving setting on my device behind settings....
    Any idea?
    Gerard
     
  18. MortenL

    MortenL New Member
    5

    Dec 22, 2010
    2
    0
    5
    Your idea seemed so promissing, that I at once tried to follow your description, but it seems there is a difference in the setup from Desire to Desire HD, as I do not see the menu item you are referring to, and can't find anywhere to set it either :thinking:

    If someone finds the golden clue - keep us posted :p
     
  19. MortenL

    MortenL New Member
    5

    Dec 22, 2010
    2
    0
    5

    Ohh happy day - your suggested solution works

    Simply un-pair, delete the record on your phone, re-pair, and when asked on the phone, do not allow the phone book to be shared. Seems to be the way to solve this, and actually the link works anyway

    Case closed for me; hope that they get the bug fixed for later, but handsfree works, which is all I need actually!

    :D
     
  20. GerardFG

    GerardFG New Member
    5

    Dec 21, 2010
    3
    0
    5
    This one worked for me too. Thanks for the trick.:)
    I already tried it before but accepting the access andit did not work. After reading your workaround,I tried it and works fine.
    My car kept my previously syncronized contacts, so very nice workaround.

    Still wondering if bluetooth power saving settings are available on Desire.

    Rgs
    Gerard
     
  21. vadeluma

    vadeluma New Member
    5

    Dec 23, 2010
    1
    0
    5
    Go to the general energy saving option. Find the bluetooth disable section and untick the box. This should work.
     
  22. WeBlah

    WeBlah Member
    36

    Nov 22, 2010
    20
    3
    36
  23. GerardFG

    GerardFG New Member
    5

    Dec 21, 2010
    3
    0
    5
    There is no such general energy saving option on the Desire, and on the bluetooth settings, nothing similar neither...

    New update installed, still same issue present...

    Gerard
     
  24. Kevlar-Source

    Kevlar-Source New Member
    5

    Jan 5, 2011
    1
    0
    5
    Wow!
    That one was a life saver :D :D :D
    I've been haunted - for months - by this issue. I almost live in the car and on the phone, so it was a major killer for me...

    Thank you so much!

    Cheers,

    Kevlar- Source
     
  25. jbulck

    jbulck Member
    5

    Dec 30, 2010
    8
    0
    5
    Same issue here. All worked fine during the first week. Then, the BT connection started to drop. Using a Desire HD and the Audi MMI. Will give the unpairing a try... Thx for the hint.
     

Share This Page

Loading...