1. Are you ready for the Galaxy S20? Here is everything we know so far!

Desire - root access stopped working

Discussion in 'Android Devices' started by wendigo, Feb 6, 2011.

  1. wendigo

    wendigo Newbie
    Thread Starter

    Hi folks,

    I'm new here, I lurked for some time till something went wrong with my Desire :)

    I rooted my Desire (Froyo, sw number 2.29.405.5) using unrevoked a month ago and everything was working fine. I backed up the original ROM from the Clockwork recovery, played around with CyanogenMon 6.1 and then went back to the original ROM.
    I backed up my apps and data with MyBackup Root, restored them, everything was fine.

    However, I tried the backup once again yesterday and MyBackup is asking for root privileges, I allow it (checked the "remember" checkbox) and then MyBackup asks AGAIN! Allow, asks again, allow asks again, etc. ad infinitum. The confirmation dialog is jumping up every 10 seconds until I force close MyBackup...
    When I open the Superuser app, MyBackup Root is listed in the Allow list, along with Superuser app. When I select Settings tab in Superuser it asks for root privileges as well!
    Then, in Superuser Settings, when I tap "Su binary v original" it asks for root again, finds new version of su binary. I confirm the update, receive "su binary updated successfully", but when I tap it again, it again find new version of su bianry and again "updates it successfully".

    It seems to me the root access has been disabled somehow, but I'm not aware of any action that might have caused this. What I think might have some connection to this - I purchased Superuser Elite from Market to show my support. Could it have somehow broken the functionality of the original Superuser app?

    I reinstalled all of these apps and wiped Dalvik cache but it didn't help.
    Runing unrevoked again doesn't help either - "Error: failed to get root. Is your firmware too new", the Zysploit app remains installed...

    I don't want to do full wipe/RUU untill I back up my data (games, mostly, which is not crucial, but I'd like to avoid playing all the Angry birds levels over again:)).

    Any ideas?:)

    Thanks for any help.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. LECTER

    LECTER Android Expert

    You didn't install an ota update by chance?
     
  3. wendigo

    wendigo Newbie
    Thread Starter

    No... Last OTA I saw was around Christmas, which brough the 2.29.405.5.
     
  4. EddyOS

    EddyOS Android Expert

    But we're you rooted at the time of the OTA?
     
  5. wendigo

    wendigo Newbie
    Thread Starter

    No, unrooted till cca 8th of January. Then I did:

    • Backup of all the apps and data with MyBackup Root,
    • Nandroid backup,
    • full wipe,
    • flashed CyanogenMod 6.1.1,
    • restored the apps and data to CM,
    • backed up from CM,
    • returned to the rooted stock ROM,
    • restored apps from CM (worked fine)
    And 3 weeks later Superuser seems to be broken. I still can boot in Clockwork recovery, though...
     
  6. wendigo

    wendigo Newbie
    Thread Starter

    Now I took the time to keep tapping on Allow while performing backup. It wasabout 50 taps per application but the backup went through.

    Moreover, Quick Boot app was doing nothing (found out today, it was fine before). Then I uninstalled PowerTutor and Quick Boot is now rebooting.
    :thinking:
     
  7. DC E1G

    DC E1G Well-Known Member

    I know it's a weird question to ask but did you try uninstalling Superuser and re-installing it?
     
  8. wendigo

    wendigo Newbie
    Thread Starter

    Yes. I uninstalled Superuser, MyBackup Root and Superuser Elite and reinstalled only the first two...
     
  9. SUroot

    SUroot Extreme Android User

    Well you need superuser to manage root access to applications. You need that back.
     
  10. EddyOS

    EddyOS Android Expert

    Ignore me, eating lunch and not reading properly
     
  11. wendigo

    wendigo Newbie
    Thread Starter

    SUroot: I know that, I installed it back and it is still the same - like it is not behaving accordingly to the saved Allow/Deny preferences. Perhaps not seeing the preferences at all, because it is asking for them over and over again.

    I think I'll contact the author of Superuser...
     
  12. SUroot

    SUroot Extreme Android User

    Have you cleared data and cache on the app yet?
     
  13. wendigo

    wendigo Newbie
    Thread Starter

    That was the first thing I've done...
    I retried it just now and it didn't help. I cleared data (there was no cache), uninstalled, installed again, same behaviour. The app (Quick Boot this time) is shown in the Allow list, but is asking for permissions again.
     
  14. EddyOS

    EddyOS Android Expert

    Whenever I try to update the SU app I can't so I'm guessing the fact you can means the rooting isn't correct. I'd flash the ROM again and don't restore the app backups. Try an app that needs SU access and see if it works. If it does, it's the backup that's knocking it out
     
  15. wendigo

    wendigo Newbie
    Thread Starter

    Currently I think the problem isn't the root access itself but how Superuser manages the permissions.
    When I use Quick Boot (which requires su permissions) it asks for the permission and when I tap Allow it reboots the phone/whatever action I selected. However, even though the Allow permission is saved (visible in Superuser app in Allow list), QB asks again next time.
    MyBackup Root seems to behave the same way - though it requires multiple (up to 50) Allow taps for backing up 1 app. When I'm patient and tap my way through the backup is finished successfully.
    Haven't tried restore yet though... I may try that and see the result, if it works I can apply the original RUU and root again from scratch.
     
  16. SUroot

    SUroot Extreme Android User

    Are you on your original rom, rooted? I'd do what Eddy says too. Unless you're not on a custom rom at all. Going the RUU route is pretty long winded.
     
  17. wendigo

    wendigo Newbie
    Thread Starter

    Yes, the original rooted ROM. Ok, I'll try flashing the NAND backup and will see...
     
  18. wendigo

    wendigo Newbie
    Thread Starter

    Ok, so in the end I just uninstalled Superuser app, now I have only Superuser Permissions and it works as expected. Without the Superuser features, though...

    Restore of the backed up stock ROM didn't help, in restored CM 6.1.1 it was working fine.
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...