1. Download our Official Android App: Forums for Android!

Support Desire S wont connect to my Netgear router

Discussion in 'Android Devices' started by Borgie1, May 29, 2011.

  1. Borgie1

    Borgie1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    May 29, 2011

    May 29, 2011
    5
    1
    6
    Hi All. New to this Site. Looks great.:)

    My problem is that my new phone seems to have some error with the Router or something.
    We have quite a few devices which work OK on the router, including my HTC HERO.
    The HTC DESIRE S, come's up in the wi-fi settings as. connecting...Disconnected... scanning and keeps going around in circles.:(

    Ive added the Mac address correct and in the wi-fi section on the phone , it states that i have an excellent signal strength.

    Ive spoke to Orange, my phone supplier and HTC an they can not help.
    They seem to think the problem is the Router.

    Its a Netgear Wireless N Router, WNDR3300

    Hope someone could help please.
     

    Advertisement

  2. Y_B

    Y_B Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    May 10, 2011

    May 10, 2011
    21
    2
    16
    Have you tried re-setting your router? remove your MAC address filtering if you have it enabled and try again.

    Do you have dynamic IP address allocation? Do you have any IP conflicts on the network? Power off all other devices using the wifi and then try and connect the phone, as that will be the only device on the network there should be no conflicts (unless someone else is using your network)

    99.9% of the time its user error when one device will not connect to another. You could be spelling the MAC address wrong, or input the passkey wrong. Remember if the information supplied to the router is not 100% accurate it will not allow the phone to connect.

    However if the phone does not work on other wireless networks you could have a faulty handset though.
     
    Borgie1 likes this.
  3. Borgie1

    Borgie1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    May 29, 2011

    May 29, 2011
    5
    1
    6
    Thanks Y_B . Not sure if it will work on any other wi fi as yet . I willhave to try this.
    It is annoying. as ive only been able to use my phone on 3G:(

    I will also check and try while other devices are not being used.
    It does say on my phone the SSID of my router and the signal strength. 100%. I would say this should connect with showing this on the phone.

    My HTC Hero works fine.

    I called Netgear earlier and they was not helpful at all, as it is not under a year old.
    I have been told to change the channel on the router but im not sure how to do this and did not want to ruin the connection to the rest of my devices.
     
  4. murrayalex

    murrayalex Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Sep 21, 2009

    Sep 21, 2009
    36
    3
    16
    Edinburgh
    Same here. My HTC Desire S will join the home network, cable broadband shared by mac Airport, then disconnect and bring everything else down, restarting both the modem and Airport brings it back. Doesn't happen with my iPhone nor my Palm Pre. I had an Xperia Arc which I returned last week as it did the same...:thinking:
     
  5. murrayalex

    murrayalex Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Sep 21, 2009

    Sep 21, 2009
    36
    3
    16
    Edinburgh
    Just realised...if no other laptop or phone is connected to the wif then the Desire S connects and stays connected. It is only if I turn on wifi on some other device at the same time that it crashes the whole system
     
  6. Y_B

    Y_B Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    May 10, 2011

    May 10, 2011
    21
    2
    16
    That sounds like an IP address conflict to me.

    Are you sure you have dynamic address allocation enabled?

    If you do then theres something wrong with DHCP. Re-setting the router should solve this issue.

    Also, double check your other devices, if you have a manaully entered IP address it could be conflicting with other devices.

    Heres a tip if you cannot get it to work even with dynamic IP address allocation.

    Set your phone to have an IP address manually eg: your network range is 192.168.0.1 - 192.168.0.255

    You have 3 devices already 1) 192.168.0.1, 192.168.0.2, 192.168.0.3.

    Set your phone to 192.168.0.4 or 192.168.0.150 or similar as this is way away from the current range of assigned addresses and should prevent a conflict.

    Although im pretty sure if you just have a look at your DHCP settings on your router you should be able to sort it to do everything automatically and this will solve the issue. :D
     
  7. Y_B

    Y_B Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    May 10, 2011

    May 10, 2011
    21
    2
    16
    Im 99% sure it'll be on either channel 3,6,11 as they overlap. (it'll be on one not all 3 as you only have 1 access point im assuming) You shouldnt need to change the channel, you'd only need to do that if you were having interference from another wifi network on the same channel (rare)

    Have a look through your routers configuration page, DHCP settings will live there somewhere and you should be able to reset everything.
     
  8. Borgie1

    Borgie1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    May 29, 2011

    May 29, 2011
    5
    1
    6
    Managed to get it to work with help from a family member.
    He checked all the settings , and made sure all was in order.
    Also said it was strange it did not work on one device . :D
    He turned off the access list, and all works now.
    What could be causing this Y_B ;)
     
  9. murrayalex

    murrayalex Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Sep 21, 2009

    Sep 21, 2009
    36
    3
    16
    Edinburgh
    Hi
    Thanks for the info which I will try. I'm also having this problem on my Nexus S and Xperia Arc but not the iPhone 4 nor palm Pre. Just one thing...where do I change the IP address on the Desire S, can't seem to find it in the settings.
    Cheers :D
     
  10. murrayalex

    murrayalex Newbie
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Sep 21, 2009

    Sep 21, 2009
    36
    3
    16
    Edinburgh
    Well, I changed the settings in the Airport Utility set up slightly, under "wireless" tab - "radio" to 802.11.n (802.11b/g compatible) and it has worked for the last 8 hours so hopefully that it is sorted. Thanks to all who helped with suggestions
     
  11. DaveJavu13

    DaveJavu13 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 3, 2011

    Jul 3, 2011
    1
    0
    5
    Technicl Librarian/Admin Support
    Essex
    Hi I resently bought my first contract phone (my sister gt the HTC Desire S, so I got one) I had a similar problem.

    My phone connected to mt Netgear Router (WGT624v3) with no problems, but my dad'd (who also decided to by one) would not.

    I reset both phone & router, but nada. So I set up my router to MAC filtering and it connected instantly.

    I'm at a loss.
     
Tags:

Share This Page

Loading...