1. Check out our app, Forums for Android! Download and leave feedback here!

Desire slow on wifi

Discussion in 'Android Devices' started by kungfuman, Jun 12, 2010.

  1. kungfuman

    kungfuman Member
    Thread Starter
    6

    Jun 7, 2010
    5
    1
    6
    For some reason my desire is quite slow on my home wifi. On speed tests I get around 600-700kbit/s, whereas on 3g i get 1800-2000kbit/s. My other devices (laptop, ps3, ipod) dont suffer from slow speeds and can get around 12mbit/s. I've tried updating the router firmware and changing the channels but its still slow, even when my desire is right next to the router! Router is a netgear dg834gt. Any idea what is causing to be so slow?
     

    Advertisement

  2. Akalatengo

    Akalatengo Well-Known Member
    36

    don't know your answer but, I can tell you that my wifi connection at home is really good and my wifi at work is really slow
     
  3. nx1977

    nx1977 Well-Known Member
    163

    Feb 8, 2010
    2,421
    174
    163
    UK
    Use app WiFi analyzer and check for channel congestion
     
  4. Akalatengo

    Akalatengo Well-Known Member
    36

    nice app thanks
     
  5. PJD

    PJD Well-Known Member
    36

    My Wifi on the home router is also excellent infact it connects quicker now after that update
     
  6. kungfuman

    kungfuman Member
    Thread Starter
    6

    Jun 7, 2010
    5
    1
    6
    tried changing router channels and used that wifi analyzer but still doesnt help. speeds still tend to be around 700kbit/s :(
     
  7. kungfuman

    kungfuman Member
    Thread Starter
    6

    Jun 7, 2010
    5
    1
    6
    any chance some of you can post what speeds you are etting through your wifi when running a speedtest? would like to know how it compares to my desire wifi speeds.
     
  8. mclemme

    mclemme Active Member
    16

    May 24, 2010
    40
    6
    16
    Programmer
    Denmark
    Using the SPEEDTEST.NET app I get 8161/1743 kbps, my DSL line is a 10Mbit/s download and 2Mbit/s upload line.

    My router is an Asus WL-500g Premium with OpenWrt firmware (linux based router OS).

    Distance to the router was ~1.5m at the time of the test
     
  9. kungfuman

    kungfuman Member
    Thread Starter
    6

    Jun 7, 2010
    5
    1
    6
    Thanks for that. Its really bugging me now. I'm wondering if it could be a firmware issue. The last two routers I've tried it on have been netgears, gonna find one that is another brand and see.
     
Tags:

Share This Page

Loading...