1. Are you ready for the Galaxy S20? Here is everything we know so far!

[DEV] Memo Pad HD7 (ME173X) Developer Resources

Discussion in 'Android Devices' started by BSydz, Dec 4, 2013.

  1. BSydz

    BSydz Android Expert
    Thread Starter

    I just got the HD7 a few days ago, and have put together some resources for any developers that wanna take a crack. I am not posting any flashable zips, this is just a file dump for now. I still have to unlock my bootloader. ;)

    The Dumps include system, boot.img, recovery.img, uboot.bin, logo.bin and a couple info files. I used MTK Droid Tools.

    For those that don't know, a dlpkgfile is an update zip that runs through apply_patch, basically an encrypted update zip. But it can be unzipped for useful info, like a factory scatter file.



    Stock 4.2.1 US Ramdisk, recovery log, and a few proc(kernel) files that may help:

    me173x 4.2.1 Stock ramdisk recovery log and proc files.rar


    Stock 4.2.1 US Dump:

    ME173X_US_user_4.2.1.86868_20130518_dump.rar


    Stock 4.2.1 US Deodexed/Decompiled framework:

    ME173X_US_user_4.2.1.86868_20130518_decompiled_framework.rar



    Stock 4.2.1 US service update dlpkgfile:

    dlpkgfile_ME173X_US_user_4-2-2-91525_20130711


    Stock 4.2.2 US Dump:

    ME173X_US_user_4.2.4.31212_20131030_dump.rar


    Stock 4.2.2 US Deodexed/Decompiled framework:

    ME173X_US_user_4-2-4-31212_201310308_decompiled_framework.zip


    Stock 4.2.2 US dlpkgfile:

    dlpkgfile_ME173X_US_user_4-2-4-31212_20131030


    Stock 4.2.2 US service update dlpkgfile:

    dlpkgfile_ME173X_US_user_4.2.4.72702_20131128



    Feel free to add anything if you think it might help.

    This is not the thread to ask if we are gonna get any custom ROMs, recoveries or anything like that, just resources and questions about the resources please.
     


    Swisaiahag likes this.

    1. Download the Forums for Android™ app!


      Download

       
  2. BSydz

    BSydz Android Expert
    Thread Starter

    I won't have a bunch of time to work on this for the next week, but I will be posting resources as I get/find/make them. Make sure you check the OP for new resources.
     
    Swisaiahag likes this.
  3. TweakAndroid

    TweakAndroid Newbie

    Hi there.

    You wouldn't per chance have the update file for the 11/28 release would you to update from 10/30 to 11/28.

    I downloaded one that had 09/18 in the updater script and because I am updating from 10/30, it would error out with the following.

    assert failed: file_getprop("/system/build.prop", "ro.build.fingerprint") == "asus/WW_memo/ME173X:4.2.2/JDQ39/WW_user_4.2.4.06716_20130918:user/release-keys" || file_getprop("/system/build.prop", "ro.build.fingerprint") == "asus/WW_memo/ME173X:4.2.2/JDQ39/WW_user_4.2.4.72702_20131128:user/release-keys"
    E:Error in /sdcard/update.zip
    (Status 7)
    Installation aborted.

    Any help would be appreciated.
     
  4. BSydz

    BSydz Android Expert
    Thread Starter

    Well you are kinda in luck, but there will be an issue. I do have the dlpkgfile but your build is WW(I think world wide) but these are US.

    First what region are you in? Cause the assert you have above is WW not US. I think I can fix that but dunno as I haven't modified a dlpkgfile, but think I might be able to change the updater-script asserts.

    I do have a raw backup of my phone excluding cache and data, but it is 1.6 GB and I don't have another tab to test whether the firmware contains serial or mac address info. It's not that big of a deal, like if it was esn or imei data, but I still wouldn't want a bunch of clones of my tab floating around. I take it you didn't make a backup of your phone. I'm still trying to figure out the bootloader, so I can keep my US firmware. Never had a bootloader before, and no info out there, so I am taking my time as if I mess up, I have a paper weight.

    What I would be willing to do is, if somebody wants to make a backup using this guide http://androidforums.com/memo-pad-hd-all-things-root/805826-guide-sp-flashtool-backup-guide.html, and send me a link to download, I will flash it to my tab to see if it changes serial or mac address info. Since I have a backup to restore. If it doesn't contain any info, then I will upload my system backups for stock 4.2.1 and 4.2.2. And hopefully we can collaborate with some of the people with other regions to get all the stock ROM backups.

    I'll upload the dlpkgfile in a few minutes and post it here.

    EDIT: 4.2.2 6MB update is in OP
     
  5. TweakAndroid

    TweakAndroid Newbie

    Thanks so much. I tried it and it did indeed not accept it with the same error as before but with the US instead of WW. The other one I installed did the same thing for some reason.

    I have two of these tablets but my other one was not altered and is using the US firmware but seeing mine was flashed with the WW 4.2.2 due to me uninstalling some of the bloatware apps, it wouldn't allow me to update.

    Now OTA doesn't work and I am restricted to these types of updates which worked last time but now CWM is not accepting the new update for some weird reason.

    I changed the updater script and rezipped but found out you have to zip a special way for it to work properly now. It's getting tiring and all for uninstalling the kindle app which I didn't need in the first place. yuck.....

    From what I am hearing, all updates are the same. I don't know why there would be different firmware upgrades for different places. Such a waste of time.

    Any help would be appreciated.

    Do you know of anywhere where I can download the WW 6meg update firmware file?
     
  6. BSydz

    BSydz Android Expert
    Thread Starter

    OK so even unrooted you can disable apps in settings, no need to uninstall. Framaroot can root without unlocking the bootloader. The only reason to unlock is for custom ROMs which we don't really have except superdragons WW version.

    If I were you, I would try the backup restore process between the two. Make backups of both and then restore the US to the WW. And I would note the WiFi and BT Macs and the serial in Settings>About tablet>Status.

    To change the assert use 7zip and notepad++. In 7zip set notepad++ as the default editor, then left click the updater-script and choose edit. Haven't done it in a while and I'm on my tab so maybe a lil different. Just make sure the first build id is the one you are using now. But it still may not work cause the files may be different. Also you could try to change the build finger print in system/build.prop, that is what the script checks.

    Good luck, let me know how it goes.
     
  7. TweakAndroid

    TweakAndroid Newbie

    Yea rooting is where this all started. I rooted and then used titanium backup to remove the unwanted apps seeing I didn't need them. I didn't know or think that having all apps the same would be a condition of updating. Such a waste.

    Is there a guide on how to do the backup and restore? This is beyond my current knowledge.
     
  8. BSydz

    BSydz Android Expert
    Thread Starter

    Yeah it sucks. The errors are probably just script errors that stop the update. Like it tries to find the file to update but can't and errors out. Also I think the update app probably checks the build.prop for the version to download the correct update packages.

    I linked to my guide in the first response.

    I just changed the assert for you, it is uploading now. I'll put a link in this post for you. I would make a backup before trying just to be sure you have a way back to where you are.

    You are renaming it to dlpkgfile and putting it in cache right? If not let me know how you are trying to flash the updates.

    This is the whole 4.2.2 update with the assert changed for you. I figured it would be wise to try the whole update since the 6MB update may not be compatible with what you are running now. Like I said, I would make a backup before I tried just to be sure that you can get back to where you are if anything does go wrong.

    dlpkgfile_ME173X_US_user_4-2-4-31212_20131030_WW_user_4_2_4_06716_20130918_assert

    Good luck.
     
  9. TweakAndroid

    TweakAndroid Newbie

    Thanks so much for your help. I am updating via a sdcard with the update on it and using cwm recovery.

    Finally got it updated through a donation of the WW 10/30 to 11/28 6meg update file from member on xda-developers. Worked fine as sooon as I replace the build.prop with a backup I created before trying to edit it for the US version.

    All up to date for now. :)
     
  10. stefanokan

    stefanokan Lurker

    I made a backup using stock recovery.
    I obtained a file with .backup extension.
    Is it possible to extract some files from that backup?
    I tried with dd linux command but without success.:(
    Thanks:)
     
  11. waledkka

    waledkka Lurker

    hi i have ASUS Memo PAD HD 7 and i am not able to update my device so i did download the update but how can i install cwm recovery on my ASUS MEMEOPAD HD 7 to use Update.zip ( dlpkgfile ) File For my device please help ?
     
  12. waledkka

    waledkka Lurker

    i get this error always [​IMG]
     
  13. waledkka

    waledkka Lurker

    i just need to know how to flash the update dlpkgfile ( 6MB) to my device :

    the problem is i am rooted and i did use Titanium Backup app to remove some system apps from my device and now the update can't be installed
     
Loading...

Share This Page

Loading...