1. Download our Official Android App: Forums for Android!

Support Device Not Compatible with this version

Discussion in 'TV & Video' started by Aidan364, Mar 1, 2016.

  1. Aidan364

    Aidan364 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Oct 28, 2015

    Oct 28, 2015
    4
    0
    5
    Male
    Hi I'm new to the forum.

    I recently bought an M8 android TV box. It came rooted and with Android version 4.4.2 installed.
    Every time I try to download something from the play store, Such as, Firefox Browser, YouTube, Netflix etc etc It tells me my device is not compatible with this version. It will allow me to download certain apps, such as Es File explorer. Does anyone have any idea what the problem might be? and is there a work around for this. I bought the box so I could use Kodi and it is running the latest version 16.0 with no problems at all.

    Thanks In advance
     

    Advertisement

  2. Simon Lam

    Simon Lam Newbie
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Feb 3, 2016

    Feb 3, 2016
    21
    2
    16
    Male
    Sales Manager
    Hong Kong
    Some apps are limited to the type of device (phone or tablet) and device model. SO it is understandable that some apps is not able to be installed.

    A work around is to change your device name, id on build.prop to trick the apps.

    You may look it up on the Internet for detail instruction. i didn't try it.

    Simon
     

Share This Page

Loading...