1. Are you ready for the Galaxy S20? Here is everything we know so far!

Difficulties rooting with 4.3

Discussion in 'Android Devices' started by hstroph, Jul 31, 2013.

  1. hstroph

    hstroph Android Enthusiast
    Thread Starter

    The OTA RootKeeper failed to preserve root with the 4.3 install, and the app page now states "no 4.3 support" -- what a disappointment. Several important apps I use and paid for require root privileges that are no longer working. Titanium Backup would be nice to use.

    With Linux, I'm using the most recent adb and fastboot contained in adt-bundle-linux-x86-20130729.zip. The RSA key was accepted from the phone's display, and the Android debugging icon is displayed in the notifications bar.

    # ps auxw | grep adb
    root 7297 0.1 0.0 31460 1488 pts/0 Sl 09:34 0:11 adb -P 5037 fork-server server

    # adb devices
    List of devices attached
    004323648951e5d9 offline

    # adb connect -d
    unable to connect to -d:5555

    # fastboot flash UPDATE-SuperSU-v1.51.zip
    < waiting for device >

    Looks like I'm stuck here with an un-rooted Nexus 4.

    I did manage to place a copy of the UPDATE-SuperSU-v1.51.zip on the /sdcard/ partition using the previous -20130717.zip ADT bundle which connected with the phone, but without root privilege can't find a way to install it. The Universal Nexus Linux Toolkit has also failed to play well with Android 4.3.

    [Edit] "yum install mtpfs" now allows the device to be recognized:

    # adb devices
    List of devices attached
    004323648951e5d9 device

    but fastboot still is "< waiting for device >"


  2. John Bean

    John Bean Happy Wanderer

    I used CF-Auto-Root-mako-occam-nexus4.zip after reading this tutorial.

    I didn't download the SDK (the standard Linux drivers work fine) and the downloaded zip contains working Linux fastboot and adb binaries along with an image and "auto" script that I ignored and simply flashed the image with fastboot from a terminal.

    The tutorial is pretty good. Seconds later I was rooted again :)
  3. lion7718

    lion7718 Android Enthusiast

    A new version of TB was posted earlier today.
    I lost root with 4.3 also..I just flashed it a few hours ago...anyway, I flashed SuperSU with TWRP & it worked fine.
  4. hstroph

    hstroph Android Enthusiast
    Thread Starter

    Thanks so much for that, I'm doing a full "adb backup ..." at this time, and it looks from the root-linux.sh script like the only two lines I really need are:

    chmod +x tools/fastboot-linux # no sudo necessary fer cryin' out loud ...
    sudo tools/fastboot-linux boot image/CF-Auto-Root-mako-occam-nexus4.img

    Hopefully it will go as smoothly as your rooting did.
  5. John Bean

    John Bean Happy Wanderer

    I hope so. Your quoted lines are exactly what I used :)
  6. hstroph

    hstroph Android Enthusiast
    Thread Starter

    Apparently my problem has to do with Step 5 in the tutorial:
    Step-5: Boot the phone into Fastboot mode by pressing and holding Volume Up, Volume Down and Power buttons together.

    Disconnecting the USB cable allowed me to get the technique needed; my hands have problems functioning with age.

    # fastboot boot image/CF-Auto-Root-mako-occam-nexus4.img
    downloading 'boot.img'...
    FAILED (data transfer failure (Protocol error))
    finished. total time: 135.303s

    and still a "downloading ..." persists at the bottom of the android screen for several minutes. A reboot doesn't provide root, so back into fastboot mode and :

    # fastboot boot image/CF-Auto-Root-mako-occam-nexus4.img
    < waiting for device >
    downloading 'boot.img'...
    FAILED (data transfer failure (Value too large for defined data type))
    finished. total time: 0.004s

    and it again says "downloading ..." on the phone. Oh well, it's late and tomorrow's another day, if what I've been told is true.
  7. John Bean

    John Bean Happy Wanderer

    Your issues with fastboot seem to be related to your underlying Linux system; I didn't have any such problem. Unfortunately I can't help with that - I have a Ubuntu-based system (12.10) and I didn't need to install anything; all I did before flashing was test that the phone was recognised in fastboot mode with "sudo fastboot devices" which confirmed the phone was recognised. After that it just worked.

    This 4.3 update is a royal pain in the rear. You have my sympathy; I thought I was stuck without root in exactly the same way you are, but fortunately I got out of it relatively easily.
  8. jmar

    jmar Nexican

    I've read this post a couple times and I find something interesting. It would seem you are attempting to root via fastboot. This is not possible, if I understand everything that I think I know.

    So, I'm currently running Stock Android 4.3. I flashed it via fastboot utility; downloaded the images from the Android Dev site.

    In order to root Android 4.3, you will need a custom recovery, like TWRP, to flash SuperSUv1.51.zip. It cannot be flashed via fastboot. The bootloader cannot unpack an archived file, it can only write unpacked image (img) files.

    Let me know if I am off base or helpful.

    I'll subscribe to this thread.


    Edit: The reason why Rootkeeper failed to save root is because 4.3 introduced SELinux for better security. Some other security measures were also put in place. So what happened is that the old code that tells the system that superuser had root privileges no longer talk to each other. Essentially, apps which ask for su permissions are either denied completely, or granted, but the app doesn't actually have the elevated privileges.

    So, chainfire rewrote SuperSU to run su at boot in daemon. When you connect your device to your Linux box, open terminal, cd ~/sdk/platform-tools, them sudo ./adb devices, your computer will connect adb via daemon via a predetermined port. So kind of the same deal, just it is running daemon on the phone at boot.

    Anyway, just thought I might shed a little light on that.
  9. hstroph

    hstroph Android Enthusiast
    Thread Starter

    Thank you all for your assistance, it's much appreciated. The Linux variant is Fedora-18, recently revised from now-defunct Ubuntu 12.04 LTS.

    The problems I experienced have to do with the fastboot utility. Fedora's android-tools package has an adb that works, but its fastboot doesn't work. The latest Android SDK fastboot works as expected.

    Again, thanks.
    jmar likes this.
  10. jmar

    jmar Nexican

    You're very welcome. Glad to help!

Nexus 4 Forum

The Nexus 4 release date was November 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 2100mAh battery.

November 2012
Release Date

Share This Page