1. Check out our companion app, Forums for Android! Download from Google Play

Root Difficulty rooting my Samsung Moment

Discussion in 'Android Devices' started by jax4pres, Feb 20, 2012.

  1. jax4pres

    jax4pres New Member
    Thread Starter

    May 9, 2010
    I still have a Samsung Moment, and tried to root it today to 2.2.2 using advice from 2 sites, but neither worked:
    How to Root the Samsung Moment – Volume 3 | Market 4 Android

    How To Root Your Samsung Moment (2.2.2 Froyo) - SDX-Developers Forum

    Here's the issue:
    After carefully following the steps on each of the pages above, I run the updater to install: recovery3_1_1.tar which install just fine. After that step, I hit volume down, talk & end call buttons simultaneously. However, when it comes to apply to SD card (selecting M900-EB28-v1.1.zip), it applies it and then says error updating, saying (bad). Is M900-EB28-v1.1.zip "bad" or corrupt? Should I be installing a different rom instead? I can't get past this.

    If anyone can help, it'd be much appreciated...



  2. jerry43812

    jerry43812 Member

    Apr 20, 2010
    Are you using the SamsungMoment_update.exe provided from Market4Android (or a different one)?
  3. HeadlessPonch

    HeadlessPonch Well-Known Member

    Jun 29, 2010
    Des Moines, IA
    You may have a corrupt download or transfer. Often when the file doesn't copy to the sd card successfully it will show as 0bytes in size. Try copying to your sd card again, or downloading EB28 again, maybe with a different browser.

    EB28 is a good starting point. To save a step, you could download BasicEB28, also found at sdx. It is basically the same as the zip you've downloaded but already includes a kernal. I'd then suggest applying a theme that disables Carrier IQ. Many of the EB28 themes at sdx do that. My favorite theme is Agat's Minimalist.

    If you do want to stick with M900-EB28 and CrapKernal, don't follow the Market 4 Android instruction where it tells you to fully boot the phone after installing EB28. You will boot loop! Reboot to Recovery and install CrapKernal, then boot to system.

Share This Page