1. Check out our companion app, Forums for Android! Download from Google Play

Support Disable 2g phone data connections?

Discussion in 'Android Devices' started by bearcave, Jan 15, 2010.

  1. bearcave

    bearcave Member
    Thread Starter
    15

    Oct 15, 2009
    14
    0
    15
    Oxford, UK
    I have a Galaxy on O2 UK. It's via work, and on a business tariff that boasts unlimited data.

    After a couple of huge bills, it turns out that apparently 3g data is unlimited, but 2g data is charged at the usual eye-watering rates. Phone Bloke is checking with O2 whether they are serious.

    In the meatime, I'd like to disable 2g data connections. I can't find a way to do that. Anyone got any cunning suggestions?
     

    Advertisement

  2. MichaelW

    MichaelW Well-Known Member
    43

    Oct 6, 2009
    364
    26
    43
    Someone is pulling a fast one, I'm also on O2 UK. At home I do not get a 3G signal at all and yet frequently look up facebook or twitter updates. I've never been charged for data usage.

    Unlimited data usage is just that, whether it's 2G/3G/Edge, it doesn't make any difference.
     
  3. bearcave

    bearcave Member
    Thread Starter
    15

    Oct 15, 2009
    14
    0
    15
    Oxford, UK
    Maybe - we're checking. However, one of the guys has an iPhone as part of the same tariff and reports the same. But you can specify data on 3g only on the iPhone.
     
  4. informale

    informale Well-Known Member
    68

    Oct 25, 2009
    704
    33
    68
    Scotland
    Maybe O2 has different billing conditions for business tariffs? I have not seen the "3g only data" setting on Android. There is an app called WiSyncPlus - it does not have such feature, but I'm sure the dev could easily implement it on request.

    Android Market QR-code link to WiSyncPlus:
    [​IMG]
     
  5. martino

    martino Guest

    That's weird... Maybe you have some different contract that might be only for businesses, but when I was on O2 what they took as 'fair usage' on unlimited data it didn't matter if you were using 2G or 3G.

    You can turn on 'use only 2G connections', or something like that, so if you untick the box, more chance of being on 3G, but as MichaelW posted, depends on the signal you can get.
     
  6. Teknik

    Teknik Well-Known Member
    53

    Dec 26, 2009
    247
    54
    53
    Guru
    Ipswich
    the only thing you could do is if you disable background data (or all data) and only refresh your gmail etc when you can manually check you have 3g?

    am i right in saying that both 3g and 2g go through the same access points?
     
  7. informale

    informale Well-Known Member
    68

    Oct 25, 2009
    704
    33
    68
    Scotland
    You are right.

    Would be handy if it wasn't so. )
     
  8. crester

    crester Member
    16

    Nov 16, 2009
    15
    2
    16
    *#*#4636#*#* -> Phone information -> WCDMA only

    Would that help?

    Edit: that forces the radio to use 3G, note that if you go to an area that does not have 3g you will not get any phonecalls or sms's with this option on. But you can always change it back to WCDMA preferred.
     
  9. Teknik

    Teknik Well-Known Member
    53

    Dec 26, 2009
    247
    54
    53
    Guru
    Ipswich
    ignore the last comment, i just checked and you can set it to WCDMA only, which is the long name for 3G, so that should sort it for you
     
  10. bearcave

    bearcave Member
    Thread Starter
    15

    Oct 15, 2009
    14
    0
    15
    Oxford, UK
    Thanks. That's a cunning idea.

    Sadly 3g coverage around me (central Oxford) is patchy. I'll have to keep 2g enabled. I've disabled background data for now, and will watch that damm 3g symbol closely.
     
  11. Andronix

    Andronix Well-Known Member
    63

    Aug 31, 2009
    676
    16
    63
    it's safer to disable apn with 'toggle data'. you can use 'Droidwall' firewall (whitelist apps) as well.
     
  12. bearcave

    bearcave Member
    Thread Starter
    15

    Oct 15, 2009
    14
    0
    15
    Oxford, UK
    Thanks for the suggestions, all.

    Company Phone Bloke has spoken to O2. Apparently they haven't correctly applied internet service to my phone number, and are rectifying this. So, panic over. I can go back to 2g data chatter.
     

Share This Page

Loading...