1. Download our Official Android App: Forums for Android!

Support Disable Google Contacts Sync?

Discussion in 'Android Devices' started by PDP, May 4, 2010.

  1. PDP

    PDP Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    5
    2
    6
    On a stock Android system, it is possible to disable sync for Google Contacts, Calendar, etc. Under Sense UI on the Incredible, there is no way to uncheck "contacts" under "Accounts & Sync" that I find. I have disabled the entire Background Sync, but of course that disables the Market. Is there a way to disable Google contacts sync that anyone has found?
     

    Advertisement

  2. russell5

    russell5 Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    206
    Joined:
    Nov 7, 2009

    Nov 7, 2009
    206
    19
    58
    When I go into accounts and sync under settings and choose gmail I can uncheck contacts. You should be able to.
     
  3. PDP

    PDP Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    5
    2
    6
    Thanks! Those checkboxes appears when I select Auto Sync, and I've unchecked them.
     
    rockcruze likes this.
  4. eagleOne

    eagleOne Member
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    Apr 13, 2010

    Apr 13, 2010
    47
    5
    16
    Engineer
    MA
    Thanks. Trick was to select Auto sync and then quickly disable.
     
  5. Statikk

    Statikk Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Mar 1, 2011

    Mar 1, 2011
    3
    1
    6
    Hi Guys

    here is a thread to my solution to permanently stop Calendar sync and it also works on Contacts sync and requires the same work involved
    I believe this won't affect exchange sync

    Thread is @
    http://androidforums.com/droid-x-su...urn-off-google-calendar-sync.html#post2365333

    The steps are same but files are different (Done on Dell Streak Froyo 2.2)

    Root the Phone and get Titanium Backup Root on your device and Open it. Then do the following.
    1) Go to Backup Restore Option and find the following entries
    Contacts 2.2
    [CONTACTS/CALLS] Contacts Storage 2.2
    Contacts Sync Adapter 2.2.1
    2) Tap on the last entry "Contacts Sync Adapter 2.2.1" and when the options come up simply select "Backup" (just in case) and then select the "Freeze!" option.
    DONE! No more sync of calendar to Google Cloud..

    For good measure I also Froze Gmail 2.3 as I DON'T want any of Google's offerings.. All of the above is being tested on my device and works perfectly in this state. Once I am confident that this is what I am happy with I will DELETE/MELT (MELT- Removed from Rom) the above crap from my Streak..
     
    insaf_mohd likes this.
  6. wayrad

    wayrad Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,177
    Joined:
    May 12, 2010

    May 12, 2010
    1,177
    148
    163
    Female
    Long Island
    If your contacts are phone contacts rather than Google contacts they won't sync either. :)
     
  7. dbvirago

    dbvirago Member
    Rank:
     #1,196
    Points:
    16
    Posts:
    69
    Joined:
    Jul 11, 2010

    Jul 11, 2010
    69
    3
    16
    Sorry to revive an old thread, but I no longer have the checkboxes to disable google sync and I can't find the auto sync option. Can someone help?

    Ultimately what I am trying to do is eliminate all the data in native contacts, it has become so jumbled, full of duplicates, and non-contact info, that I want to strip it and start over. But first I want to make sure it isn't going to sync with google contacts anymore.
     
  8. TheBr0ken

    TheBr0ken Member
    Rank:
    None
    Points:
    15
    Posts:
    41
    Joined:
    Mar 2, 2010

    Mar 2, 2010
    41
    0
    15
    Just fyi, if you goto google.com/contacts while logged in you can modify, find duplicates and merge contacts form there. i personally love that all my contacts are backed up. either way Menu>Accounts & Sync. click on your gmail acct and uncheck what you dont want sync'd
     
  9. adelbosque

    adelbosque Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 27, 2011

    May 27, 2011
    1
    0
    5
    I'm new to android. I have the Samsung Galaxy Ace with Android 2.2 and this is how I solved the issue:

    1. Export all your gmail contacts to a CVS file on your computer's desktop.
    2. Delete all your gmail contacts.
    3. Reset phone to factory defaults to delete your gmail account and all contacts merged.
    4. Add gmail account to your phone again.
    Notice that no contacts will be sent to the phone because the gmail account has no contacts at all.
    5. Go to settings > Accounts and sync > Gmail account under Manage Accounts > unckeck sync contacts (and calendar if you wish so).
    6. Go to your gmail account on the computer and Import back the CVS file you previously exported.
    Notice that all of your contacts are back in.
    7. On the phone, go to settings > accounts and sync > gmail account under manage accounts > press menu and finally press Sync now.
    This last step will let you verify that no gmail contacts have merged to the phone contacts.
    Hope its helpful !
     

Share This Page

Loading...