1. Check out our companion app, Forums for Android! Download from Google Play

disable low battery alert sound

Discussion in 'Android Devices' started by yzingerr, Aug 2, 2010.

  1. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    Is there any way to disable the low battery alert sound?
    I hate it when I'm doing something and it goes buh-bup in my ear.
    It always startles me when listening to music.. fn annoying!!
     

    Advertisement

  2. GideonX

    GideonX Guest

    I haven't done this, but I believe the following should disable the sound.

    In terminal:

    su

    mount -o remount,rw /dev/block/mtdblock4 /system

    mv /system/media/audio/ui/LowBattery.ogg /system/media/audio/ui/LowBattery.ogg.old
     
  3. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    Thanks, can anyone confirm?
     
  4. doomedromance

    doomedromance Well-Known Member
    78

    Nov 9, 2009
    664
    82
    78
    The Left Coast
    yeah that should work. You just have to rename/remove that soundfile then it won't play. Just like the camera/video shutter sounds. I think you have to be rooted, don't know if you can modifiy that from ADB, I've never used ADB
     
    yzingerr likes this.
  5. GideonX

    GideonX Guest

    What happened, don't trust me? ;)
     
  6. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
  7. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    I can't seem to make the command work. I am using android terminal emulator by jack palevich if it makes a difference.
    Can you explain where the enter command goes inbetween commands.
    I'm a newb to the terminal emus.
     
  8. GideonX

    GideonX Guest

    I edited my post, just hit enter after each line that I separated.
     
    yzingerr likes this.
  9. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    I give up, thanks anyhow.
    It says "system/media/...LowBattery.ogg" -read only file
     
  10. GideonX

    GideonX Guest

    Did you run this line?

    mount -o remount,rw /dev/block/mtdblock4 /system

    Usually if you get a read only error, it means you didn't mount it for writing.
     
  11. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    Yes,i ran it exactly as you put it. Not sure what is wrong.

    Do the spaces in the code matter?

    I.e.

    Mv /system
    Mv/system
     
  12. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    Here is the exact code as I put it


    export PATH=/data/local/bin:$PATH
    $ $ su
    #mount -o remount,rw/dev/block/mtdblock4/system
    Usage: mount [-r] [-w] [-o options] [-t type] device directory
    # mv /system/media/audio/ui/LowBattery.ogg /system/media/audio/ui/LowBattery.ogg.old
    failed on '/system/media/audio/ui/LowBattery.ogg' - Read-only file system
    #
     
  13. Lomallin

    Lomallin Well-Known Member
    18

    Jan 12, 2010
    77
    19
    18
    Workforce Management
    Michigan
    It looks like there should be a space in the line (see underscores)
    mount -o remount,rw_/dev/block/mtdblock4_/system

    However I am a random wanderer and might have mis-read this.
     
    yzingerr likes this.
  14. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    It still won't take, thanks for your persistent trying anyhow!!!
     
  15. GideonX

    GideonX Guest

    Here are the spaces:

    mount[space]-o[space]remount,rw[space]/dev/block/mtdblock4[space]/system

    I just triple checked and this works.
     
  16. GideonX

    GideonX Guest

    Your mv line looks fine btw
     
  17. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    Does it give you some sort of confirmation when successful?
     
  18. GideonX

    GideonX Guest

    Nope, just brings u back to the prompt.
     
  19. KidFlash

    KidFlash Well-Known Member
    38

    Feb 10, 2010
    104
    13
    38
    If you're still having problems with getting it to work, I think you can also use root explorer to rename or delete the file.
     
    discy likes this.
  20. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    That seems simple enough to work, where is the file located?
     
  21. KidFlash

    KidFlash Well-Known Member
    38

    Feb 10, 2010
    104
    13
    38
    GideonX actually provided the location in his first post, it's in /system/media/audio/ui/LowBattery.ogg
     
    discy and yzingerr like this.
  22. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
  23. GideonX

    GideonX Guest

    You retried with the correct spacing and it still errors out? Root explorer might be an easier option then.
     
  24. yzingerr

    yzingerr Well-Known Member
    Thread Starter
    56

    Dec 28, 2009
    215
    6
    56
    SF Bay
    export PATH=/data/local/bin:$PATH
    $ $su
    #mount -o remount,rw /dev/block/mtdblock4 /system
    # mv /system/media/audio/ui/lowbattery.ogg /system/media/audio/ui/lowbattery.ogg.old
    failed on '/system/media/audio/ui/lowbattery.ogg' - No such file or directory
     
  25. GideonX

    GideonX Guest

    You need to type exactly what I wrote.

    LowBattery is not the same lowbattery.

    Everything is cAsE seNsItiVE.
     

Share This Page

Loading...