1. Are you ready for the Galaxy S20? Here is everything we know so far!

disabling data roaming on Nokia 6.1 (Android 10)

Discussion in 'Android Lounge' started by mutie, May 10, 2020.

  1. mutie

    mutie Lurker
    Thread Starter

    I'm in Japan with my Nokia 6.1, running Android 10. My service provider is o2 (in the UK). I am using a pocket wi-fi to connect my phone to data services.

    I've done everything I can find to disable network data:
    • Settings / Network & Internet / Mobile network / Mobile data: OFF
    • Settings / Network & Internet / Mobile network / Roaming: OFF
    • sent o2 a "NOTRAVEL" SMS on their 23336 number
    I can no longer find my "Data roaming" option, which I have turned off in the past.

    Nevertheless, when my wi-fi fails, my phone has switched to data over 4G, incurring hundreds of pounds of charges. (This may be using the VoLTE protocol?) I have therefore selected "2G" for "Preferred network type", disabling my phone's network connectivity (as Japan has retired 2G). o2 has not been helpful.

    Are there steps I can take on my phone to disable data without the 2G overkill?
    1. does Android One (v.10) still have a "Data roaming" option? If so, where should it be?
    2. can I disable VoLTE on my phone?
    3. if I disable "Data roaming" and VoLTE, will I be able to avoid data charges if I use a 3G network?

    1. Download the Forums for Android™ app!


  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I don't have a Nokia, but I do have Android 10, and as far as I can see you have done what you need to prevent data roaming (Roaming: OFF is the data roaming option - Data: OFF should stop you using mobile data on your home network as well as when roaming).

    Under those my phone has an option "4G Calling", which sounds like VoLTE by another name. It's greyed-out on my phone, which is odd as my service provider (EE) say they do support it (maybe they just ignore the setting and enable it regardless? I didn't buy my phone through them, so it's not something they've done to the firmware). EE also claim that VoLTE won't work when roaming, but that's them not O2.

    Have you been able to confirm that the problem is VoLTE, or is that just a guess? Have you discussed this with O2? Asked to speak to a supervisor? Suggested that you may wish to raise these unexpected charges and their lack of response with the national media (it's amazing how many problems suddenly become soluble when the person calling is the BBC or the Guardian rather than the plebian customer - they all worry about bad publicity costing them money).

    As for 3G, 3G is not LTE, so VoLTE cannot work on 3G by definition.
    mutie and mikedt like this.
  3. mikedt

    mikedt 你好

    On my Huawei Android 10 phone all of that is found under the Mobile Network settings, and can be toggled on or off as required. See attached screenshot.


    If Mobile data, Roaming, VoLTE, etc. are off, they definitely are off.

    Of course I've never seen or used a Nokia phone, so can't say how that might differ.
    #3 mikedt, May 10, 2020
    Last edited: May 10, 2020
    mutie likes this.
  4. mutie

    mutie Lurker
    Thread Starter

    Thanks @Hadron and @mikedt .
    • I'm just guessing, given that I've turned off "Mobile data" and "roaming" that VoLTE is slipping data through in disguise
    • I can't see a "4G calling" option; when I "Search settings" for "volte", I find a hit, which takes me to Network & Internet / Mobile network, where I can't see it (see attached photo)
    • I also can't find the "data roaming" option on mikedt's Huawei
    • I've tried talking to o2 about this: the chat agent had no idea what I was talking about, and spent her time trying to sell me a £5/day package that's 5x as expensive as my wi-fi solution, and about as expensive as their unexpected bills; when I asked to speak to a technical advisor, she ended the call
    • agreed: o2's strategy seems to be to ignore me until it can't. I've not filed a complaint via the BBC or Guardian: do you know the programmes/columns I should look for?
    • I've set my "preferred network" to 3G, and also found I have a "data limit", which I've set to 0GB. Can you think of any further weird back doors that I still need to close?
  5. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I can't see the photo - I think the attaching failed. For me the setting is in the same place your ghost it for VoLTE is, visible but greyed-out (actually greyed-out in the "on" position). If O2 say they don't know what it's about maybe you could point them to their own web pages on this: https://www.o2.co.uk/connectivity/wifi-and-4g-calling - if nothing else that might embarrass someone into passing you on to someone who knows more about it ;).

    I think the BBC's consumer affairs programme on the TV is Watchdog, don't know whether it's on at the moment (TBH I've never watched it). "You and Yours" is Radio 4's consumer affairs programme, and the Guardian's consumer affairs column can be contacted via your.problems@observer.co.uk. I'm sure most other papers have similar columns.
    mutie likes this.
  6. mutie

    mutie Lurker
    Thread Starter

    Oops - trying again.

    I now have "Developer options" enabled, and have turned "Mobile data always active" off.

    Nevertheless, I received an SMS from o2 earlier today, welcoming me to Japan - where I've been since March. When I've received these from o2 previously on this trip, it's often been followed by a big bill for data usage.

    I've got my network set at "3G" as well to err on the side of ruling out VoLTE. Screenshot_20200511-001756.png

Share This Page