1. Are you ready for the Galaxy S20? Here is everything we know so far!

Do current rooting methods work with the jellybean update

Discussion in 'Android Devices' started by kfh, Dec 27, 2012.

  1. kfh

    kfh Lurker
    Thread Starter

    I got a copy of the jellybean update that came out on Decebmer 24th and everything works great. I was wondering, however, if the current rooting methods out there will still work with this update? I had not rooted it prior to the update, in fact I just bought it the day before that and was looking into rooting it when the update hit.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. lamentoflife

    lamentoflife Lurker

    I was doing some homework and according to someone on another forum the Droid RAZR Utility 1.82 root still does work with the update. Sadly, I can't confirm it personally.

    I know the update is being hosted a few places so you might be able to recover to ICS, root, use VooDoo, and then push the update through recovery.

    Good luck!
     
  3. TheErMinE

    TheErMinE Newbie

    I can confirm from my own experience with the 24th OTA on two different RAZR's..

    Rooted before update.. Works if root is backed up with Voodoo..

    Very important though.. Update SU before you update to JB or you will be out of luck..

    I tried using Utility 1.82 to root the one I didn't update SU on and it failed.. So no root for that one..
     
  4. TheErMinE

    TheErMinE Newbie

    Just an update on my experience..

    I was able to fix my half rooted JB RAZR that I forgot to update SU on before updating. From some bits and pieces I found on xda:

    Go to Superuser and download Superuser-3.1.3-arm-signed.zip
    Open up that file, and copy out the files Superuser.apk and su, put them somewhere on your desktop, say c:\tmp
    cd c:\tmp
    adb push Superuser.apk /data/local/tmp
    adb push su /data/local/tmp
    adb shell
    su
    (you should have the # prompt at this point...if you don't, you don't have "half-root" like I did, and this won't work.)
    cd /system/bin
    mount -o rw,remount /system
    mv su su-backup
    cp /data/local/tmp/su .
    chmod 06755 su
    cd /system/app
    cp /data/local/tmp/Superuser.apk .
    chmod 644 Superuser.apk

    Reboot, then all should be good. Worked for me anyway. Hopefully it'll help others.
     
  5. blakeslee14

    blakeslee14 Lurker

    TheErMinE

    I think i have similar situation as you. I'm sure as tech savy and don't really understand the directions that you typed out. I get to "put them on the desktop"... i'm not sure where i am supposed to type the rest. help would be great!
     
  6. Grey1001

    Grey1001 Android Enthusiast

    TheErMinE is suggesting you put the extracted files into a directory, for example c:\tmp

    the rest are command line entries

    cd c:\tmp - will change the directory you are in to c:\tmp

    the rest are commands using abd to move files/preform actions on the phone from that directory

    adb is part of the android sdk - don't know if you can set it up any other way


    good luck
     
  7. blakeslee14

    blakeslee14 Lurker

    So i am able to navigate to c:\tmp in the command prompt.

    do i open the adb shell from there?
     
  8. kfh

    kfh Lurker
    Thread Starter

    So if I never had SU because I never attempted a root on ICS, you think the util will fail alltogether?
    I may try to revert to ICS, root, then re-update as suggested above. I'd hate to wreck it trying to revert if I don't have to though. If I attempt the root while on JB I don't want to brick it. If it simply fails to root then fine. I'll go with whatever method is less likely to nuke it. =)
     
  9. Podivin

    Podivin Android Expert

    If you never had root before, why worry about it now? Rather than go through all of this, wait until somebody has an 'easy' root for JB (working on the assumption that will happen). Update to JB and enjoy it w/o root.
     
  10. blakeslee14

    blakeslee14 Lurker

    well i was just screwing around last night trying to fix my phone which was "half" rooted, as i forgot to update the binaries.

    i downloaded this restore root for jelly bean program. i plugged my phone in, clicked the batch file, it started automatically. The program rebooted my phone once and presto it was fixed. It may be just more dumb luck than anything else. but oh well!
     
  11. kfh

    kfh Lurker
    Thread Starter

    I don't suppose I "have" to root it, and I have no desire to use other roms at this point. Mainly wanted to get rid of the bloatware, etc. I'll probably end up waiting for an easy method, but it can't hurt to ask right?
     
  12. sinclac

    sinclac Member

    This worked for me also.
     
  13. TheErMinE

    TheErMinE Newbie

    Interesting... I tried that before anything else and it didn't work for me. Glad an easier solution works for some though.
     
  14. TheErMinE

    TheErMinE Newbie

    Yea, I'd wait for a JB root, pretty sure reverting is not an option.
     
  15. festerw

    festerw Member

    Didn't work for me when I was connected as mass storage, switched to MTP and it worked fine.
     
  16. carracerz14

    carracerz14 Android Expert

    Still no way to root yet I don't think, but back it up with voodoo before and you should be good.

    I had to download matts root restore thing to get mine to work right because for some reason voodoo didn't restore it right, but the program worked fine. Keep in mind in order for it to work through you need to have it backed up first.
     

Motorola Droid RAZR Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...
Similar Threads - current rooting methods
  1. somnomania
    Replies:
    13
    Views:
    678
  2. FairyTalePink
    Replies:
    0
    Views:
    403
  3. counterfactual
    Replies:
    1
    Views:
    518
  4. Lollypolly
    Replies:
    15
    Views:
    1,298
  5. Sunny Rio
    Replies:
    3
    Views:
    868
  6. Teofel Ervenge
    Replies:
    11
    Views:
    1,745
  7. LA1
    Replies:
    3
    Views:
    986
  8. Troubleshooter03
    Replies:
    2
    Views:
    550
  9. samjones3
    Replies:
    17
    Views:
    25,895
  10. twodose
    Replies:
    8
    Views:
    6,188

Share This Page

Loading...