Do Not Disturb


I have an up-to-date Samsung Galaxy S7. When I choose, "Do Not Disturb," with the exception of "Favorites," it works except for one thing. When someone from my favorite lists calls, it rings but doesn't show up on the screen. The screen is completely black. So in order to answer, I have yo be very quick of putting in my passcode to unlock the phone and then I can see who's calling and can answer. Problem is… most times I'm not quick enough before the call goes to VM. Especially if I was sleeping. Any suggestions, opinions or guidance on how to fix this problem?



Smoke me a kipper...
Use the fingerprint scanner? Must be quicker than waking the screen and entering a PIN.

There may be settings related to screen wake, but I've never owned an S7 and Samsung customise the software a lot, so beyond suggesting checking the screen and DND settings for advanced settings, and maybe the phone app, I can't really help with that. I don't have the "black screen" problem with calls coming through my DND, but different phone, different software, and anyway I'll put my finger on the scanner when I pick it up so it will be unlocked before I really see it.


Thread starter
What's finger print scanner. Do you man using your finger print to unlock phine rather than a passcode?