1. Are you ready for the Galaxy S20? Here is everything we know so far!

Does anyone else lose data connection randomly?

Discussion in 'Android Devices' started by jkoch2272, Aug 14, 2012.

  1. jkoch2272

    jkoch2272 Newbie
    Thread Starter

    I lose my data connection a few times a day. I'm on Verizon. It only lasts about a minute but it's really annoying. Does this happen to anyone else?
     


  2. mrsmith2002

    mrsmith2002 Newbie

    It's nothing but a network problem, especially if you are moving around while using the phone. Where is it worst? Check your network provider's network map and you'll see that the problem is worse wherever their signal is weak. I use Sprint, and the BestBuyMobile personnel have acknowledged that this is most always the problem.
     
  3. heavychevy

    heavychevy Android Expert

    False, not a network problem, mine only does it when lte4g is enabled. But will do it while I'm sitting right next to my air rave with crazy signal strength. The lte on this phone is not ready for prime time. Hope this is not a hardware issue.
     
  4. jkoch2272

    jkoch2272 Newbie
    Thread Starter

    I mainly notice it at work because that's when I'm using it most. I work in downtown Cincinnati so there shouldn't be any kind of problem with a weak signal. It just seems to stop working then it will randomly come back...
     
  5. Jceinc

    Jceinc Android Enthusiast

    Mine does it all the time.
     
  6. rjm12rjm12

    rjm12rjm12 Guest

    I have the same problem.
     
  7. yorklab

    yorklab Newbie

    I lose it sometimes also, but mostly it's 4g I seem to loose. I correct it by cycling airplane mode. I do think there is a software issue with the phone.
     
  8. universem2

    universem2 Well-Known Member

    I have the same issue. 4G Lte has its issues. Does anyone coming from a razr, or rezound care to chime in?
     
  9. Rolo42

    Rolo42 Android Enthusiast

    If you're in a concrete jungle, your signal will be blocked/deflected/echoed by tall buildings.
     
  10. iganinja

    iganinja Lurker

    :fight:Good day everyone. I just recently purchased a New Galaxy S3 from a local Spint store. I have been a loyal Sprint customer for 15 years. I have owned many different phones (Star-Tac, Sony, Touch-pro 1-2, Evo, EVO 4G) Over the past 2 weeks since buying the S3, I've noticed a SERIOUS drop in network connectivity, both Data & Cell for absolutely no reason. Now, stop me if I'm wrong, but on my Evo 4G, I could connect to the internet EVEN if I didn't have a 3g signal... As long as I had Cell bars, I could access the web no problem. So the S3 is giving me some headaches and I've seen on other forums that others are too. These people are on diffferent carriers too.
    So here's my issue. When I'm in a GOOD STRONG Sprint network, I've been attempting to access the web (Google Store or You-Tube) and have seen the 3g or 4G icon on the bar show data up/downloading then WINK, they dissappear and I get a "No connection RETRY" window. I've made many changes, selected CDMA instead of CDMA/LTE, vice-cersa. I've updated PRL, Profile, Firmware and even have the new Jelly Bean 4.1.1
    I've contacted Samsung and "Chatted" with a technician, but this person had NO clue of this issue... I gave them the links to this and other Android forums...
    So do I take it back? Revert back to my Evo? I have to say, the speed and versatility on the S3 when it's good, is GREAT, but I'm not one to have some half good, especially one so expensive...
    Any imput is appreciated...:D
     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...