1. Are you ready for the Galaxy S20? Here is everything we know so far!

Does anyone's virtual buttons light properly?

Discussion in 'Android Devices' started by markdoc, Dec 20, 2011.

  1. markdoc

    markdoc Android Expert
    Thread Starter

    I've had 3 or 4 Tbolts (exchanged for various reasons) & one thing that is always off is the lighting on the virtual buttons. The lights seem to have a mind of their own. They're off in the dark, on when it's light, I can't seem to get a phone with consistent lighting. I can get them to light slightly by covering the sensor with my finger, but that only lasts for a few seconds. Am I the only one with this problem or is it the Tbolt?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. jackdubl

    jackdubl Android Expert

    Never had this problem. Mine light up in the dark, are off in the light.
     
  3. swankyspoon

    swankyspoon Newbie

    No problems here.
     
    markdoc likes this.
  4. darkestred

    darkestred Android Enthusiast

    my capacitive buttons have a tendency to flicker. Thats about it.
     
    markdoc likes this.
  5. Blacklight82

    Blacklight82 Well-Known Member

    Mine are just really dim. My old Incredible's light was really bright.
     
  6. Joon525

    Joon525 Member

    Mine are a little slow to light up at times but I think that's got to do with the sensitivity of it all. Not sure if there's a setting to change that or not though.
     
  7. offanairplane

    offanairplane Android Enthusiast

    +1 to that. I definitely preferred the button lights on my Incredible.


    To the OP,
    Go to Liquid Settings>>General>>Automatic Backlight then check the "use custom" box. Then click on "edit other levels."

    At the top of the screen it shows the light level the sensor is picking up right now. The max is around 10,500 (I got it to read this by shining a bright LED flashlight directly at the light sensor.) In my normal office lighting conditions it reads about 1280, and when I cover it with my hand it goes down to about 160. So it's pretty accurate.

    Below there is a list and settings for different ranges of light levels.
    The top one is by default (0 - 159). That is the lowest range. If you are in a deep cave that is what light range your phone will be on. :)
    And then at the bottom of this list is the highest range, say you are flying in space and get too close to the sun, you will be on that range.

    And of course there are many ranges in between.
    You can adjust the lower limit of each range, but I wouldn't if I were you.
    What I would adjust is the Screen brightness for each range, and the button brightness for each range. For example I didn't like how dim the screen gets when you are in low light conditions. So I changed the screen level at the bottom range from 21 to 28 just to see how that works. And then you'll notice also that by default the buttons are only lit on the lowest three levels, and they are set for a brightness of 30 at those three levels. (You can set them up to 255 brightness if you want, but they don't get any brighter, so you might as well use 30 as your number. They are either on or off, they don't have different levels of brightness.
    So anyway if they aren't coming on when you think they should, maybe go down to the first range that they have a "0" and change it to a "30". If you still aren't happy, go down one more so that the top five light ranges all have the buttons turned on.

    Hopefully that helps you.




    edit: My mistake. I thought I was in the Liquid Smooth 3.2 ROm section.
    If you are running that Rom, this post will be helpful, if not, then it won't.

    Sorry.
     
  8. offanairplane

    offanairplane Android Enthusiast

    There is a setting to help with that.
    Under Liquid Settings>>General>>Automatic Backlight there is a checkbox labeled "Allow Light Decrease" which sounds like it's custom designed to reduce flicker of the screen and buttons.


    edit:
    Same thing for this post. This option is available on Liquid Smooth 3.2 ROM, and possibly some other roms, but it's not a stock option. My apologies.
     
  9. mrman8

    mrman8 Newbie

    Thanks offanairplane, I use Liquid 3.2 and your post solved my issue.
     
  10. darkestred

    darkestred Android Enthusiast

    I don't use liquid roms. I'm on 1.4 Touch My Bamf and i don't think it has happened. Then again i haven't been paying much attention. Thanks for that, though.
     

HTC Thunderbolt Forum

The HTC Thunderbolt release date was March 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1400mAh battery.

March 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...