1. Download our Official Android App: Forums for Android!

General Dolphin Browser Battery Drain

Discussion in 'Android Devices' started by dlee1001, Apr 29, 2012.

  1. dlee1001

    dlee1001 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    118
    Joined:
    Jun 2, 2011

    Jun 2, 2011
    118
    7
    36
    How many of you use Dolphin Browswer HD? Do any of you notice that whenever you use it, your battery drains excessively? Here's my story:

    I charge my phone to 100%. When I unplug it and use this browser, the battery decreases 1% in less than 5 minutes. This goes on and on, and in less than an hour, I'm at 80%. I've done some test browsing with the browser and Gauge Battery Widget, and the results show that:

    1. The battery decreases 1% about every 2 and a half minutes.
    2. At that rate, the battery will be empty in 3 hours.

    I've tried the Battery-saver add-on that Dolphin Browser HD offers, but it doesn't provide any way to customize what power-saving settings you want enabled or disabled. I'm the kind of person who needs to receive e-mails as they come, but using the battery-saver add-on disables auto-sync, and there's no option to have that enabled while also keeping other settings off. So essentially, the add-on is useless for me.

    On the contrary, using the stock browser, while it has its (severe) limitations (such as not even being able to download .pdf files), has a lesser impact on the battery, according to Gauge Battery. The stock browser drains the battery 1% about every 4 minutes, according to tests that I've done.

    But I really like to use Dolphin, because it lets you download anything and I really like the desktop toggle feature. How can I go about using this browser without the excessive battery drain?

    My phone is running Gingerbread from the official AT&T-released update. Here are my settings and specs:

    1. Background data and auto-sync are enabled. Sync for Facebook contacts, Gmail, and Exchange contacts are enabled.
    2. Auto-brightness is turned OFF. I adjust the brightness if the screen is too dim or bright for the ambient lighting.
    3. Screen timeout is 2 minutes.
    4. Power saving mode is enabled.
    5. Wi-Fi is turned off whenever there is no connection.
    6. No task killers or battery saving apps are installed. The only battery app I have installed is a widget that tells me how much battery I have left.
    7. I have two widgets on my home screen (Network Signal Info) and two widgets on the status bar (Gauge Battery and 3G Watchdog).
    8. No live wallpapers on the homescreen.

    Please help. I'm baffled as to why Dolphin needs to be such a resource hog (when actively in use, the RAM usage is over 90MB and the CPU usage is anywhere from 10-90%, fluctuating every second).
     

    Advertisement

  2. Dankees

    Dankees Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    500
    Joined:
    Apr 10, 2011

    Apr 10, 2011
    500
    14
    63
    I seem to be a lot like you and I experience the same battery drains with Dolphin. Have you been able to find a solution for this?
     
  3. Andima

    Andima Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    449
    Joined:
    Jul 31, 2011

    Jul 31, 2011
    449
    42
    43
    Male
    Undergraduate.
    Install "where is my droid power" app and check dolphin HD battery usage.
     
  4. Dankees

    Dankees Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    500
    Joined:
    Apr 10, 2011

    Apr 10, 2011
    500
    14
    63
    When I used to have it, it would show in my battery settings as using 8%.
     
  5. ferdossi

    ferdossi Member
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Mar 3, 2012

    Mar 3, 2012
    36
    1
    16
    Hi,

    I had the same issue and was solved, maybe my solution can help you.

    I have Uninstaller pro installed on my galaxy sii and thanks to it, I disabled some system services (like application update, email, fotaclient, google services) because I thought they were useless.
    Yesterday I unfreezed them all and now dolphin works perfectly, it never exceeds 13%, before it went up to 35%..
     
  6. Dankees

    Dankees Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    500
    Joined:
    Apr 10, 2011

    Apr 10, 2011
    500
    14
    63
    I don't believe that I have any of those applications (other than e-mail) running, and Google services.

    You just disabled and reenabled them and Dolphin wasn't killing your battery from then on?
     
  7. ferdossi

    ferdossi Member
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Mar 3, 2012

    Mar 3, 2012
    36
    1
    16

    Yes, those apps were frozen since a long time on my phone.
    Don't ask me how but yes, but reenabling them, dolphin works better..
    Maybe this workaround will work for 2 days, but for now it seems fine
     
  8. Dankees

    Dankees Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    500
    Joined:
    Apr 10, 2011

    Apr 10, 2011
    500
    14
    63
    Can you let us all know in a week how you're doing?
     
  9. ferdossi

    ferdossi Member
    Rank:
    None
    Points:
    16
    Posts:
    36
    Joined:
    Mar 3, 2012

    Mar 3, 2012
    36
    1
    16
    After one week I confirm my problem is solved. At this moment, dolphin uses about 2% of my battery although I'm using it since 1 hour.
     
  10. dlee1001

    dlee1001 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    118
    Joined:
    Jun 2, 2011

    Jun 2, 2011
    118
    7
    36
    I've been doing extensive amounts of testing with this browser.

    When I browse with Dolphin HD, the battery drops at an alarming rate of 1% per about 90 seconds. It makes the battery pretty hot too, about 113
     
  11. maded

    maded Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 26, 2012

    Jun 26, 2012
    1
    0
    5
    Hi!
    So I have the same problem with dolphin browser.
    But I think the cpu hogging is related to multiple tabs.

    If I only have 1 tab open dolphin "only " uses 8-11% of cpu when not focused. (still sad it needs that much running in the bg)

    but when I have more. tabs the cpu usage goes way up. Same page opened in 3tabs gives a 60-70% cpu usage when unfocused(read: checking the cpu usage in task manager)

    I hope this might get us closer to a solution.
     
  12. Dankees

    Dankees Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    500
    Joined:
    Apr 10, 2011

    Apr 10, 2011
    500
    14
    63
    It completely burns my battery and it ruins my phone.

    After loading Dolphin, my phone can't get a connection, my battery gets so hot. In fact, I have to get my phone replaced - my problems began after getting the application (after laying off of it for a while).
     
  13. electricpete

    electricpete Android Expert
    Rank:
     #61
    Points:
    393
    Posts:
    2,073
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    2,073
    1,028
    393
    Male
    Electrical Engineer
    I have noticed when I load many tabs, they sometimes lose their content and need to be refreshed by loading again. I also notice the app uses a lot of memory - often 80MB or so.

    I wonder if the highe memory usage forces a lot of memory swapping which uses up battery.

    If so, perhaps opening fewer tabs at a time may help. Also doing a checkup on what items are showing up in "Running Services"... these items are not swapped out of memory and if you can remove the app they are associated with and get rid of these services, you'll have more memory to work with.
     
  14. electricpete

    electricpete Android Expert
    Rank:
     #61
    Points:
    393
    Posts:
    2,073
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    2,073
    1,028
    393
    Male
    Electrical Engineer
    I have been watching my phone pretty carefully in terms of battery usage and power usage.

    I recently had an experience traced to the Dolphin Browser:
    http://androidforums.com/android-ap...-whois-taking-lots-cpu-power.html#post4739357

    There is no doubt in my mind that the power draw attributed to the WhoIs add-on of Dolphin was drawing ridiculous amounts of power even when I wasn't actively browsing with Dolphin (but I think maybe Dolphin window was open in the background but I stopped browsing and viewed real-time power usage and it just kept drinking up the power). Also I wasn't using the Addon at the time or shortly before that. I'm not sure if the PowerTutor is possibly assigning all Dolphin usage to that add-on or the add-on just went bezerk. I think I'll delete that Add-on just be safe because I rarely use it and don't want my battery to drain unexpectedely like this again.

    Also, you might try out Opera Mini browser. It has a very simple striaghtorward interface - easy to learn. Not as many features as Dolphin and does not present all web pages the way I like (one-column browsing setting is good for some pages but not for others). If browsing on data (vs wifi) with a limited plan there is a benefit of Opera Mini: it does lessen your data usage since all pages are compressed by an Opera server before you read them. That seems to reduce data by 30 - 50%. When browsing with a fast connection (wifi connected to broadband router) it seems a little slower than Dolphin for some sites and I think that may be the result of going through that extra webserver in between the origin and my phone. Probably on a slow data connection (like when using Data far out in the country away from a city) the benefit of transmitting less data may have a bigger effect on speed and overcome that extra server... so Opera may end up faster in that case.
     
  15. kct1975

    kct1975 Android Expert
    Rank:
    None
    Points:
    523
    Posts:
    1,200
    Joined:
    Sep 26, 2011

    Sep 26, 2011
    1,200
    1,053
    523
    Male
    NoVA
    Just a quick note...

    I did use the Dolphin browser, but I had too may problems with it.

    A friend suggested Ninesky browser and it works great.
     
  16. pcguys

    pcguys Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    8
    0
    5
    Dolphin | settings | Gesture & Sonar | Sonar Settings |

    TURN SHAKE TO ACTIVATE OFF.

    It clearly warns that "enabling shake to activate, Dolphin Sonar may use more power"

    Let me know if that help,
    Mike
     
  17. pcguys

    pcguys Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    8
    0
    5
    Update: Even with the shake disabled, my dolphin went out of control, eating 23% of my cpu for the last hour.

    It's a shame because I really like Dolpin,

    I may need to uninstall and move on :-(

    Mike
     
  18. pcguys

    pcguys Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    8
    0
    5
    Oh, just found this: DISABLE FLASH!!!

    Menu> More> Settings> Web Content> Flash Player> Always on/ On demand/ Off.
     
  19. electricpete

    electricpete Android Expert
    Rank:
     #61
    Points:
    393
    Posts:
    2,073
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    2,073
    1,028
    393
    Male
    Electrical Engineer
    I had both those settings off when mine went bezerk.

    If I were inclined to continue using Dolphin HD, I would also think about deleting all the add-in's that I don't use regularly (I put a lot of them in there just to try them out, before I became aware of possible problems with Dolphin). Even so, the sheer size of Dolphin HD application when loaded into memory is pretty unique on my phone...nothing else comes close. That still makes me leery.

    I tried out Dolphin mini. It is the exact opposite of Dolphin HD in that it's size in memory is tiny, only 2 MB or so. The look and feel vaguely resembles Dolphin HD. They kept the home page with speed dial. They kept gestures, but with one annoying thing.....the button that you tap to tell Dolphin Mini you're about to use a gesture isn't always there! To get it, you may have to grab a blank area of the screen and scroll... then button shows up. Quite annoying....adds another step to the gesture process. Why would they think the button should ever disappear? There are no add-ins, but I can do without that. Bookmarks on Dolphin HD was a strength (lots of nested folders, easily accessed and navigated). Bookmarks on Dolphin Mini is sort of the opposite...doesn't have folders. Just has labels. So you can tag a bookmark with a label, and then select filter to look at only the labels of interest. But you can't build a nested structure with labels (categories and subcategories). And for some silly reason when you apply a filter, the screen doesn't tell you a filter is applied. I guess I will be using Chromemarks for most of my bookmarks, so shoudln't be a problem.

    At this point I'm still using Opera Mini and Dolphin Mini. Don't know which one I'll settle on, but it's not gonna be Dolphin HD for me.
     
  20. Julie9009

    Julie9009 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 6, 2011

    Mar 6, 2011
    2
    0
    5
    I found that certain websites would consistently cause Dolphin to use 100% CPU, sometimes to the point of making the phone totally unresponsive if I had multiple tabs, and eventually causing a phone reset (after several minutes).

    For example, webpages at pcmag.com such as Microsoft's Massive Metro Mistake | News & Opinion | PCMag.com were using 100% CPU, but after turning off Javascript, Dolphin CPU dropped to 0%.

    Menu > More > Settings > Web Content > Enable JavaScript = OFF

    My guess is that there is some badly written JavaScript on some pages.

    Samsung Galaxy S with Dolphin Browser version 8.7.0

    UPDATE: That same web page uses 100% CPU when viewed using Opera Mobile v12, and again drops to zero when I disable JavaScript in Opera.

    Type opera:config in the address bar to open the preferences editor, then under "Extensions", disable Scripting (2nd from bottom) and then Save
     
  21. electricpete

    electricpete Android Expert
    Rank:
     #61
    Points:
    393
    Posts:
    2,073
    Joined:
    Jan 7, 2012

    Jan 7, 2012
    2,073
    1,028
    393
    Male
    Electrical Engineer
    Good catch Julie. I went to the PCMag site and was able to recreate fairly high usage which went down when I turned that javascript setting off.
     

Share This Page

Loading...