1. Are you ready for the Galaxy S20? Here is everything we know so far!

Download files from linux nfs share to android device

Discussion in 'Android Lounge' started by scporse, Jun 30, 2019.

  1. scporse

    scporse Lurker
    Thread Starter

    As the header says, I'm looking for a way to access and download files from an NFS share on my linux machine, onto my Samsung Galaxy S7 Android device. I have not, and do not intend to root my phone, so any proposed solution would have to avoid rooting.

     


  2. Best Answer:
    Post #11 by scporse, Jun 30, 2019 (1 points)
  3. mikedt

    mikedt 你好

    I'm sure you need to install an app that supports Network File System(NFS).
    There's a few in the Play Store. Can't recommend any particular one though, as it's not something I've ever used.

    Think an other way is to use FTP, but again you'd have to install an app on your phone.
     
    ocnbrze likes this.
  4. scporse

    scporse Lurker
    Thread Starter

    I tried to find an app with real NFS support, but all the ones I came across had only SMB and/or FTP support - no NFS :(

    The closest I got was being able to browse and stream from my NFS share in VLC Player for Android, and KODI. Downloading, however, was not an option in those apps.
     
    #3 scporse, Jun 30, 2019
    Last edited: Jun 30, 2019
  5. mikedt

    mikedt 你好

    If there isn't, and if nobody else knows of one. Could you change the Linux share to FTP or SMB?

    Don't think the S7 does, but some Android phones and tablets include FTP in their file explorers, depending on the manufacturers.
     
    Dannydet and ocnbrze like this.
  6. scporse

    scporse Lurker
    Thread Starter

    I'm currently using FTP as an alternative and this is working locally, but not remotely (via SSH) - maybe you could help me with that? :)

    I connect to the ftp server through an SSH connection to media center pc, from my android phone - this connection is established using the app VX connectbot.
    In this app, I've then configured specific port forwards for Kodi, Transmission and FTP.

    Unfortunately, the FTP port forward is not working, although the other ones work just fine.
    When I open my ftp client app of choice, Solid Explorer, and try to connect to the ftp server on my media center pc, through the ssh tunnel, I just get a "connection refused" message.

    The ftp connection in Solid Explorer has been configured with:

    hostname: localhost (to make the connection go through the ssh tunnel)
    portnumber: 21212 (forwarded in vx connectbot to port 21 on localhost - the media center pc)

    Username and password left out.

    If you have any idea why this isn't working, I would higly appreciate it!
     
  7. scporse

    scporse Lurker
    Thread Starter

    Nevermind.. I got it working with SCP in AndFTP app instead. It's a bit slow, but this is not a problem since I'm doing most downloading when on the local network (via normal FTP connection).
     
    ocnbrze and mikedt like this.
  8. mikedt

    mikedt 你好

    Happy you got it working. I've only done network shares coming from a Mac to a Raspberry Pi running Kodi, and that worked straight away.
     
    ocnbrze and scporse like this.
  9. scporse

    scporse Lurker
    Thread Starter

    Thanks, it's nice to have found a working solution, having spent numerous hours upon first trying NFS, then FTP and finally settling on SCP :)
    Well, actually I've ended up using all 3:
    NFS when connecting to media server from another local linux machine
    FTP when connecting from android device locally
    SCP when connecting from android device remotely

    Phew! That's a little complicated, and I guess I could get rid of NFS, but that would kind of be a waste, having spent some hours setting it up :)
    What complicates things especially, is when you want to reach these service remotely, via an SSH tunnel, as in my use case ;)
     
    mikedt and ocnbrze like this.
  10. mikedt

    mikedt 你好

    I don't even know the protocols my setup uses, I just set the drive share to whatever the MacOS default is, and Kodi on the RP found it immediately
     
  11. scporse

    scporse Lurker
    Thread Starter

    To my disappointment, it was not possible to move files from one directory to another on the media server, using SCP.
    Onto SFTP it is...
     
  12. scporse

    scporse Lurker
    Thread Starter

    I ended up using SFTP in CX File Explorer. It's a bit slow, just like SCP, but I think this is to be expected when transferring over SSH tunnel.
     
  13. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    I'm aware your issue has basically been resolved, but I just wanted to say you're doing it the hard way! :)

    I use nothing but Linux, and have been effortlessly transferring files between my computers and phones forever. I use different methods--all effortless--depending on what I'm doing.

    One method uses Airdroid, another uses various file managers I like. It just shouldn't be complicated.

    By the way, we have a Linux mega-thread you may want to pop in on. It's for Linux geeks and non-geeks alike, basically anyone smart enough to be using Linux on their computers AND devices! :D
     
    mikedt likes this.
  14. scporse

    scporse Lurker
    Thread Starter

    Ok, so what would be your recommendation for quickly transferring large files from my linux media server to to an android device? Airdroid or something else? I would prefer to be able browse the media server from my android device, just like when using FTP.

    Regarding FTP, I do have a problem when downloading from the vsftpd server on my media server pc (Lubuntu 16.04) to my Android device (Samsung Galaxy Tab S5e): The transfer speed is very unpredictable. It goes from anywhere between 4 to 17mb/sec., but for some transfers it stays below 5 mb/sec.
    Do you have any idea what might be causing this fluctuation in speed? I'm using Solid Explorer as ftp client on the Android device being dowloaded to.

    I'll make sure to have a look at the linux megathread. It's always nice to find like-minded (and helpful) people such as yourself :)
     
  15. Dannydet

    Dannydet Extreme Android User

    Not sure if this helps but have you tried transferring files using Solid explorer on your phone only via wifi?
    Solid explorer will find the local host, not as a server, and you'd be able to see the files on your Linux device?
     
  16. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    How large are we talking? I know that Airdroid, free, limits certain things, but I've never personally come up against that.

    They use a subscription method rather than free vs paid. I've contacted them about making a paid version (I always buy paid versions if I like an app--assuming there is one). They have no plans to, but said I can subscribe/unsubscribe at will.

    I use several file manager apps, all of which see my Linux network and connect to my computers without issue.

    Network Browser is what its name implies. Here are some screenshots of it showing some of my Linux computers, and then drilling down to show the file system on one of them:

    Screenshot_20190701-122306.png

    Screenshot_20190701-122318.png

    Screenshot_20190701-122345.png

    Sorry, but I really can't help with that, as I never FTP on phones. I haven't needed to.

    BTW, I've been using lftp instead of ftp on my computers for many years. If you're not familiar with it, you should be! It's like FTP on steroids, giving you a full suite of UNIX commands, as compared to FTP's handful. This page is a good summary.
    Yes, please do! :D
     
  17. scporse

    scporse Lurker
    Thread Starter

    I fixed the slow download problem when using regular FTP by installing a different ftp server - proftpd instead of vsftpd.
    And on the client side, I use Solid Explorer for both the FTP connection (local) and the SFTP connection (remote).
    Everything seems to be running smoothly now (finally!) :)

    Thanks for helping @ everyone in this thread.
     
Loading...

Share This Page

Loading...