Help "Download unsuccessful"

I'm having problems with the app store, and it seems to be a little different to the ones already listed here. I'm hoping it's a problem with the Android app store or something...

Anyway, I'm just getting "download unsuccessful" every time I try to get an app.

The main bit of advice is to clear the caches, or delete the data, from a few things. I've done this, except for "Google Apps", because the delete data button isn't there.

I've also had it suggested that it's changing from one sort of google account to another. I've had gmail for years and years (since the early days of its beta) and have never changed it, or any settings related to it.

Sites have suggested logging into and out of Google Talk, which I've done.

None of these solutions have worked. But if you know a way to make the Google Apps "delete data" button magically appear, or some other way round my problem, or just the comforting knowledge you're all having the same problem, please help. After my awful experience with a Desire, I'm beginning to get a little disheartened with Android.

Famous Mortimer

Thread starter
I've tried both, but it's mainly been with wifi.

Internet's working fine on it, and I've been able to download and use one of the Samsung Apps, if that helps anyone narrow down the list of problems / solutions.


I had this exact same problem today. I think AppBrain may have caused it. Anyway, all I did was take out the battery (after trying hwat you did) for 2 minutes and then booted it up. I could download things again but now the problem is back. i dont want to have to reboot all the time.


This is a semi-known problem, I would be so bold as to say that AppBrain has nothing to do with it since I experience it occasionally and don't use AppBrain. What tends to do the trick is to cancel the download (if it hangs in that loop) and let the Market app rest for a while, minutes-hours and try again.
I am not sure what is causing the problem, but its safe to say it came with the market upgrade. Could be a server capacity problem. For me, clearing caches and memory has never worked.


This happened to me too and I followed all the advices on the net.
Basically I can say that it had something to do with AppBrain and restarting the phone.
I cleared the cache of the Market App and then the some other things it mentions on the many forums and threads, but make sure in the end you take out your battery and leave it out for like 3-5 mins stick it back in and should work, just make sure you uninstall AppBrain too. Thats my advice to you.



I've had this for a few days now (Orange Desire) - it's NOTHING to do with Appbrain, I'm 99.9% convinced it's just a capacity issue with the Store...

Clearly there are multiple servers/systems at work tho, because some thing work fine and others refuse to work for ages (and then magically work some hours later).


You say it happens on wi-fi, I had the same problem for me it turned out to be a combination of the firewall and the content filter I am using. My home network is quite complicated however I guess you must be at least using a router? Does it have a built in firewall?

Tell us about your network i.e internet-----router/wifi-----device or what your setup is some details on the device might help too.

Have a look at my post as see tis helps if not come back with your network setup details


Android Expert
Its not Appbrain, and I'm not at all convinced that clearing cache etc help one iota. I think its a problem on Googles end somewhere, and the only 'fix' is some time for them to tidy up. I think things like clearing cache only appear to work when you do them right before the Market would start working again anyways. If you look at all the device forums here and elsewhere you'll see many users complaining of this issue. This is happening on different phones, from different manufacturers, different OS versions, different carriers/countries, and even different firmwares amongst affected users of the same handset. No one fix ameliorates the issue for any of them. That either means that various different problems are causing this for various users, all at the same point in time, and this is why some fixes work for some and not others, or that the problem is something else altogether . The same problem affecting all these people sure as heck seems a lot more likely than a multitude of different ones...

I've had this problem once, cleared cache, did all the various fixes people proposed, no luck. I left it for a day without doing anything to caches/whatever, and it started working again just fine. Appbrain was not installed.


Android Expert
yeah there are many reasons that could cause this so if it comes and goes it might not be the phone. however I've had a slightly different problem which turned out to be the infamous internal SD corruption. Nothing helped until I did a factory reset.