1. Download our Official Android App: Forums for Android!

Downloading error from cgi

Discussion in 'Android Apps & Games' started by migihito, Apr 18, 2011.

  1. migihito

    migihito Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 18, 2011

    Apr 18, 2011
    1
    0
    5
    Hi, sorry if there were any answered question related to this.

    What I want to do : download pdf file from my web server by android
    default browser.

    What happens : download doesn't start(neither start downloading or download icon on the topbar will appear)

    What Server's CGI doing : old downloading stuff(read file from local,output file)

    When I try to download from my WebServer by putting the URL directly,
    download starts without problem.
    But when I try to download from cgi, nothing happens. Of course, this cgi
    works fine with any PC browsers, even mobile safari on iPhone.
    I guess when browser requests directly the URL of the file to Web Application Server(IIS6.0), IIS responds the correct headers or somekind
    of action whitch suites Android's default Web browser. And the cgi doesn't. I dont know the Android's browser's regulations, so I have no
    chance of fixing this problem. Can someone help me with this?

    Below here is the header information of direct URL download and CGI download.

    direct URL:
    HTTP/1.1 200 OK
    DeleGate-Ver: 8.11.5 (delay=0)
    Content-Length: 10110
    Content-Type: application/pdf;
    Last-Modified: Tue, 31 Aug 2010 00:32:52 GMT
    Accept-Ranges: bytes
    Etag: "738323ca448cb1:801"
    Server: Microsoft-IIS/6.0
    MicrosoftOfficeWebServer: 5.0_Pub
    X-Powered-By: ASP.NET
    Date: Mon, 18 Apr 2011 06:59:51 GMT
    Via 1.1- (DeleGate/8.11.5)
    Connection: keep-alive, timeout=50, maxreq=60
    Transfer -Encoding: chunked

    from CGI:
    HTTP/1.1 200 OK
    DeleGate-Ver: 8.11.5 (delay=0)
    Content-Length: 10110
    Content-Type: application/pdf;
    Server: Microsoft-IIS/6.0
    MicrosoftOfficeWebServer: 5.0_Pub
    X-Powered-By: ASP.NET
    Date: Mon, 18 Apr 2011 06:59:51 GMT
    Via 1.1- (DeleGate/8.11.5)
    Connection: close
    Transfer -Encoding: chunked

    header informations missing in CGI is I guess the ones when you get right connection.
     

    Advertisement

Share This Page

Loading...