DPS Dream 7 is ill


Hello all

I have serious problems with my new Android device, which I have won recently.
First short info about tablet:
DPS Dream 7 - 4.0.4 (ICS) - 1.5 - 3.0.8+ - inet_zw@inetsuperserver #10 - Sun Sep 2 15:03:57 CST 2012
Iťs exotic tablet :D

Well, and now the story:

I wanted root to my device... I've heard, that z4 root is really nice for beginners to root their device.
So I have given it a try. I have downloaded, launched and... it said that I have already root... > I thought it's just a mistake so I clicked RE-ROOT. Tablet has frozen for few seconds and z4 shutted down. Nothing happened. Well, so I have tried UN-ROOT (and than I wanted just to click root).
After I selected UN-ROOT, it said: done and I have rebooted tabled. After reboot I was shocked.

EVERYTHING WAS GONE! All data, applications, even live wallpaper... When I opened menu, there we're only basic applications... It was just like after I have unpacked tablet from box (but Icons we're somewhere else, it was like I have just started another ROM). Well, ok (I thought) and I have launched z4 root APK from SD card. But suddenly it said that I can't install that, because I have full memory!

I looked at memory and - 1,5 GB free (in) and 15GB free (SD-card). I looked on internet (using google) and I've heard, that sometimes I need to clear /cache and some app data in /data. Well, so I have cleared /cache (through recovery) and than I have tried to download something from google apps (I needed to sign in again and now I have my same device twice in google play). But I cannot download anything - it say, that memory is full! I have then tried to install game (APK was in SD-CARD) called Inotia 3 and it normally installed.. LOL. I have tried reboot (I wanted to install that z4 root and root my device again to bring old ROM back) but .. WTF .. Inotia is GONE again and everything is again just like after factory reset!

So... there was just one way out left. Factory reset through recovery.. It's weird, that in recovery menu I can only move down... I cannot move up (I have buttons at the side of tablet - POWER, BACK, MENU) Well, I have selected total factory reset, confirmed, rebooted, AND IT DIDNT HELP.
So.. please, do you have any ideas, what can I do now?:thinking:

I need to install z4 root somehow. Maybe it's just stucked somewhere between root and no-root... I cannot do anything, because all changes are deleted after root...
Any help will be appreciated.