1. Check out our app, Forums for Android! Download and leave feedback here!

General Droid Eris Breaks LAN

Discussion in 'Android Devices' started by kgunnIT, Feb 28, 2010.

  1. kgunnIT

    kgunnIT Member
    Thread Starter
    35

    Jan 6, 2010
    12
    0
    35
    So I have a problem, as odd as it may sound. Every time I connect my Droid Eris to my home network, after a few minutes the network locks up. I can't access the router or anything on the network, no ethernet, wireless, nothing.

    The only fix is to unplug and plug in the router again from the power outlet, after I turn off the wireless on my phone. This "solution" is inconvenient as you can imagine.

    My network is controlled (routed) by a Motorola SBG900, I have a desktop XP machine that connects via a Linksys Wireless USB adapter, and a MacBook pro via Airport. My wife also has an iPod Touch that connects wirelessly.

    3G is great, but when I want to use apps such as GMote, I must connect to my network, which then brings it all to a crashing halt after some time. Any help would be greatly appreciated. I have tried both static and dynamic IP addressing, I have tried changing channels, I have tried just about everything I can think of. My LAN uses the standard 192.168.x.x IP scheme.

    Oh, and one more thing I should mention: I have connect my Droid Eris to a friend's network who also happens to use a Motorola SBG900 as well, and I have not had any problems on his network. Weird.
     

    Advertisement

  2. smacky

    163

    Jan 11, 2010
    2,844
    299
    163
    Try updating your router.
     
  3. aleis

    aleis Well-Known Member
    118

    Nov 14, 2009
    1,055
    33
    118
    what about specifying it by mac address...i just throwing things out there.
     
  4. SirSlayer

    SirSlayer Well-Known Member
    113

    Feb 18, 2010
    875
    455
    113
    QA Engineer
    San Diego, CA.
    Update the firmware on your router. May fix the issue.
     
  5. deno73

    deno73 Well-Known Member
    16

    Jan 9, 2010
    68
    2
    16
    machinist
    indiana
    Yeah have the same problem, but i noticed it before the phone even though I know it happens when the phone connects too. 2 laptops, xbox360, playstation3 and now the wifeys eris and mine. like you said just unplug for reset and good to go....we've gotten so used to it its kinda normal...." HEY SOMEBODY RESET THE MODEM " can be heard yelled through out the house on a daily bases.
     
  6. gruss

    gruss Well-Known Member
    163

    Feb 16, 2010
    1,411
    116
    163
    IT
    Toledoish
    Check the dhcp settings. Had a linksys that just stopped allowing things on the network. Go in adjust save and everything is fine for a few months then repeat. Had to do it again with the phones.
     
  7. weihl165

    weihl165 Well-Known Member
    38

    Nov 30, 2009
    296
    14
    38
    Same thing here.
     
  8. mistaj33

    mistaj33 Well-Known Member
    53

    Feb 6, 2010
    168
    32
    53
    Computer Consultant
    New Orleans
    Upgrade your firmware on your router. If that doesn't solve the problem, you need another router. The fact that you can connect your phone to your friend's identical router with no issues is proof.

    I buy a lot of routers and have been happy with D-Link lately. Specifically, the DIR-655 works really well for me and a bunch of my clients. I never have to reboot it. Just checked my up-time: 96 days.
     
  9. kgunnIT

    kgunnIT Member
    Thread Starter
    35

    Jan 6, 2010
    12
    0
    35
    The firmware is up to date. My suspicion is the router itself as well, however it can't be more than a year old, so I have a hard time believing that it needs to be replaced.
     
  10. pkopalek

    pkopalek Well-Known Member
    113

    Dec 19, 2009
    837
    117
    113
    Computer Technician / Systems Implementation Manag
    Buffalo, NY
    Many computer parts are like light bulbs. You never know when they're going to go bad. Could be five seconds after opening the product, or fifteen years.

    Things stop working. It's life.

    I've had 0 problems on my Eris, and I've connected to, literally, dozens of wireless networks all over the place. I use it for work, even. Probably a hundred or more wireless routers. I have _never_ experienced or seen this problem.

    I have my Wi-Fi settings to use Google DNS. I use a 'Static IP' (not really, all that is static is my DNS and secondary DNS) and set the DNS to 8.8.8.8 and 8.8.4.4. It helps with speed.
     
  11. kgunnIT

    kgunnIT Member
    Thread Starter
    35

    Jan 6, 2010
    12
    0
    35
    Yes, it's true, this will just be the second time I have to replace a router within the past year, which is frustrating.


    However, I have another hypothesis that I will try out today. I just remembered that my friend with the same router uses WEP encryption for his wireless, because his microwave interferes and he loses his Airtunes with WPA. I am currently using WPA encryption. Last night I changed the from WPA-TKIP to WPA-AES. I phone would connect to the network, get an ip address, but I couldn't ping my phone nor could I browse the web on my phone. So, I wonder if my Droid Eris simply does not like WPA, at least with this particular router. I am going to change to WEP encryption, even though it makes me cringe switching to WEP. It's on older, more easily cracked encryption, but I may not really have a choice. Here it goes...
     
  12. pkopalek

    pkopalek Well-Known Member
    113

    Dec 19, 2009
    837
    117
    113
    Computer Technician / Systems Implementation Manag
    Buffalo, NY
    WPA2, which I believe your Eris calls WPA Enterprise, might work just fine too, if your router supports it.

    I am using WPA, literally, right this second, with no trouble.
     
  13. kgunnIT

    kgunnIT Member
    Thread Starter
    35

    Jan 6, 2010
    12
    0
    35
    Yeah, I think there may be some sort of bug or something with WPA on the Motorola SBG900, since my friend also had problems with some devices using WPA. I may visit Motorola forums and see what I can find there or post a thread there. Unfortunately, the router does not support WPA2, so if WPA doesn't work for me, I have no other option but to use WEP, or go open (which won't happen). Thanks for the tip.
     
  14. pkopalek

    pkopalek Well-Known Member
    113

    Dec 19, 2009
    837
    117
    113
    Computer Technician / Systems Implementation Manag
    Buffalo, NY
    Try just having your network hidden.

    Don't broadcast the SSID with the router and use WEP. Without broadcasting, it's a lot harder to hack into.

    Just make sure you type in your settings EXACTLY on the Eris, how they have to be, capitalization and all.
     

Share This Page

Loading...