1. Are you ready for the Galaxy S20? Here is everything we know so far!

droid / exchange activesync / geotrust

Discussion in 'Android Lounge' started by suelizy, May 18, 2011.

  1. suelizy

    suelizy Lurker
    Thread Starter

    My corporate environment just installed a new geotrust certificate for exchange 2007 activesync. After doing so, all phones except droids were fine. They get the following error: "The certificate from the server is not validated."

    We did some research and found a lot of information saying that android hasnt pushed out the root certificate for geotrust to all of its devices yet, that it should be fixed in 2.3, but that even some on 2.3 still can't sync.

    I tested with my droid2 and could uncheck use a secure connection and it would sync but we do NOT want users doing this.

    Has anyone else run into this? What did you do to resolve it?

    Thanks!
     



    1. Download the Forums for Android™ app!


      Download

       
Loading...

Share This Page

Loading...