1. Are you ready for the Galaxy S20? Here is everything we know so far!

droid explorer

Discussion in 'Android Devices' started by Rastaman-FB, Dec 5, 2009.

  1. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    i managed to install it on windows7 x64 professional just fine
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    did you follow the steps i posted that pegasus gave me?
     
  3. camalot

    camalot Lurker

    A few people are reporting this, it seems to be an issue with vista x64. I am trying to track down the issue.
     
  4. briany

    briany Newbie

    okay. fortunately i've got another computer with XP on it, so I'll just install it on that one--problem solved.
     
  5. scollie

    scollie Guest

    I've managed to successfully install Droid Explorer on my Win 7 x64 PC but when I launch it, it shows '0 Devices Found'.

    I've been having an issue with trying to get adb to see my phone for weeks and have trawled all the forums trying various 'solutions' but no luck.

    I believe my problem is with the drivers from NPS which are required by adb but I'm not sure.

    One solution was to not install NPS but instead just find the device in Device Manager (DM) which had a yellow flag next to it and point it to a set of drivers that were provided in the solution; however I don't have a yellow flagged device relating to the phone in DM!

    Can someone (Rastaman-FB?) who has successfully got adb working on a Win 7 x64 system tell me what appears in DM in relation to the Galaxy?

    All I see in DM is
    ADB Interface
    Samsung Galaxy Composite ADB Interface

    There are no entries for the Galaxy under Modems or USB controllers. Should there be?

    I'm starting to doubt whether I'll ever resolve this issue!!
     
  6. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    thats all i see under ADB Interface is Samsung Galaxy Composite ADB Interface
    that would suggest your device is connected as an adb device correctly
    the modem stuff is only available when you install NPS

    when you connect the device and use ADB and type ADB Devices what happens? seems odd that it displays but you cannot use ADB

    try updating the driver and repointing it to my custom driver set here http://yardimage.co.uk/files/i7500/samsungADB.zip
    this should deffo work as they are the ones im using since android sdk does not include the correct drivers anymore

    [​IMG]
     
  7. camalot

    camalot Lurker

    Make sure you have USB Debugging enabled on the device under Settings -> Applications -> Development
     
  8. scollie

    scollie Guest

    I updated the driver to the samsungADB as you suggested but same result.
    I have always had USB Debugging enabled and have tried with the SD card Mounted/Unmounted but no difference.

    ADB devices shows
    List of devices attached


    and a blank line after it!

    ADB version shows 1.0.22

    ADB remount shows
    error: device not found

    You mention that the modem stuff is only available when you install NPS.
    I currently don't have it installed but when I have installed it in the past no Galaxy information has ever shown up under Modems.

    That is why I was asking what shows up in your PC. I thought for adb to work it also needed some libraries from NPS, is this correct?
     
  9. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    not that im aware of no
    odin needs some of the libraries but not adb
    my adb version shows 1.0.25
    im using a redownloaded version of googles modular sdk rather than the old one as its been completely decommissioned now but it was working on 1.0.20
    i find it odd that it lists the device there (in device manager) but cannot connect to it.
    is the device rooted? do you get the same if you boot into recovery without connecting the device, run ADB usb (so it starts the daemon) then connect the device and do adb devices?

    is it a RC version of windows7 or retail/RTM?
    you got full admin rights with UAC settings quite low?
     
  10. scollie

    scollie Guest

    My phone is rooted and running GalaxoHero rom and the driver I am trying to install is from http://yardimage.co.uk/files/i7500/samsungADB.zip which you mentioned in a previous post.

    I tried booting into recovery without connecting the device, ran "adb devices" ( not sure what you mean by "adb usb"?) to start the daemon, connected the device and ran "adb devices" again but no device shown.

    I am running a retail upgrade version of win7 x64, upgraded from XP (where I had adb working successfully!).
    I have full admin rights and I had previously also created an admin user to try getting adb working but no luck.

    My UAC settings were on "Default - Notify me only when programs try to make changes to my computer" - the second highest but I thought this only changed the notification level. I reset them to the lowest level "Never notify me", rebooted and tried again - same result.

    Apart from notification levels, are there other UAC settings I could try?
     
  11. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    very odd
    those drivers are the same im using cos i created them and hosted them.
    its wierd that it sees the samsung galaxy composite interface but you cannot do anything with it.

    try reinstalling NPS clicking ok to all the prompts and errors then turning off usb debugging then turn it back on again and connect device and see if it picks it up again

    im at a loss completely as apart from you upgrading from xp we are identical
    i did a fresh install of win7 pro 64 Retail
     
  12. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    ok found a fix for you and im sure its the same issue so ill write it up when i get home and add it to the FAQ as this deffo works

    go into device manager and uninstall absultely every samsung usb related driver including the ADB
    if it gives you an option to delete it click yes
    after all of the drivers are deleted, DO NOT connect the device and make sure you reboot your machine

    once you boot back in connect the device, windows 7 will try and auto find the drivers so click skip and it should fail.
    click here and download the samsung usb drivers
    extract them to a folder (default file name is good so you know which drivers they are)
    go into device management and right click samsung usb device. click update driver, click browse computer for driver software, click browse and point it to the driver folder of the file you just extracted.
    windows7 should install samsung galaxy usb composite device and then it should start auto installing the rest of the drivers

    It will now fail on one driver and should show in device manager as unknown device
    now this is the ADB driver.
    go to device manager click update driver, click browse computer for driver software, click let me pick, click all devices, click have disk, point that one to the usb_driver/amd64 folder you downloaded from yardimage and select samsung composite adb interface.

    jobs done
     
  13. scollie

    scollie Guest

    I'll give this a try shortly but before I do I'll just mention that this is similar to previous advice given by either yourself or Kam or maybe someone else and my problem as I have been mentioning all along is that apart form ADB Interface I have nothing else related to the Galaxy showing up in Device Manager(DM).

    When I connect the device win7 doesn't try and install the drivers and I have never had a samsung usb device show up!!

    This is why I was constantly asking what others had in DM in relation to Samsung.

    In XP I believe I had entries under USB controllers and Modems for the Galaxy, but nothing in win 7 and I think this is a major part of my problem.

    Anyway I'll give your suggestion a try and report back.

    Thanks for taking the time to help!
     
  14. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    Yes its because the samsung usb device driver has been pointex to the adb driver rather than the samsung usb composite driver so it can't fint the rest. I tested and reproduced your fault at work on your same setup and its easy to mess up if you don't do it in the order I specified.
    Good luck mate
     
  15. scollie

    scollie Guest

    Right we're getting closer but not quite there yet!

    I deleted the adb device and uninstalled all Samsung USB related drivers, rebooted my machine and connected my device.

    I could now see devices with missing drivers which I updated with the drivers you linked to in your post.

    Now in DM I can see
    Ports(COM & LPT)
    Samsung Mobile Modem Diagnostic Serial Port (WDM) (COM4)

    and under USB controllers
    Samsung USB Composite Device
    USB Mass Storage Device

    There was already a USB Mass Storage Device but there is now a second which is not marked as Samsung but the hardware Ids show it as
    USB\Vid_04e8&Pid_6601&Rev_0100&Mi_03&Os_NT
    USB\Vid_04e8&Pid_6601&Rev_0100&Mi_03
    USB\Vid_04e8&Pid_6601&Mi_03&Os_NT
    USB\Vid_04e8&Pid_6601&Mi_03
    USB\Vid_04e8&Pid_6601&Class_08&SubClass_06&Prot_50&Os_NT
    USB\Vid_04e8&Pid_6601&Class_08&SubClass_06&Prot_50
    USB\Vid_04e8&Pid_6601&Class_08&SubClass_06&Os_NT
    USB\Vid_04e8&Pid_6601&Class_08&SubClass_06
    USB\Vid_04e8&Pid_6601&Class_08&Os_NT
    USB\Vid_04e8&Pid_6601&Class_08

    It is not flagged with a yellow marker but I've tried pointing this at the driver folder and it tells me that the best driver is already installed.

    When I untick the "Show compatible hardware" box and scroll down I see Manufacturer Samsung which shows 3 models "Digimax 220", "E.M. USB Hub" and "USB Hub" and also Manufacturer
    Samsung Electronics Co Ltd and model "USB Composite Device".

    When I select the Electronics one and point it to the same driver folder as above it looks for an .inf file and says the .inf files don't contain the relevant driver.
    When I point it at samsungADB I get the same message.

    At this point I had debugging turned off so there is no "ADB Interface" in DM.
    When I turn on USB Debugging ADB Interface appears as a default ADB Device and I pointed this at the samsungADB drivers and it updated to
    "Samsung GALAXY Composite ADB Interface", however the other entries mentioned above under Ports and USB Controllers disappeared.
    They reappear when I turn off USB debugging but ADB Interface disappears

    I then tried running adb devices with debugging both on and then off but no luck.

    I'm just wondering whether I should have had USB Debugging on when I connected my device after rebooting?

    Unfortunately I don't have any more time this evening to try it again.
    Unless I hear to the contrary I will repeat the process tomorrow with USB debugging already on and see what happens then.

    I must admit when I saw the new Samsung entries appear in DM I thought we were there as I hadn't managed that before.
     
  16. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    try it again with debugging on
    the mass storage should just be default windows7, there is nothing special there and doesnt need specific samsung ones
    have debugging on when you delete the ADB driver please

    there will only be one driver left with an X in windows 7 hardware automation and in device manager it will just show a yellow exclamation with "unknown device" that is the last driver and is the samsung composite ADB interface


    is a red herring and not much to do with it, its mass storage and you shouldnt be messing about with that.
     
  17. ryko

    ryko Well-Known Member

    Hi started following this thread having had similar problem. I seem to remember that there is also a Nokia driver with the same date as the Samsung drivers that you have to unistall at the same time for this fix to work .(do'nt ask me why just hope it helps:))
     
  18. scollie

    scollie Guest

    Just read your reply but I don't have time to do this tonight. Hopefully I will get time tomorrow - so this is just a note to let you know that I'm still here looking for a solution and appreciating your help.
     
  19. scollie

    scollie Guest

    Thanks a million Rastaman-FB!!!!!!!!!

    I had another go with USB debugging enabled and after a little bit of messing around, adb works as does DroidExplorer.

    I think I'm fairly competent on a technical level (Oracle developer; Unix/Linux) but don't know much about windows - esp Win7. I think I would still be messing around trying to get this working at Xmas next year if it hadn't been for your help.

    So once again - THANKS!!
     
  20. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    no worries, glad we got there in the end :p
     
  21. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    hmm i cannot create new folders or files within droid explorer
    running windows7 professional x64
     
  22. camalot

    camalot Lurker

    That functionality is coming, i've had to put it on the back burner for the last couple releases because of some install issues, but I am working on it. Once I wrap up the couple issues I have, it's on the top of my list.
     
  23. Rastaman-FB

    Rastaman-FB Extreme Android User
    Thread Starter

    ahh ok so this is work in progress then?
    that would explain it. i wasnt sure if it was something broken or not

    thanks for the clarification
     
  24. cbuy

    cbuy Lurker

    Hi ! I'm new to Android (tech profile though), and was searching for a solution to my "pains" when I found this forum, which I find great. So, signed in... and here I am ! For now, I just have questions... hope to have answers in the future ! The thing is this:

    I bought a Motorola Milestone (the best cell phone I've ever seen). I learned all the necessary liturgia, and started messing with it: rooted it, then installed SDK, etc. I then began using ADB, which worked great. I could manage to install busybox without a flaw. Later, I installed de 2.0.1 SBF from Brazil, which is very nice. So far, so good.

    Buuuuut, then I installed Droid Explorer !!! In short, since then, ADB won't work any longer. I get the message "error: device not found". That's it ! It's a strange matter, because when I plug the device my computer "sees" it without a problem. I turn USB debugging on. I've tried even to run RSD Lite, which also can see the device.

    What's up ? Hope you can help me ! (And hope I can help anyone in the near future !)
     
  25. ryko

    ryko Well-Known Member

Loading...

Share This Page

Loading...