1. Check out our companion app, Forums for Android! Download from Google Play

Support Droid Incredible 2 stuck on Boot screen...help!?

Discussion in 'Android Devices' started by patti123777, Dec 4, 2011.

  1. patti123777

    patti123777 New Member
    Thread Starter

    Dec 4, 2011
    So I just recently got a Droid Incredible 2 by HTC on December 1st and it is now the 4th and already I'm encountering issues. I downloaded AVG antivirus onto the phone as I was advised to by my mobile carrier, Verizon. At first it was all good, and then I downloaded more apps like Netflix, papertoss, city story, etc. Not many though. Then I encountered an issue where I'm unable to send or receive MMS unless my mobile network is turned on and my wifi is turned off. <--that is annoying since I only have the 2GB plan. I read this could be due to Antivirus app so I uninstalled it from my phone and that didn't work. Before reinstalling it, I was watching netflix on my phone and it worked FINE. Later that night, reinstalled AVG antivirus and when I went into Netflix, the screen was black but all the bottom home keys were lit. Clicked out of there into antivirus and ran a scan, it said I had a "suspicious text message" some stupid add from verizon. So i DELETED IT thinking I fixed whatever issue with Netflix, turns out I didn;t and then my home key decided to stop working. I decided to just reboot the whole phone so I hit restart and now everytime it gets stuck on the Droid eyeball thing that appears right before the main screen. All the bottom keys light up to but with no function.. I took out the battery three times and tried charging my phone but nothing has worked. Help?


  2. Sounds like factory reset time. I think you can get there by holding the volume-down button while turning the phone on.
    TheAtheistReverend likes this.
  3. blackepoxy

    blackepoxy Well-Known Member

    Jan 14, 2011
    Oyster shucker blacks oyster bar
    Dirty South, Louisiana
    Yep, the home key does nothing and hitting back just cycles you through the last 3 things you opened. hTC sense on your phone has locked up. (disappeared, 0.00 and all options grayed out in manage applications) I too restarted the phone only to be stuck on the eye, pull the battery leave it out for a full minute put it back put back on the cover and hold volume down and press the power button down for about for seconds then let the power button go, this will bring you into Hboot, use the volume down button to highlight factory reset and press power to confirm.
    This will put you back in action...

Share This Page