1. Are you ready for the Galaxy S20? Here is everything we know so far!

Droid Mini stopped connecting with wifi

Discussion in 'Smart Home' started by rick12, Feb 15, 2016.

  1. rick12

    rick12 Newbie
    Thread Starter

    My Droid Mini (Android 4.4.4) stopped connecting with our home wifi in January. In December we got a new FIOS Gateway router and added another Roku player. I asked the rep at Verizon if there is a limit on the number of devices that connect, and he said there isn't. I tried everything I could find on the web to fix it, including doing a hard reset on the phone. One night, after resetting the router, turning wifi off and on on my phone, forgetting our network in my phone and re-entering the password several times, connecting with WPS, and turning off all other devices in cases my phone was trying to grab the same IP as another device--all these done several times--it finally connected. Meanwhile--and here it gets crazy--our two Rokus, our two Kindles, my laptop, and my wife's phone all connected without a problem. To find out if the phone was defective, I went to a local bookstore and turned wifi on, and it connected without problem. Finally one night it connected, and I have no idea what mix of "fixes" I did that worked.

    Yesterday it started all over. It wouldn't connect for awhile, then connected, then disconnected. I went to a museum and a restaurant during the day, and my phone connected with their wifis without a problem. This morning it isn't connecting at home again.

    So there's something about my phone and my router that's the problem. Sometimes the network shows up in the list with the line, "Saved, secured with WPA2," and sometimes it doesn't show up at all. When it does, I tap on it, forget the network, re-enter the password, and it gives that message again and doesn't connect.

    Is there anything else I can try? Serious responses only, please.

    1. Download the Forums for Android™ app!


  2. rick12

    rick12 Newbie
    Thread Starter

    Problem solved.

    I have a FiOS Quantum router. I had noticed that the phone didn't pick up any wifi networks on the 5.0 GHz frequency, but I just thought it wouldn't operate on that frequency. By chance I saw something on another website about devices not connecting with 5.0, so I followed the suggestion of getting into the router settings and manually setting a channel for that frequency rather than using auto. I did, and the phone immediately connected. I set it on channel 36 (or 39?) first, and the reception was poor at the other end of the house. So I tried a couple other channels, eventually ending up on something like 157, and I have the best connection I've ever had that distance from the router (a download test showed something like 84 mbps).

Share This Page