1. Check out our app, Forums for Android! Download and leave feedback here!

Support Droid X, never rooted. never messed with the phone

Discussion in 'Android Devices' started by ndfan4u, Sep 22, 2010.

  1. ndfan4u

    ndfan4u Well-Known Member
    Thread Starter
    38

    Jun 13, 2010
    223
    10
    38
    Los Angeles
    Ok, I have a big problem with my Droid X. I have never rooted or messed with the phone precisely because I didn't want to have problems come FROYO day. I went to download the update that I received notification as being available and now I have a black screen with the Motorola Logo M in the center. I doesn't shut down. I took the battery out and the M comes back. What do I do now?? Anybody else having this problem??
     

    Advertisement

  2. mchung53

    mchung53 Well-Known Member
    58

  3. in2uition

    in2uition Well-Known Member
    68

    Aug 13, 2010
    444
    215
    68
    Philly
    For me, I ended up doing a cache wipe and factory reset. Then I pulled the battery out for 30 seconds, put it back in and it worked fine.
     
  4. Old Man

    Old Man Well-Known Member
    43

    Jul 19, 2010
    271
    37
    43
    Marietta, GA
    Yes, others do seem to be having the same problem. I was also stuck on the Motorola logo after the update despite no root, no leaked Froyo and running stock Blur. After reading some posts here and on other forums I tried multiple battery pulls but they did not resolve anything. Took it to a local Verizon store and they could also not get past the Motorola logo, so I now have a replacement phone on the way. The techs at the store did note that three people had already brought in their Droid Xs with the same problem and mine was the first that either a battery pull or installing a fresh battery would not fix, but it looks from the comments here that several people have had to get new phones.

    In2uitiv, how do you perform a cache wipe and factory reset on a phone that is stuck on the Motorola logo?
     

Share This Page

Loading...