1. Are you ready for the Galaxy S20? Here is everything we know so far!
Thread Status:
Not open for further replies.

Droid X - Stuck at M logo, Won't boot into recovery HELP!

Discussion in 'Android Devices' started by aloha312, Aug 28, 2011.

  1. aloha312

    aloha312 Lurker
    Thread Starter

    I have looked at many other threads and have not been able to solve this problem.

    I purchased a Droid X from eBay. There is no water damage to this phone, but I know little else about this phone's history.

    ISSUE:
    The phone is stuck at the M logo. I have SBF'd to VRZ_MB810_3.34_1FF_01 through RSD lite (and via linux CD). RSDLite works fine. It asks me to manually reboot the phone at the end and I do this by starting the phone back up in bootloader mode. The progress in RSDLite lists that the process is finished, but I am still stuck at the M logo when I turn on the phone.

    I have tried to boot into recovery mode by pressing the home button and the power button unsuccessfully (then releasing the power button while still holding the home button). I have tried to battery pull and repeat for varying periods of time.

    Any ideas on what else I can do to try to save this phone?
     



    1. Download the Forums for Android™ app!


      Download

       

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...