Help Droid X won't download from the market.


So earlier I noticed I wasn't getting any notifications on my Droid X from Facebook or Twitter.

I had figured it was an issue with GoLauncher EX which I had installed a day or two ago, but upon uninstalling the issue continued, along with the phone's inability to connect to wifi.

So I attempted to redownload the launcher from the market, and noticed it got stuck at "downloading" then it appeared to proceed to cancel itself in the notification bar. Going back to the market, I was just given the option to download it again. I tried, and the same thing happened.

Browsing the internet, a lot of people seemed to say to try a factory reset. Doing that got no results, but now I have the OLD marketplace, and can still not download or update any apps. It also doesn't make the "click" on unlocking anymore, I have no idea if that's signifigant or not.

I've tried clearing the cache of the marketplace, a factory restore (obviously), and a battery pull, and I haven't uninstalled or messed with google talk in any way, literally, i've never even used it. If anyone has any advice outside of going back to a verizon store nearby and having them replace it, it'd be greatly appreciated.

Thank you.


Exact same problem here. I get about 10 seconds of an attempted download (with green arrow in the notifications bar) and then suddenly it just ceases. I've tried logging out of / into Google talk, and even force stopped the Google Services Framework -- which made the Market completely inaccessible for a time -- and still no dice. HELP


Android Expert
Had the same issue night before last (so the 1st). It would show up in the notification bar then just disappear. Figured it was a market issue, so I gave up. On the new web version of the app store it even showed I had the app installed when I was looking around yesterday. I just tried again, and it's fine. Ahhh glitches, gotta love 'em.


Android Enthusiast
Bluenova, exactly. I figure it's a rollout issue that will be resolved over the next hours and days.
I have had this issue before too. I mostly notice it when I've switched between wifi/3g during an automatic update. To fix it, I go to the market, go to my downloads, stop the offending download, and click install. That has gotten them to start right up without a hitch for me!