1. Are you ready for the Galaxy S20? Here is everything we know so far!

DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf)

Discussion in 'Android Devices' started by themib, Aug 18, 2012.

  1. themib

    themib Android Expert
    Thread Starter

    updated many times see change log

    Root Only
    [ROOT] Framaroot, a one-click .apk to root
    I have verified it works with these Motorola devices running android 2.3.4
    Droid 2 (a955), Droid 2 Global (a956), R2D2 (a957), & Droid X (MB810)

    Just download, allow unknown sources, install, open, select top root method (Gimli), reboot phone, done

    no pc needed.


    Flash Original Stock Firmware with ezSBF

    Steps 1 through 6 need to be followed exactly.
    1. Download an .iso file (Droid_X_621-SBF-and-RootCD-2nd_edition.iso)
    a. Verify the file was downloaded correct with MD5/SHA-1 Hash Checksums
    2. How to use the .iso disc image file (use one of the options a-e)
    a. burn to CD (Windows)
    b. burn to CD (Mac)
    c. mount to usb drive with unetbootin (Mac/Win/Linux)
    d. Using Oracle VM VirtualBox
    e. Burning .iso from Ubuntu
    3. verify files created on CD/USB are correct
    4. charge battery/ low Battery options
    5. reboot pc from cd or usb
    6. Follow onscreen instructions

    ezSBF 2.3.4/4.5.621 & Magic MD5 Root
    DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf) (213mb)

    instructions and downloads posted DX (MB810) ezSBF & Root 2.3.4/4.5.621 (no milestone .sbf)- Google Docs

    How to verify the file was downloaded correct with
    MD5/SHA-1 Hash Checksums

    what is ezSBF?
    original [TOOL] ezSBF (not for 2.3.4)


    Hit enter at the yellow "boot baby... boot" screen
    You will see yellow dots for 3-5 minutes then the script will start



    basically read onscreen directions

    select DX
    don't use numbers on right side of your keyboard, just use the ones above qwerty

    turn phone on, connect to pc with usb cable

    check usb debugging (settings/apps/development)
    select charge only usb mode in top status bar

    press continue
    adb will push
    Code (Text):
    1. data/local.prop /data/preinstall_md5/magic.md5
    program will prompt you to
    manually reboot phone to bootloader (Hold volume up+down buttons and power button, or hold Vol.Down and Camera and wait for the screen to flash)
    program will will be flash repacked sbf (less than 50mb)
    Program will reboot phone twice, very important (reboot just replaces the local.prop, but the old local.prop is still in memory, till second reboot)
    adb pushes su,superuser, and busybox
    program will reboot to recovery,
    manually wipe cache (should auto reboot to recovery, at android andy press both volume buttons, if it doesn't press home button and hold it in then press your power button, hold it in also till you see a triangle on the screen w/ android andy then press both volume buttons)
    then select reboot

    error info
    when running the program you may see these errors

    rm failed for /data/preinstall_md5/magic.md5 no such file or directory
    no root.img.gz no such file or directory
    rm failed for /data/preinstall_md5/magic.md5 read only file system

    that is fine, it will still work

    after flashing files in bootloader, phone reboots to bootloader, instead of normal android operating system..... now what?try disconnecting usb, pull battery,wait a few secs, replace battery, reboot, wait for reboot to complete, reconnect usb

    Using Oracle VM VirtualBox, and Magic MD5 root iso

    If you planning on making nandroid backups or flashing roms
    read [HOW TO] Install/Use Droid 2 Bootstrap

    bhigham[/URL]/beh modified the root method
    based on New D2 root method for stock 2.3.4 (621/622) found (Droid2, R2D2)

    How this works

    My Lists

    Magic MD5 Root 2.3.4 for D2, R2D2, D2G, DX and 2.3.5 for DX2 - Google Docs

    sd_shadow's [Collection] of Links: FAQs, Guides, Rooting, SBFs, ROMs... - Google Docs

    13 sept 2012: added bootloader and recovery instructions
    02 Oct 2012 added mac info
    10 Oct 2012 added error info
    18 Dec 2012 major rewrite
    09 March 2013 added ezSBF link
    26 April 2013 added Framaroot link
    10 May 2014 reordered things

    1. Download the Forums for Android™ app!


  2. 1aushell

    1aushell Lurker

    Wow, seems simple enough. Now I have a few questions (yes, I am new to rooting).
    1. reboot phone to bootloader. Is this a menu option?
    2. flash repacked sbf. Does this happen automatically? Is there a file name I need?
    3. Reboot twice. How do I reboot? Do I turn the phone off/on or is there a special combination of buttons?
    4. reboot to recovery and wipe cache are probably menu options.
    5. reboot normally. How do I reboot normally?

    Thanks for being patient.
  3. themib

    themib Android Expert
    Thread Starter

    you need to reboot to bootloader manually
    flashing will be done when you click continue
    phone should reboot twice, just wait for it to completely boot before clicking continue, or it might skip one reboot
    it should reboot to android recovery
    at ! in triangle with android andy, press both volume buttons to enter recovery
    choose wipe cache, comfirm
    wait for it to finish
    choose reboot in android recovery
  4. Deleted User

    Deleted User Guest

    Wow, that was easy. Easier than SDB/SBF or whatever I've used in the past.
    So, now that is done, what is different then factory image and root?
    Do I now need to update or flash the latest OS? Use root keep and flash .621 again?
    I'm on 4.5.621MB810
    Droid X
    Build 4.5.1_57_DX8-51
    I think I have the latest everything, root, and antenna (15P) what ever that means.

    I didn't loose a single app. That was a great tutorial!
  5. themib

    themib Android Expert
    Thread Starter

    no, your done, install bootstrap, make a nandroid, freeze bloat, install v6 supercharger, flash a rom, or what ever you what

    ok reread, your post

    rooted means you can now alter/remove system files/settings
    nonrooted you can not do any of the things I listed
  6. sbasco

    sbasco Lurker

    I did your rooting method and it worked awesome but I'm having trouble finding any custom rom's that will run with my rooted .621. If you have any clues that would be great. I already put bootstrap on and a freeze bloat, I've already shut off the nonsense verizon junk now I just want to really customize it.
  7. themib

    themib Android Expert
    Thread Starter

  8. Contact a moderater to make this a stickey
  9. 4.5.621 was a lesson to us all. Brand new OTA ... install it. Six months later I have regained root.

    Thank you.

    ... Thom
  10. themib

    themib Android Expert
    Thread Starter

  11. cougar214

    cougar214 Android Expert

    Hey guys. It's been a while since I have stopped in. I'm assuming this is a root method for the infamous .621 and you no longer need the milestone files? Is that correct? Any roms come out for the .621 yet?
  12. themib

    themib Android Expert
    Thread Starter

    any dx 602 rom should work
  13. sethc

    sethc Lurker

    When I click on the Droid2_D2G_DX_DX2-RootCD-2012.iso link it takes me to Mediafire. When I click to download the file it either: 1. reloads page and download button. Or, 2. saves to My Downloads from (after I decline the FULL-DISKfighter advertisement)...but it never actually saves. The transfer rate continues to say "calculating" the whole time.
  14. themib

    themib Android Expert
    Thread Starter

    try a different browser or download from phone and transfer to pc
  15. ssm14293

    ssm14293 Lurker

    I know this is the most common topic here (kinda), but none helped me.
    I own an Android 2.3.4 Build GRJ22
    It is Qmobile A5,google it... cant post the link
    Now the problem, I tried to root it with SuperOneClick Root at least 10 times but the app hangs (for an hr) then I had to force Close it.
    I tried to find every where but it did not seem to help. Hoping to find some answers here.
    I have rooted many phones before including HTC, Motorola and Huwaie, but mine one seems to work on it. even z4root froze and force close dialog appeared.

    My PC Specs:
    • P4 3GHz HT
    • 3.5 GB RAM DDR2
    • Windows 7 Professional x64

    Phone Specs
    • MT6573 650 MHz Processor
    • 213MB RAM
    • Android version : 2.3.4 GRJ22; Release Codename : REL; API LEVEL : 10;
    Can I root my android with your software? Is it safe to do so because i cant download a recovery image as none is made for it.

    Salik Sadruddin
  16. themib

    themib Android Expert
    Thread Starter

    no, this will not root your device
    no, it is not safe for non-moto devices
  17. BSH

    BSH Member

    I just got a second-hand DX, and having a hard time getting root. At first, it looked like it worked, so I installed Bootstrap for Droid X, and flashed Ky's modded 621. Then ran into a bad loop upon setup, and had to SBF. I'm trying the whole process again.

    Upon beginning the root process after booting this cool linux live CD, it gave an error very early on, something about an /MD5 not being found, it but continued the root process right through to the end. Could this have had something to do with the problems I've been having? If I continue to have problems, how could I correct the issue?
  18. themib

    themib Android Expert
    Thread Starter

    you first issue, bootloop is a bad rom, or you just needed to wipe data again

    the md5 error is a , does not effect rooting, it's working if you can use bootstrap
  19. BSH

    BSH Member

    Ah, there's the rub. After using Ubuntu live to SBF the 621 file here from 1KDS, I wiped cache and did factory reset. I then applied root using the ezCD method and the multi-device live-boot Linux CD, selecting to root the Droid X (with USB debug and non-market apps enabled). I wiped cache again, just to be safe. I installed the Droid X Bootstrap. But Bootstrap gave me a blank screen. I could select anything - backup/restore, flash zip file, reboot, wipe cache - when I hit the power button to execute, I got a blank screen and had to pull the battery.

    For some reason, the Droid 2 root CD did not work for me - it got a kernel panic every time I tried it yesterday. I was able to load the 604 sbf, but that's not where I wanted to be.

    BTW, the loop I was referring to above was not a boot loop, it was a setup loop. I was stuck setting up accounts, and it would not let me say "done setting up accounts." Can't figure that either. Anyway, stock SBF set that right.

    After getting root, I was able to freeze a bunch of bloatware with Titanium Backup. I was able to boot to recovery. But once in Bootstrap recovery, I could go nowhere. I wonder of Bootstrap is flawed, because the rest of the system seemed okay. I had done full wipes, so the system should have been clean. Heck, I rooted over a system that didn't even have any user set up, I skipped setup and only turned on USB debug & allow non-market apps. Oh, and having the phone on 'charge only' did not work for me; I had to set it to PC mode. I'm running through the whole process again now. The one glitch in the process, at the very early stage of running the root says: rm failed for /data/preinstall_md5/magic md5/magic.md5. No such file or directory. (there's a letter missing at the beginning I can't make out, because it's off-screen). It doesn't do anything at that point, but then I reboot to bootloader, and it proceeds normally.

    Thanks for looking at my post.
  20. BSH

    BSH Member

    I am just not getting a good root out of this. Tried again, and this time TiBu couldn't get root access, even though SU was installed & updated, and Root Checker said I had root, and I could rummage around the root directory with the ES file manager. Last time, it was the failure with Bootstrap (which I didn't even try this time, if TiBu didn't work). Man! Maybe I'll just stick with my Eris! Could it possibly be that, as another person suggested somewhere else, a Motorola-brand USB cable is necessary? (the cable I'm using is Pantech, but has a Verizon V-cast tag on it, so I thought it would be okay) Or, isn't there a pre-rooted 621 sbf file somewhere I can plug in through Ubuntu?
  21. themib

    themib Android Expert
    Thread Starter

    i'm guess in tibu didn't work because you missed the allow/deny time, sometimes happens
    open superuser and change tibu to allow

    cable may be an issue, but if sbf went fine, root should work

    also could try updating superuser, if you can go through all the update steps you are rooted
    or use root basic or voodoo ota to verify root status

    not that I know of
    just this and the 1kds milestone 604 ezSBF
    someone with a x2, had trouble keeping root and flashing roms
    I made a nandroid of my eclipse rom, he was able to flash that, and keep root
    you could try something like that, post in the rom thread you want, and ask if someone could upload a nandroid to mediafire or db
    not a great option, but it may be your phone, has a hardware problem
    BSH likes this.
  22. BSH

    BSH Member

    Thanks themib. Hardware problem is definitely possible - after all, it's an Ebay phone ;)

    Before I go mucking up my (currently) good root by installing Bootstrap, let me ask a couple more questions. I bought the Droid X version of Bootstrap, but I've seen other threads where people install the D2 version. Does it make a difference, if so which is better for the X? If I have Bootstrap, I don't need Rom Manager, right? Does Rom Manager substitute for Bootstrap, or no?

    Thanks again.
  23. themib

    themib Android Expert
    Thread Starter

    dx bootstrap only worked with froyo roms

    install d2 bootstrap
    then install rom manager
    update cwm in rom manager to dx 2nd init
    should work

    edit: on stock rom, use rom manager to boot to cwm
    on custom roms you can use the roms boot to recovery if it has one, usually press power/reboot/recovery
  24. BSH

    BSH Member

    Okay, this phone just won't work with CWM at all. I followed those directions exactly. Rom Manager would not boot to recovery, only to a regular phone reboot. Quick Boot will boot the phone to regular phone recovery, but not CWM recovery. I go into Bootstrap and tap "bootstrap Recovery" and it says success. I hit "reboot recovery" and it boots into recovery, but has the same problem as before. Selecting any item and pushing the power button to execute leads to a blank screen. Hitting power again brings back the recovery menu screen. I have root, but I can't even make a Nandroid backup (or restore one, or flash a zip file, or even reboot) because I don't have CWM recovery.

    I accidentally bought two DXs on Ebay, so I'll be interested to try this process on the other and see what the result is. I may have to give up on flashing any alternative rom, but just be satisfied to have TiBu functional.

    Thanks again for your help.

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
Similar Threads - MB810 ezSBF Root
  1. enby_dashie
  2. Yesi Trotamundos
  3. Yesi Trotamundos
  4. Yesi Trotamundos
  5. asiopat9
  6. kumaranil13k
  7. CrunchyShadow
  8. kumaranil13k
  9. Please Help52
  10. MaxIQ

Share This Page