1. Are you ready for the Galaxy S20? Here is everything we know so far!

DX Not Syncing All Email Accts and won't send corporate email

Discussion in 'Android Devices' started by rmgetts, Nov 2, 2010.

  1. rmgetts

    rmgetts Lurker
    Thread Starter

    I have searched and haven't been able to find any threads with one of my issues, so I apologize in advance if I missed one...

    Anyways, my DX has been working flawlessly since I got it back on 10/6. Sunday, 10/31, my DX quit syncing just my corporate Exchange 2003 emails, then yesterday it started not sending emails as well and now, this morning, it quit syncing my personal email. Coroporate email will sync manually, just not push.

    I have rebooted several times, pulled the battery several times, and also deleted both my Exchange account and my personal account and re-added both and the problem still persists. I don't have any task killer apps installed and haven't recently added any apps since the issues started. Anyone have an idea what may be causing the lack of push (in and out) on both of my accounts?


    1. Download the Forums for Android™ app!


  2. ekyle

    ekyle Android Expert

    This seemed to work for a person that posted something similar to this yesterday.
  3. rmgetts

    rmgetts Lurker
    Thread Starter

    I am not running any task killing apps, never have on the DX.
  4. GTPprix

    GTPprix Member

    Ok here is what I did, although I think the last step is actually what did it :)

    1. Cleared the Cache
    2. Cleared the Email Cache
    3. Installed the Android Power Control Widget on one of my home screens and cycled the sync button. When I restarted the phone my email pushed immediately and now seems to be working.
    rmgetts likes this.
  5. rmgetts

    rmgetts Lurker
    Thread Starter

    Clearing the cache seems to have worked...thank for your help!!
  6. This problem just started for me today also. Won't sync any of my accounts automatically. I cleared the cache...actually reformatted the cache partition. Error message at the bottom of the screen said it couldn't open the cache so that was my only option. This didn't seem to help. My next step is clearing the email cache but I can't figure out how to do that. Any help is appreciated.
  7. lennydude

    lennydude Android Expert

    good question...............how does one clear the cache's ????
  8. I got mine working again today. Seems to have been a problem with one of 3 apps that have been acting up: F+, Facebook for Android, or Acar. I updated the first 2, force closed the last, rebooted and it immediately started to sync my email accounts again. Hopefully it will remain that way.
  9. Gummibands

    Gummibands Well-Known Member

    OMG This is the second time this has happened to me. I have the Data Push checked and the fetch schedule set if the data push is unable to but the fetch schedule doesn't even work. This is highly irritating and is has happened to me several times. It's making me consider purchasing a BB on my next upgrade if Motorola is unable to deal with a simple email issue.
  10. Gummibands

    Gummibands Well-Known Member

    I have no apps on my phone that would have affected my emails. So it's not that. What happened the first time was it just stopped working and then it started up again by itself and then it stopped working again, but at the same time I'm having the issue where I can't even call or pick up phone calls. Meaning I can call, I have signal, but there is no dial tone, not ringing going on nothing, I can't hear the other person even though I'm connected until I restart my phone and I'm fine. So I'm not sure if it's my phone or what.
  11. ScubaCA

    ScubaCA Member

    Sometimes it sends, sometimes it doesn't. I could be working and send a boat load of emails only to see that they are still sitting in my outbox, virtually lost in cyberspace. I am also convinved that the fetch schedule thing is crap because my phone can go 30,45, 1hr, 2hr, or 3hrs before getting emails that were originally sent to me hours before. What sucks even more is that I cant even open the emails that are in the outbox and save them to be sent later so I dont have to retype them, I only have the option to delete them. I find that sometimes that it happends after I use the 3g mobile hotspot...?

  12. Gummibands

    Gummibands Well-Known Member

    There is about two more threads on the first page about this. Thought I'd post so that people would stop making duplicate threads on this matter. Apparently my corporate account started working today. I don't want to get tidbit this phone if I dont have to but I got this for the email and Internet and if one doesn't work then there is no point in having this phone.
  13. draconius

    draconius Well-Known Member

    Welp...nothing is working. My main gmail account is the culprit. I have cleared my cache, toggled my auto sync in SwitchPro, rebooted my phone, uninstalled Facebook, and even gently pet my phone and my main account won't sync, send emails or do anything. My secondary (another gmail account) works perfectly.
  14. Gummibands

    Gummibands Well-Known Member

    So I called verizon and they said that this is a known issue with these phones. That motorola is well aware of this issue and that the only thing that they can do is exchange out the phone itself since its something wrong with the phone, but when I pointed out that they syncing and what not is due to programming and not the device itself the individual on the phone didn't know what to do or say. So this is a motorola issue. I would say go over to the motorola site and create a ticket and get enough people to say it's and issue.

    Here is the link that has like 1,000 plus posts on the very issue.


    You can send motorola an email explaining your issues and they will if they deem it enough of an issue issue you a touchdown email thing and you can get touchdown for free instead of paying for it. However Froyo was promised to fix these issues and as it is evident it didn't.
  15. 2horses

    2horses Android Enthusiast

    The only problem froyo was supposed to fix was the lack of notification. Have y'all tried just deleting your email account and then adding it back?
  16. Gummibands

    Gummibands Well-Known Member

    Actually if you knew anything about Froyo you would knowthat it was never put out to solve one issue. That would be a waste of money for Verizon and Motorola and everyone involved. Second Froyo fixed many issues including smaller issues that they held the update back for to fix that users informed Motorola of near the end.

    I have done a soft reset, a hard reset, deleted accounts and readded them, I have done *228, I have cleared my catche, etc. I have done everything plus that Verizon has reccomended including reloading my apps one by one even though none of them have anything to do with my email system at all. It's a device known issue according to Verizon and Motorola.
  17. 2horses

    2horses Android Enthusiast

    Actually, I should have been a bit more specific and said that all froyo was supposed to fix *for email* was the notification problem. I am well aware of all the many things that froyo did or was supposed to address. Sorry your email isn't working, I have touchdown (got it free when they offered it long before froyo came out) and have not had an issue. Are you going to get a new phone now?
  18. Gummibands

    Gummibands Well-Known Member

    No I'm planning on emailing Motorola and getting a free touchdown account since they are still doing that according to Verizon.
  19. locoandroid

    locoandroid Well-Known Member

    I just started having this issue,the X was working flawlessly and just out of the blue is a complete lag of sync.How do I clear the cache (email / cell)? Thanks in advance.
  20. ns1

    ns1 Lurker

    Hi All:

    Love my Droid X, but had the same corporate sync issues that you're discussing here. Corporate sync with Exchange Server worked great for quite a while, then email was "stuck" in the Outbox. Additionally, I didn't realize that my Contacts and Calendar stopped synchronizing as well. I was able to receive email just fine.

    The first time this occurred, I simply pulled and re-inserted the battery. With a good 3G signal in range, the issue was fixed. The second time this occurred just yesterday, it was not as simple to fix it.

    Here is the procedure that I followed to fix the issue. Some of it is a compilation of steps that others have posted, plus those that resolved the issue for me. I did perform each of these steps. This process assumes that no changes were made to your corporate account or corporate server to cause disruption. For me, no changes were made at the server-side or device-side, but the synchronization quit on me. In both cases, it started when the phone put itself into Battery Saving Mode and my 3G signal was weak. This combination caused the issue in both cases.

    PERFORM THIS PROCEDURE AT YOUR OWN RISK! Make sure your Exchange Server mailbox and settings are backed up, and your Droid data and apps are backed up. Also, there is no guarantee that this will work for you, but it did work for me. And check with your carrier to ensure that the selections will not cause additional billing to your plan. In other words, you assume the risk for this procedure and the results/consequences that it produces. If you have reservations about your ability to perform this procedure, have your IT Department or service provider try it. No warranties of any kind, neither expressed nor implied, are offered. Sucks when it comes to having to state all of this when you're explaining how you solved a problem!

    1. ON YOUR DROID X, delete your Exchange/Corporate email account. Obviously, DON'T delete your account from the server.
    2. On the Exchange server, right-click your mailbox and select "Manage Mobile Device" (Exchange Server 2007)
    3. Delete/Remove the MOTOBLUR30 device from the list.
    4. Remove the battery from the Droid. Re-insert it after about 15-seconds. Power up the unit.
    5. On the Droid. Go into SETTINGS:
    a) Background Data: Enabled
    b) Data Roaming: Disabled
    c) Data Enabled: Enabled
    ii) Back at the SETTINGS menu, go into the BATTERY MANAGER and set BATTERY MODE to "Performance Mode"
    iii) Back at the SETTINGS menu, select WIRELESS & NETWORKS and attach to a local Wi-Fi network that is high-speed.
    iv) Back at the SETTINGS menu, go to ACCOUNTS and add your corporate account back in again.
    v) Back at the sETTINGS menu, go to DATA DELIVERY -> EMAIL AND CORPORATE SYNC -> EMAIL DELIVERY. Set as follows:
    a) Data Push: Deselected (Feel free to turn this on later if you wish, but lets keep it simple for now)
    b) Fetch Schedule: Every 15-minutes (Again, set this to whatever you'd like after the first sync)
    c) Sync over Wi-Fi Only: Deselected (Your call)
    That's it! Open your corporate email and try to sync. Give it 3-to-10 minutes before you expect to see email flowing in. While it'll likely be much shorter, your servers may be set up differently from ours.

    I hope this works for you. I owe thanks to other posters who had posted different components of this process. Ultimately, this process resolved my issue, until the next time. I'm sure I'll be searching for this post when I need to remember how it was fixed.

    By the way, my Droid is running version 2.2.1 software. At the time of this posting, there were no updates available that I or the phone were aware of.

    Good luck!


Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date

Share This Page