1. Download our Official Android App: Forums for Android!

Support E-mail "push" problem

Discussion in 'Android Devices' started by Clint1583, Aug 26, 2010.

  1. Clint1583

    Clint1583 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    25
    0
    15
    When I first bought the DX, my Comcast e-mail would always automaticly appear on my phone. Recenty I've noticed that some of my e-mails aren't being "pushed". I have to manually go into the e-mail app and refresh the program. I've tried turning the phone on/off and taking the battery out but it some times still won't "push" e-mail's like it should. All my e-mail settings are correct. Any idea's??? Anyone ever have this problem?
     

    Advertisement

  2. NickDroid86

    NickDroid86 Android Enthusiast
    Rank:
    None
    Points:
    83
    Posts:
    509
    Joined:
    Apr 18, 2010

    Apr 18, 2010
    509
    21
    83
    Largo, FL
    I have the same issue.. In fact, when I know I have an email but its not in my inbox I have to refresh multiple times...
     
  3. Deathshead

    Deathshead Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    173
    Joined:
    Oct 29, 2008

    Oct 29, 2008
    173
    15
    38
    you can try k9 mail free on the market, I have found that it pushes mail faster for some reason then the stock mail app.
     
  4. aclone

    aclone Newbie
    Rank:
    None
    Points:
    15
    Posts:
    17
    Joined:
    May 19, 2010

    May 19, 2010
    17
    0
    15
    Des Moines
    +1 for K9. I can't get my email account to work with the stock email because I need TSL and K9 works pretty well. Only problem I see is that it actually sends notifications when I don't have new mail...but better that than not sending them when I have it.
     
  5. e5116

    e5116 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    142
    Joined:
    Apr 20, 2010

    Apr 20, 2010
    142
    23
    38
    I've had this issue intermittently for the past few days. My phone would ALWAYS get the e-mail seconds before my computer (gmail) in the past and after I changed some settings to optimize my battery life, it seemed to be extremely fickle. I had to manually refresh a few times in the past, but now it seems to be working once again (although it's behind my computer, sometimes by a few seconds and sometimes by a few minutes, which I can deal with). Not sure why it's working all of a sudden as I didn't change anything.

    I have sync on, data timeout to 15 minutes, data delivery background data checked, and wifi sleep policy as never....it appears to be working once again. I did a bunch of test e-mails to myself to see the speeds, as after having a day or so getting used to the new settings, I guess gmail has figured it out. ;) But honestly, I don't know why it stopped working and started working once again for me...
     
  6. NOLAaustin

    NOLAaustin Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jul 15, 2010

    Jul 15, 2010
    7
    1
    6
    Austin, TX
    I had the same problem with my email pushing until I found a solution yesterday.

    Hold your finger down on one of the screens where there is a blank spot and it will bring up the "Add to Home Screen menu". Choose Android Widgets and then choose to add power control.

    For some reason my sync button on this power control menu was turned off. Just make sure it is on and hopefully this will fix the problem.

    Good luck!
     
  7. dimitri407

    dimitri407 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    239
    Joined:
    Jul 21, 2010

    Jul 21, 2010
    239
    16
    38
    IT
    Orlando, Fl
    I see this issue with my Exchange. It seems to update on the fetch schedule even though the Push Option is checked in Settings.
     
  8. kensdavid

    kensdavid Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    141
    Joined:
    Aug 12, 2010

    Aug 12, 2010
    141
    45
    43
    I had this problem as well - solved it with version 2.2.1 of the Gmail app!
     
  9. erezel

    erezel Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    May 14, 2011

    May 14, 2011
    2
    3
    6
    You might wanna try deactivating and then reactivating your facebook account. apperantly, their new version for android is getting every push software stuck, except for gmail...
    it worked for me with yahoo! mail
     

Share This Page

Loading...