1. Are you ready for the Galaxy S20? Here is everything we know so far!

easiest way to root?

Discussion in 'Android Devices' started by kudoboi, May 16, 2011.

  1. kudoboi

    kudoboi Newbie
    Thread Starter

    ?? any1
     



    1. Download the Forums for Android™ app!


      Download

       
  2. SB13X

    SB13X Android Expert

    Go here:

    19/Nov r14: VISIONary + one click root - Android @ MoDaCo
    1. Download Visionary and install to your phone.
    2. Select the Tick Box next to Run Visionary.sh
    3. Click Temproot.
    4. Once complete check to see if you have the SuperUser app in your app drawer.
    5. If you do open up Visionary again and click Attempt Permroot.
    6. Wait for the phone to reboot and voila.

    This is for FroYo however if you have upgraded to GB let me know and I'll get a Gingerbreak guide up.

    That said just a little look at the top of the screen would have revealed this:http://androidforums.com/desire-hd-...iversal-root-visionary-method-theunlockr.html
     
  3. kudoboi

    kudoboi Newbie
    Thread Starter

    will it wipe out all my apps?
    also do i need to go to 1.32 to update?
     
  4. D-U-R-X

    D-U-R-X turbo drinker

    You probably would need to downgrade to 1.32. If your phone is carrier branded, then you may also need to create a goldcard in order to downgrade to 1.32 (I had to do this, as I had an Orange UK DHD). What ROM are you running? 2.2 / 2.2.1?
     
  5. SB13X

    SB13X Android Expert

    As said you will need to downgrade. The rooting process doesnt wipe apps however downgrading might...
     
  6. Xyro

    Xyro 4 8 15 16 23 42
    Moderator

    Downgrading definitely will.
     
  7. SB13X

    SB13X Android Expert

    There ya go...;)
     
  8. Hadi HTC DHD

    Hadi HTC DHD Lurker

    I Have upgraded to GB, any Idea how i can root it now?? never done rooting it would be nice if it explain step by step :) thanks .
     
  9. D-U-R-X

    D-U-R-X turbo drinker

    Firstly - read EVERYTHING you can about this before attempting. It's not as hard as it seems, but you don't want to brick your phone! I was looking in to it for a couple of weeks, before finally going for it.

    I've been told that only TEMP ROOT works on Gingerbread. If you want to PERM ROOT, you'll need to do some, if not all, of the following things:


    Create a goldcard - this is so that you can trick your phone in to thinking that it is non-carrier-branded - this is optional, not needed if you have a non-branded phone

    Downgrade your phone to version 1.32

    Install Visionary + click temp root (not forgetting to select remember on reboot - or something like that)

    Once you have temp, click perm root (not forgetting to select yes to superuser access request)

    Download Radio S-Off (and ENG S-Off if you want to) tools from the internet and run the programs.

    Download ROM Manager from the market and install it, so you can get clockworkmod.

    Here is a useful site that goes through the process fully:
    [GUIDE] How to root Desire HD (DHD) install h-boot (S-Off) and Clockwork recovery - xda-developers

    When I did this, I had issues creating a goldcard (see my thread - http://androidforums.com/desire-hd-...0-dhd-downgrading-before-rooting-problem.html).

    If you need more info, feel free to ask!! :D
     
  10. Jimsan

    Jimsan Lurker

    I tried downgrading from 2.36 to 1.32 using the method above. It got all the way to the bootloader but nothing happened from there. Rebooted and checked version number and I'm still on 2.36

    Tried process again and when entering the command ./data/local/tmp/GingerBreak i get the error 'cannot copy boomsh : Permission denied'

    I figured I'd try on here to see if anyone has encountered this before and knows of a solution before I have to register on the other forum and hope I get a reply on there.

    Apologies if this is a daft question, i'm totally new to all this
     
  11. Hadi HTC DHD

    Hadi HTC DHD Lurker

    i have got the same problem, I have been looking around to find answer, if you got something plz let me know, thanks.
     
  12. Jimsan

    Jimsan Lurker

    I've found the fix. Run the following then run gingerbreak again

    adb shell
    rm /data/local/tmp/boomsh

    adb shell
    rm /data/local/tmp/sh
     
  13. dijon

    dijon Member

    OK, I had this the other day when I was downgrading my GB to 1.32, here's how I got round it.

    Firstly, kill the adb process on your computer & reboot your phone.

    From Terminal Window:

    adb shell rm /data/local/tmp/*
    adb shell rmdir /data/local/tmp
    adb shell mkdir /data/local/tmp

    after that, I rebooted the phone, and when back up I tried the push statements again:

    adb push misc_version /data/local/tmp
    adb push GingerBreak /data/local/tmp
    adb shell chmod 777 /data/local/tmp/misc_version
    adb shell chmod 777 /data/local/tmp/GingerBreak
    adb shell
    $ /data/local/tmp/GingerBreak

    Worked for me..
     
    andgzm likes this.
  14. JustByZero

    JustByZero Newbie

    I'm not sure if my phone is branded with vodafone or not, I don't think it is as I can put any SIM in my phone without a problem, and there doesn't seem to be any VF applications pre-installed on my phone
     

HTC Desire HD Forum

The HTC Desire HD release date was October 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 768GB RAM, Snapdragon S2 processor, and 1230mAh battery.

October 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...