1. Are you ready for the Galaxy S20? Here is everything we know so far!

Easy guide to update to Galaxo or GAOSP!

Discussion in 'Android Devices' started by DaSchmarotzer, May 2, 2010.

  1. DaSchmarotzer

    DaSchmarotzer Blame it on me
    Thread Starter

    There are other ways to install the custom recovery, but this method probably is the most used. If you want to use the Drakaz application, you will have to root your phone first using the easyroot method by Drakaz. The easiest way to get the custom recovery would be to Odin the JC6 firmware with integrated recovery, but you shouldn't mess with any of that if you don't really know what you are doing.

    The guide is now updated for Galaxo or GAOSP Beta 3!

    Ladies and gentlemen, here's a complete idiot's guide to updating to Galaxo/Gaosp! It seems long and complicated, but it really isn't. I was using the JC6 firmware on my phone before updating to Galaxo, but you don't need any specific firmware. You don't ever need to use an external SD card during this process.


    **I suggest downloading and saving every folder directly on your desktop, so everything is easy to find.**

    This guide takes for granted that you can access your phone via USB from your computer. If the device isn't detected properly, you should install Samsung New PC Studio (NPS). You don't need to use the software at all, but it will install the correct drivers. To access your phone from your PC, plug it in and then move the notification bar down, select the USB notification and then select "Mount".

    STEP 1 (ADB drivers):

    You need to install the ADB drivers, which mean Android Debug Bridge. You’ll need those to operate the Android SDK correctly. You don’t understand what I’m saying? No worries, just follow the tutorial, and if you have a problem, post your question saying what went wrong and what happened.

    Download the drivers here: MEGAUPLOAD - The leading online storage and file delivery service

    I’m using Windows 7 (32 bits), so maybe the steps aren’t exactly the same for other versions of Windows.

    Open your Galaxy, go into the Settings, select Applications, then Development, then tick USB debugging. Now plug it into your computer. Open up the device manager.


    You should see an unknown device with a yellow exclamation mark. Right-click it and select update drivers.


    Select Browse my computer.


    Select Let me pick from a list of device drivers on my computer.


    If you see a list of devices and you have to pick one, don’t select any and just click next again. Then, click “Have Disk”. Browse to the “usb_driver” folder, then select the x86 folder (which means 32-bits) and in it select “android_usb.inf". If you have a 64 bits version of Windows, instead of going into the x86 folder, get the “android_usb.inf” that is in the amd64 folder.

    Your device should now have the required drivers. More on that later, but for now just stick to the guide. If none of the three "android_usb.inf" seem to be working, you should try this one, it might solve your problem.

    STEP 2 (Placing the Recovery, Update and Google Apps):

    You’re going to need those files:

    The Android SDK: Download the Android SDK | Android Developers

    The latest custom recovery (used to apply the update, among other stuff)

    Galaxo or GAOSP Beta 3

    The GAOSP Google apps (pick the light or ultra light) (also known as Gapps) or the Galaxo Google Apps.

    I suggest saving all of those to the same place, to avoid confusion.
    Start by placing the “android-sdk-windows” folder to the root of your C drive. The place doesn’t really matter, but you’ll have to type the path into a command prompt later, so if you follow my example, place it in the root of your C drive.

    Extract “RECOVERY_version number.zip”. You now have “recovery.img” and “RECTOOLS.tar.gz”. Take “recovery.img” and place it in the “tools” folder of the “android-sdk-windows” folder, which should now be located right into your C drive.

    Mount your phone, you’re going to be placing stuff on it.

    Take “GAOSP-2-PUBLIC-BETA-3.zip" or "Galaxo_1.6.3.4.zip”, “Gapps_light.zip” and “RECTOOLS.tar.gz” (the last one was in RECOVERY_version numbers.zip), and place them on the internal SD card of your phone. I placed the three of those in no folders, directly on the phone, just in case. Alright!

    STEP 3 (Recovery and update):

    Power off your phone. It should still be connected via USB.

    Open a Command Prompt (search for “cmd” in the start menu, and click on “cmd.exe”).


    Type “cd C:\android-sdk-windows\tools”, of course without the “ ”. If you didn’t put the Android SDK on the root of your C drive, you’ll have to modify this line and put the actual path. Press enter.

    Now type “fastboot flash recovery recovery.img” without pressing enter just yet.


    Boot your phone into fastboot mode, do so by pressing and holding both the Call button (bottom left) and Power button (bottom right) at the same time, until you see on the phone that you are in fastboot mode. You’ll have about 15 seconds to press enter on the command prompt on the computer. If it works, you’ll see something else than “waiting for device” appear in the command prompt.

    Fastboot on the phone (picture took by Chronodekar and his brother, thanks!):

    When I tried to do so, it wouldn’t do anything. It would wait for the device, then my Galaxy would boot normally. To solve this, open the device manager on your computer and turn the Galaxy off again. You are going to boot into fastboot mode again, but you’ll have about 15 seconds to check the device manager (open it beforehand), and see if there’s a new device that needs drivers. Mine was something like Android 1.0 (with a yellow exclamation mark, meaning that there are no drivers). You’ll do the exact same thing as you did with the ADB driver, using the exact same driver (right click the unknown device, update the driver, select from a list, next, Have disk, Browser, then find the same “android_usb.inf”. Check the beginning of the guide if you don’t remember what to do.) You'll need to do this during the 15 seconds the Android 1.0 will appear, so you have to be quick.

    During the process, on the phone (picture took by Chronodekar and his bro):

    Success (command prompt):

    If it worked, well great, now power off your phone again. Boot it again, but this time in recovery mode. Do so by holding the “Lower volume button”, the Call button and the power button. If it works, you’ll see a green menu with lots of choices. You’re almost done.


    Go down and select “Nandroid backup”. It will take a short while but it sure is worth it. You'll have to press the Home button to confirm, just follow the instructions on-screen.

    Now, select “Wipe data/Factory reset”. It’s going to erase all your applications and settings, but it shouldn’t touch anything saved on your SD card (such as pictures, music, saves, etc). It’s important to do so, else the phone will not work properly.

    After that, select "Apply any zip". Now on the list find either the GAOSP.zip file or the Galaxo.zip file, depending on your choice. Right after that, select "fix package permissions", then "apply any zip" again but this time pick the Gapps you previously downloaded, which will restore the Google Applications on your phone. I do not recommend to wipe again at this point, it seems pointless to me.

    You can now reboot and enjoy Galaxo or GAOSP!

    **Now if you want to switch between GAOSP and Galaxo or if you want to change version of GAOSP or Galaxo, you simply have to put the new .zip on your phone, boot into recovery, wipe, apply the zip, fix package permissions, apply the Gapps and you're good to go. The "hard" part is to install the custom recovery for the first time.**

    If the phone gets stuck on the Android screen, wait for about 10 minutes, and then if it's still stuck, pull out the battery and boot again. If it still doesn't work, you can try again, or boot into recovery and try to apply Gaosp.zip or Galaxo.zip again, rebooting, and then fix package permissions and apply the Google apps.


    Have questions, comments? Post them here!

    You want to thank me? Screw me, donate some money to DRAKAZ! He did all the hard stuff! :D

    gsmtronic, LeetHero, karkaza and 44 others like this.
  2. beitinsw

    beitinsw Member

    Point of clarification: Samsung.tar looks like I7500XEJC6-PDA-CL209906.tar inside the "JC6".tar.gz file. So extract the "PDA.tar" file and rename it Samsung.tar.

    If your Restore G.Apps takes 1-2 seconds it didn't really work.
  3. DaSchmarotzer

    DaSchmarotzer Blame it on me
    Thread Starter

    For the Google Apps, it's true, mine worked on the first try and took some time.

    As for the Samsung.tar, if you download the firmware with the link I posted, inside of "I7500XEJC6.zip", there's only SAMSUNG.tar, ready to be used.
  4. beitinsw

    beitinsw Member

    Ah, well I used the JC6 I'd used ages ago. :)
  5. angeamon

    angeamon Well-Known Member

    great idiots guide to flashing a galaxo rom. May be the best guide ever.

    Can one of the moderators sticky this guide as it ll be of great use to a noobie....
  6. Hark

    Hark Well-Known Member

    Thanks so much for this. I've not tried Galaxo yet despite having my Galaxy for months, but this should make it much easier. I haven't really understood what to do (or even exactly what Galaxo, Recovery, etc all do).

    I have been afraid to ask for a guide like this as I know someone would go "read the FAQ". I'm not a newb with the phone or computers, I just find some of this Android stuff a bit confusing.
  7. kresten

    kresten Newbie

    should i flash to jc6 before flashing galaxo ?
  8. inFECT

    inFECT Android Enthusiast

    Thanks to the op for the permission to post it on androidwiki.

    Very good job!
  9. Snazzy

    Snazzy Android Enthusiast

    Perfect. Thank you DaSchmarotzer and Drakaz!
  10. mrqs

    mrqs Android Expert

    might wanna add a comment for 64 bit os users
  11. Hark

    Hark Well-Known Member

  12. denial86

    denial86 Newbie

    hmm I really cant seem to get past the waiting for device screen... did all the steps you said but the android 1.0 figure kept coming back even if I kept installing the driver all the time... weird :S
  13. DaSchmarotzer

    DaSchmarotzer Blame it on me
    Thread Starter

    Just to be sure, did you install the driver during the 15 seconds time lapse? I don't know if it's necessary, but that's what I did, and I had to do it quick. (You can only see Android 1.0 during those 15 secs, right?)
  14. Snazzy

    Snazzy Android Enthusiast

    Yup keep at it. Remember that you can just hit "UP ARROW" in the CMD box to repeat the last command so you do not have to retype that long string or paste it. Alternate installing Android 1.0 devices as they appear and hitting that ENTER key on the CMD command. Eventually you will get the OKAY message but it will take a few attempts and many lengthy reboots.
  15. Rastaman-FB

    Rastaman-FB Extreme Android User

    you have to be like a ninja. i was 1st :p
  16. denial86

    denial86 Newbie

    Well I always seem to run out of time. I kinda figured it had to be in those 15 seconds, but nevertheless it seems like thats almost impossible :S
  17. Haltemien

    Haltemien Newbie

    What I did was: During the 15 sec I had time to find the android 1.0 in devicemanagement and access it before it vanished. Once I had clicked on it and had it open, I had all the time in the world to install the drivers that was needed.

    Edit: sorry about the "til". Fixed it. The phone replaces words from time to time
  18. mrqs

    mrqs Android Expert

  19. denial86

    denial86 Newbie

    alright, great got it work now. Had to install the driver in the 15 second time stamp, which worked in the dying moment ;). Anyways flying through now with 614 mhz... seriously feels like a new phone! Thanks for the great guide!
  20. kyle.grealis

    kyle.grealis Lurker

    don't kill me because i'm a newbie :eek:, but i had a few questions:

    after successfully rooting my wife's g1, i wanted to update to galaxo on my i7500. i bought it already rooted (baseband XXII5, kernel 2.6.27, firmware 1.5, and says "galaxy with MCR 1.2). before i update to galaxo, is it still necessary for me to flash a new recovery image or is that already done for me? :thinking:

    what steps should i take from here, besides the new update.zip??? please help a new guy break into the android universe. (you can email me at kyle.grealis@gmail.com also)

  21. Snazzy

    Snazzy Android Enthusiast

    Start from the top and complete every step of this great guide.
  22. cma353

    cma353 Newbie

    Thanks for the instructions!

    My Galaxy phone is in version of "I7500_XEJC6_XEJC6_SERJC6_Russia_SER" and I want to move to galaxo.

    I got problem from the step Wipe data/Factory reset.. and the apply update.zip. It has no effect or output "Installation failure!" after pressing the Home button.

  23. Rastaman-FB

    Rastaman-FB Extreme Android User

    redownload the update.zip
    put it in the tools folder of your android sdk
    go into recovery on the phone
    connect to the device
    delete the update.zip currently on the phone (adb shell rm /sdcard/update.zip)
    push the update.zip via adb instead of using mass storage (adb push update.zip /sdcard/
    fix package permissions
    apply update.zip
    restore gapps

    I know it seems alot but you shouldnt be having a problem really so doing it this way is going to rule out alot of things that could potentially cause an issue
  24. ryko

    ryko Well-Known Member

    Hi, have been stuck for a day or two on apply sdcard:update zip I get this message.....
    Finding update package...
    Opening update package...
    E:Can't open /sdcard/update.zip
    (No such file or directory)
    Installation aborted.
    I've tried putting a dummy update .zip file on the sd card and instead of no such file it just says "Bad"
    I have reformatted the card and followed the very clear instructions to the letter.
    On the computer the card's letter is G and not E but I think that it is just windows giving that letter. I have tried galaxo 1.6.3. but the same thing happened any idea's anyone :thinking:
    edit: I have just noticed although I installed JC6 the Baseband version shows I17500XXIJ1 could this be the problem ?
  25. Snazzy

    Snazzy Android Enthusiast

    Are you putting the file on the removable SD card or the internal memory poorly called \sdcard\ ? The latter is correct.

Share This Page