1. Check out our app, Forums for Android! Download and leave feedback here!

Eclipse goes dead for 10..15 seconds...

Discussion in 'Application Development' started by mmoser, Jul 28, 2010.

  1. mmoser

    mmoser Active Member
    Thread Starter
    16

    Jun 28, 2010
    26
    1
    16
    I am using Eclipse to develop my first android program. One things that starts driving me nuts is, that whenever I type a dot on one of androids types (e.g. TextView) Eclipse goes dead for >10 seconds apparently digging up the possible code completions. E.g. if I want to write

    Code (Text):
    1. TextView tv = new TextView(this);
    2. tv.setText("bla bla");
    3.  
    then in the moment when I write the dot in the second line:
    Code (Text):
    1. ...
    2. tv[B][U].[/U][/B]
    Eclipse blocks to bring up a TextView's methods.

    I am using eclipse in my everyday work as well and sometimes - when one is working in HUGE projects with hundreds of classes - this code completion lookup may take a second or two but here I am essentially still at the "hello world" level and I am seeing delays that are an order of magnitude longer.

    Are others seeing this as well? Why does this take so long? Is there anything one can do or configure to speed this up? I have integrated the Android SDK into Eclipse 3.6 (Helios). I am using the Sun/Oracle JDK 1.6.0 update 21.

    Michael
     

    Advertisement

  2. markb

    markb Well-Known Member
    63

    Sep 14, 2009
    148
    26
    63
    Software Developer (Java, C, Web, Unix)
    Birmingham, UK
    Hi mmoser

    I haven't had the problem with android (yet). I'm using 3.4 on Linux.
    I've had it now and again at work for non-Android development.

    But I have recently upgraded to Helios at work, and found it to be frustratingly slow at times. Sometimes I suspect it's going over the network (and at work it goes through a proxy which is pretty slow).

    I'm afraid I don't know how to speed it up. But if it's really annoying you every time you type a "." then you could try increasing the auto-activation delay. (Windows -> Preferences -> Java -> Content Assist). At least with a longer delay you won't be interrupted every time you type a ".", but it will still work if you wait a little longer.

    Mark
     
  3. jonbonazza

    jonbonazza Well-Known Member
    163

    Jul 13, 2010
    1,934
    458
    163
    Male
    I have had it a few times. What I did was get rid of the "properties" window in the eclipse IDE while typing the xml manually. I am not sure what causes it to happen as it only happens every once in a while to me, and hasn't happened in a long time, but that is the only "fix" I could find.
     

Share This Page

Loading...