1. Download our Official Android App: Forums for Android!

Support Email constantly downloading data

Discussion in 'Android Devices' started by santy7, Apr 24, 2012.

  1. santy7

    santy7 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 24, 2012

    Apr 24, 2012
    1
    0
    5
    I just upgraded my Samsung Galaxy S2 to ICS (XEU version) and since then the Android email application has been constantly downloading data in the background. It's used 500mb in 24 hours, although it's only downloaded a few hundred kb of emails.

    Samsung want me to take it to a service centre to flash ICS off and re-install it, but the nearest place is miles away. Any suggestions how I can stop this because it's now gone over my data cap on my phone contract? I've no idea how to uninstall ICS myself!
     

    Advertisement

  2. alex01

    alex01 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    121
    Joined:
    Jun 13, 2010

    Jun 13, 2010
    121
    2
    36
    Male
    Herts. UK
    i got a shock text from t-mobile this morning saying that my data usage has reached 80%.
    when i looked on my phone it said that i have used 316mb between 17-23 may, the email app has used 290mb of this.
    there are 3 email accounts configured, the same of which have been for about year and the usage of which is very low with no attachments. this is the first time i have had this problem. i've noticed that the email app has frozen several times since upgrade to ics, never having any problems previous to this.
    this must be a problem with the app itself. i've had to turn off my data in fear of the cost that may incurr if not already done.
    just a note that the data usage of the email app is:

    foreground 5.18mb
    background 285mb
     
  3. Matilda32

    Matilda32 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 23, 2012

    May 23, 2012
    1
    0
    5
    I'm having the same problem. To stop the background data using up all my data allowance I had to "restrict background data" (settings > data usage > email > tick the box that says "restrict background data" - it might want you to set a limit first, which you do by just dragging the line to where you want it on the graph).

    This is not a fix though, as I cannot get my emails when i am not connected to wi-fi, and my wi-fi usage is now going through the roof! Alright when I'm using someone elses, but my ISP might have something to say about it soon!

    Like you, I really need a fix - just my opinion but I think it's a really poor show from Samsung to have let something like this slip through. And I much preferred the old Gingerbread anyway! grrrr.

    Anyone else able to help?
     
  4. alex01

    alex01 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    121
    Joined:
    Jun 13, 2010

    Jun 13, 2010
    121
    2
    36
    Male
    Herts. UK
    i never had this problem with gingerbread and was also happy with it. I think this is pureley an android problem - doubt if samsung have any control over applications.
     
  5. anotheran

    anotheran Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 7, 2012

    May 7, 2012
    4
    0
    5
    I have the same problem. I turn off Account Sync when I don't need it.
     
  6. alex01

    alex01 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    121
    Joined:
    Jun 13, 2010

    Jun 13, 2010
    121
    2
    36
    Male
    Herts. UK
    after seeing that others are expeiencing same problem and almost all my data was used up only a couple of days into the month, i contacted t-mobile to tell them that this situation was not my fault. they told me that warning text from them was in error, but the usage amount is still shown under data usage on my phone. not sure what's going on.
     
  7. Dekkit

    Dekkit Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    1
    0
    5
    I had the same issue and in my searching on the internet found a few articles that gave me a few ideas that seemed to work.

    Basically it seems the ICS update corrupted the mail settings. I have a samsung galaxy s2 and did the following (after a few days of testing it seems to have been fixed)

    Try the following (after backing up your email and email settings of course):

    - goto setup
    - goto apps
    - find and select the email app amongst the list (its somewhere around the middle)
    - select to force stop the default email
    - select to disable default email

    - reboot the phone (to clear out any junk in the memory)

    - after it reboots, goto setup
    - goto apps (scroll down to the end of the list to find disabled apps)
    - select to install the default email app

    - setup your pop accounts (again)
    - note there is a setting to sync email with the server over x days (i selected 1 day to be safe, but it may not matter).


    note you will lose all your emails and email settings, so it might be worth taking a few screen shots or jotting it down on paper first (you have been warned).

    Don't forget to check re-enable background data for email if you've turned it off previously because your email data was going nuts.

    hope it works for you, but as at day 3 it seems to now be working fine for me (the way it should!)
     
  8. alex01

    alex01 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    121
    Joined:
    Jun 13, 2010

    Jun 13, 2010
    121
    2
    36
    Male
    Herts. UK
    i'll give your suggestion a try, but do you think it could be a fix because you're just telling it to check for emails once a day in stead of hourly etc.?
    i've read that there is genuinely a bug in ics stock email app.
     

Share This Page

Loading...