1. Are you ready for the Galaxy S20? Here is everything we know so far!

Emulator process is immediately killed in Android Studio

Discussion in 'Android Development' started by Nuno Feliciano, May 30, 2021.

  1. Nuno Feliciano

    Thread Starter

    Hi,

    I have installed Android Studio in a new laptop, and now I cannot get AVD to work. When I try to run a device, I get a message
    Code (Text):
    1. "The emulator process for AVD <AVD-name> was killed"
    immediately after launching the device. I have tried with API 29 and 30. I have installed the following tools
    [​IMG]

    If I try to run the emulator by command line I get:

    Code (Text):
    1. C:\Users\Nuno\AppData\Local\Android\Sdk\emulator>emulator.exe -avd Nexus_6_API_30
    2. emulator: Android emulator version 30.6.5.0 (build_id 7324830) (CL:N/A)
    3. handleCpuAcceleration: feature check for hvf
    4. added library vulkan-1.dll
    5. Failed to open /qemu.conf, err: 2
    6. HAX is working and emulator runs in fast virt mode.
    7. emulator: INFO: GrpcServices.cpp:315: Started GRPC server at 127.0.0.1:8554, security: Local
    8. emulator: INFO: EmulatorAdvertisement.cpp:93: Advertising in: C:\Users\Nuno\AppData\Local\Temp\avd\running\pid_11172.ini
    9. Failed to sync vcpu reg
    10. Failed to sync vcpu reg
    11. Failed to sync vcpu reg
    12. Failed to sync vcpu reg
    13. Failed to sync vcpu reg
    14. Failed to sync vcpu reg
    15. Failed to sync vcpu reg
    16. Failed to sync vcpu reg
    17. Failed to sync vcpu reg
    18. Failed to sync vcpu reg
    19. Failed to sync vcpu reg
    20. Failed to sync vcpu reg
    21. Failed to sync vcpu reg
    22. C:\Users\Nuno\AppData\Local\Android\Sdk\emulator\qemu\windows-x86_64\qemu-system-x86_64.exe: error while loading state for instance 0x0 of device 'goldfish_pipe'
    23. Failed to sync vcpu reg
    24. Failed to sync vcpu reg
    25. Failed to sync vcpu reg
    26. Failed to sync vcpu reg
    27. deleteSnapshot: for default_boot
    28. VCPU shutdown request
    29. Failed to sync vcpu reg
    30. Failed to sync vcpu reg
    31. Failed to sync vcpu reg
    32. Failed to sync vcpu reg
    33. emulator: Saving state on exit with session uptime 25 ms
    34. VCPU shutdown request
    I think everything is the same as what I had in the other laptop, expect in this one I am using HAXM. But if I unistall HAXM, I cannot launch a device in AVD, and I have to install it again. I don't know if it is related to the issue.

    Any ideas?

    Thanks, Nuno
     



    1. Download the Forums for Android™ app!


      Download

       
Loading...
Similar Threads - Emulator process immediately
  1. Theappdev
    Replies:
    5
    Views:
    546
  2. fra8995
    Replies:
    0
    Views:
    854
  3. AndroMan2021
    Replies:
    0
    Views:
    720
  4. Kingdr
    Replies:
    0
    Views:
    728
  5. Ginjitzu
    Replies:
    0
    Views:
    680
  6. etienne langevin
    Replies:
    0
    Views:
    264
  7. Balos1234
    Replies:
    0
    Views:
    786
  8. claytoncarney
    Replies:
    0
    Views:
    1,041
  9. Fabrizio Ferrari
    Replies:
    0
    Views:
    1,089
  10. imughal
    Replies:
    0
    Views:
    11,591

Share This Page

Loading...