1. Are you ready for the Galaxy S20? Here is everything we know so far!

Eris stops responding after reboot!

Discussion in 'Android Devices' started by kgunnIT, Jan 6, 2010.

  1. kgunnIT

    kgunnIT Newbie
    Thread Starter

    First off, I apologize if I start a new thread when one already exists. I tried searching, but couldn't find anything related to my issue.

    The issue:

    When I have to restart my phone, all apps stop responding, including phone, google apps, everything. I can't make calls, I don't have a signal, nothing works really. The solution: uninstall recently installed applications, and that fixes it.

    However, I wonder if there is something else going on causing this. The reason: Yesterday I installed Backgrounds (a popular 4-5 star application from Android Market). I had to reboot my phone (locked up), when I did, nothing was responding, got messages like acore, gapps, and other apps stopped unexpectedly. I removed Backgrounds, restarted again, and everything worked. My wife uses Backgrounds, but her phone doesn't stop working when she has to restart. Why is this happening on my phone? Is there another app causing interference?

  2. Podivin

    Podivin Android Expert

    Yep, I suspect that Backgrounds is conflicting with some other app on your phone, as opposed to conflicting with the phone itself. Compare the apps on your phone to the apps on your wife's phone to see what's different (hopefully that list isn't too long). On your phone uninstall the apps that are different (especially if you've got another one that does something with backgrounds - if Backgrounds does what the name implies that it does). Reinstall Backgrounds on your phone, then start bringing the 'different' apps one by one and rebooting between each install. At some point you're phone will stop responding and you'll know which app is causing the problem. At that point your probably have to decide which one you want the most, and uninstall the other one.
  3. kgunnIT

    kgunnIT Newbie
    Thread Starter

    I was afraid that would be the only way to get it working. I started removing apps and found the following to cause the phone to stop working:

    Wifi Analyzer
    Skype Lite Beta
    Layar Reality Browser
    Google Voice

    If I install any of the above apps and restart my phone, it stops working. As stated, this started when I download and install Backgrounds (a timed background changer as well as offers a variety of backgrounds, I haven't used it yet).

    I find it hard to believe it is interferring with all of these apps, since these apps have nothing to do with background wallpapers.
  4. fahertyps

    fahertyps Newbie

    Really frustrating I know. I've taken to rebooting after every 1 or 2 new installs or even updates from the Market. My lesson learned is from having to do a hard reset because an install had "bricked" my phone. Even uninstalling them would not allow it to work.
  5. gtpdjw

    gtpdjw Android Enthusiast

    did you reboot the phone while it was connected to the pc if so that was the problem disconnected or unmount the phone before rebooting
  6. gtpdjw

    gtpdjw Android Enthusiast

    It has happened to me twice now so I know
  7. IzelTokatl

    IzelTokatl Android Enthusiast

    Hello, I had the same issue, thought it was the phone so I had verizon send me a new one, just got all my apps installed and rebooted and the phoen stopped working. These are the programs I have in common with the above user:

    (I removed each one then rebooted after uninstall)
    Wifi Analyzer (uninstalled, no resolve)
    Skype Lite Beta (uninstalled, no resolve)
    Yelp (uninstalled, no resolve)
    Backgrounds (uninstalled, everything works!)

    I installed Wifi Analyzer, Skype and Yelp back (no backgrounds) and again force closing processes.

    there must be some cross issue with these for apps? i'll use a combination and see whats up.
  8. erisuser1

    erisuser1 Android Expert

    I'm using Wifi Analyzer without any problems whatsoever - don't use any of those other apps.

    But, I will say that I did once experience a weird problem (on PCs in a network) that finally resolved itself as being an interaction between software from three separate vendors - so... test away!

    BTW, all three of them said that I should contact the other two vendors. :mad:

  9. gtpdjw

    gtpdjw Android Enthusiast

    I think that it's not a app problem I think it's having the eris connected to the pc that caused the problem I have tested it 3 times to be sure I did it with the phone mounted and it had the problem on reboot did a hard rest and tried it without the phone connected and it worked fine after reboot did it again with the phone connected but unmounted and it worked fine after reboot
  10. gtpdjw

    gtpdjw Android Enthusiast

    It fixed my problem, so I guess there are two different issues going on
  11. erisuser1

    erisuser1 Android Expert

    Neither the OP, nor any of the other posters ever mentioned being connected to a PC.

    Glad you got your issue straightened out.


    PS - My laptop won't boot if I have the Eris plugged in via USB - but that's a different set of circumstances as well.
  12. falltime

    falltime Well-Known Member

    There was another thread on this - I dont think it is any specific app - I think the problem is that the Eris seems to have some sort of hard limit on the total number of apps - I never counted (and not even sure what to count - as it seems widgets are affected too) but I have a ton (125 icons) and if I install one more I get the same symptoms; but if I unisntall one app and then install new app - no problem, and it doesnt seem to be related to memory because I have tried the same with different sizes....again it seems like there is a hard limit on the total NUMBER of apps you can install.

    Check it for yourself and then confirm or refute - this I think is valuable info for the community if I'm correct.
  13. IzelTokatl

    IzelTokatl Android Enthusiast

    I've been testing without a cable plugged in and still have the force close processes on boot. I'm not done testing all the combinations, but I think Falltime may be on to something, as I've had some odd combinations work and not work.
  14. IzelTokatl

    IzelTokatl Android Enthusiast

    *SOLVED* at least my issue.

    So, falltime is correct.

    There must be an app/memory limit on the Eris (and apparently on the Hero).

    I was testing various combination's of Wifi Analyzer, Skype Lite Beta, Yelp, Backgrounds and some odd combination's were working and not working. So I figured why not try installing a larger app (weather.com app) and see how it played out. Apparently there is a memory issues based on how much free space is left after so many apps being installed into the ram(duh, but I wasn't originally keeping track). I doubt its an APP count issue, as I simply removed one 3MB app, then installed Wifi, Skype, Yelp and Backgrounds which combined dont equal the 3MB, and restarted and everything works fine.

    Obvious Point: When total memory used gets around 80%+ of total RAM, processes start to die on reboot. they must compete for loading space and fail if they don't get it.

    side note: I have 94 apps installed using 74% memory.
  15. erisuser1

    erisuser1 Android Expert

    As it turns out, I unpacked one of the RUU updates (the files are unpacked into temporary folders underneath C:\Documents and Settings\---username---\Local Settings\Temp when the installer starts to run), and then found this tutorial on how to further unpack the boot.img and recovery.img files.

    Poking around in the "init.rc" file in the ramdisk that the boot process loads, i stumbled across these two curious sections:

    # Define the oom_adj values for the classes of processes that can be
    # killed by the kernel. These are used in ActivityManagerService.
    setprop ro.FOREGROUND_APP_ADJ 0
    setprop ro.VISIBLE_APP_ADJ 1
    setprop ro.SECONDARY_SERVER_ADJ 2
    setprop ro.HOME_APP_ADJ 4
    setprop ro.HIDDEN_APP_MIN_ADJ 7
    setprop ro.CONTENT_PROVIDER_ADJ 14
    setprop ro.EMPTY_APP_ADJ 15

    # Define the memory thresholds at which the above process classes will
    # be killed. These numbers are in pages (4k).
    setprop ro.FOREGROUND_APP_MEM 1536
    setprop ro.VISIBLE_APP_MEM 2048
    setprop ro.SECONDARY_SERVER_MEM 4096
    setprop ro.HOME_APP_MEM 4096
    setprop ro.HIDDEN_APP_MEM 5120
    setprop ro.CONTENT_PROVIDER_MEM 5632
    setprop ro.EMPTY_APP_MEM 6144

    It made me curious, so I did a little digging and found this explanation about how the OS "starts to get panicky" when memory gets low.

    So, you surmise correctly - but the behavior is actually fairly complicated, as it divides processes into lots of different classes, and has separate count and memory quotas for each of the classes.

    The only way to change any of this would be to "get root" somehow.

    However, I will note that if I leave the Eris running for a long time between boots, the amount of free memory reported by ATM seems to dwindle, even when I kill off all apps.

    Maybe the moral of the story - since it is the only thing we can control at the moment - is to be cautious about installing a lot of apps, especially those that launch services at boot, and to reboot the phone occasionally.

  16. paleodust

    paleodust Android Expert

    Yeah. I've run into the same issue with my Eris. I hope there's a solution on its way...
  17. kgunnIT

    kgunnIT Newbie
    Thread Starter

    Unfortunately, I had to do a hard reset. My phone would reboot, stay on for less than a mintue, then reboot itself automatically. I wasn't able to keep the phone on long enough to remove some apps.

    Now, my phone works with out any problems. I could not reinstall all of the apps that I previously had (some were updated and removed from < 2.0 market). However, the apps that I thought were causing the problems in fact are not.

    I think installing too many apps (using up most of your phone memory) is the likely cause of this issue that I was experiencing. This is one reason why having the ability to install apps to the SD Card could be useful.

    If you reboot your phone and everything stops responding, uninstall the last app(s) that you installed. Then go to SD Card and Phone Memory, observe your phone memory. If it is low (not sure what the limit is), try removing apps you don't use very often. As others have stated, low phone memory could prevent phone from booting properly.

    Thanks everyone for your input and help on this issue.
  18. dk7pdx

    dk7pdx Lurker

    I had the same problem and had to hard reset it my Eris twice (which was really annoying after getting all the apps and settings where I wanted them). The third time it happened I was able to find a couple of threads that helped. One mentioned that they had removed a few apps plus Layar (which was the only one we had in common). I removed Layar and that fixed my problems. I have since been able to turn the phone on and off with no service stallout.
  19. paleodust

    paleodust Android Expert

    Does Layar specifically cause problems or is it just a matter of freeing up enough space for the device to function properly?
  20. pkopalek

    pkopalek Android Expert

    Installing too many apps. I had 108 Apps at some point. Reboot. FAIL! Had to use ES File Manager (or other uninstall tool) to uninstall a few apps. A few reboots later, I was fine.

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page